Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
TITANIC_131

Performance issues update 0.7.2

7 comments in this topic

Recommended Posts

Players
29 posts
5,321 battles

Since the new update I have been having major problems with the games performance to a degree that just made the game borderline unplayable. I wondered If any one else has any problems with the game since update 0.7.2.

 

For me the major problems are extreme lag when using the games UI and FPS dropps down to as low as 30 (I usually have a FPS of 60 because my monitor is limiting my FPS output) aside from that I also have garbage ping even though my WIFI is completely fine I have been getting a ping of around 400 ms :/ On top of that my computer hardware   is complete overkill for this game so there is absolutely no way I should be having these problems.

 

My current components:

 

r9 390

i5 5600

16 GB DDR 4 RAM

some cheap 480 GB SSD

 


 

530627322.png

Edited by TITANIC_131
added some additional info

Share this post


Link to post
Share on other sites
[FUSO]
Players
73 posts
6,501 battles

Well i had major issues with 7.1 But since 7.2 it has increased a bit.

 

but one of my clan has the same problems as you

  • Cool 1

Share this post


Link to post
Share on other sites
[P-W-C]
Players
846 posts
12,737 battles

Maybe uninstall game and all modes and instal one more time make sure all modes( if you have) are up to date for new patch.

  • Cool 1

Share this post


Link to post
Share on other sites
Players
29 posts
5,321 battles

Okay, Thanks all I don't have any mods installed right now so reinstalling the game isn't gonna help much but I hope the soon will bring out a patch to fix these problems.

 


 

530627322.png

  • Cool 1

Share this post


Link to post
Share on other sites
Beta Tester
430 posts
5,146 battles

Just some bad russian coding...I'm running stable 60+ fps on a crappy rig I started building somewhere around 2008 and last upgrade done 2013 (GPU and some good and one bad SSD drive that sometimes fails to boot on windows :D) Nevertheless, I'm gonna scrap/sell the rig in few years, no point upgrading it anymore, just gonna build or even buy a new one. Connection speeds have never been a problem for gaming, running around 30-35 ms with 4G mobile connection, althought streaming is out of options.

 

i3-2120 3,3 ghz

8gb ram

GTX 760

2x 250gb SSD drives

 

 

 

 

  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

×