Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
Pagster123

Southern Dragon Gifting Issues

10 comments in this topic

Recommended Posts

Players
55 posts
2,149 battles

I can't be bothered to contact support as they take days to reply, so instead I'll express the issue to the players.

 

I gifted my friend who is new to WoWs a Southern Dragon yesterday so he could have a high tier premium to call his own. The transaction went through without a hitch, and I have recieved a confirmation email that he got the ship (also he got the signal flags which came with the bundle). However he cannot find the ship in his port. We've tried the ship cog on the far right, we've tried the carousel and nada. He is level 12 so this is the only issue I can think of. Any help?

Share this post


Link to post
Share on other sites
[PUPSI]
Players
6,229 posts
Vor 39 Minuten, Pagster123 sagte:

No tick box.

mightbe some mods have messed up your port gui then...

 

and btw the Dragon ships aren't real premium ships...

 

 

Share this post


Link to post
Share on other sites
Players
55 posts
2,149 battles

Yes I know they aren't 'premiums' but I got it him so he could have a high tier premium. Is that the only explanation do you think?

Share this post


Link to post
Share on other sites
[PUPSI]
Players
6,229 posts
Vor 2 Minuten, Pagster123 sagte:

Is that the only explanation do you think?

 

with the gui? yes. Since the signals have arrived, the transaction should have been fine. And the standard for the Dragon ships filter is that those ships are hidden and you have to set the filter correctly. And if you cannot see the little wheel to get to the filter window, something must have screwed up your gui, and mods are the most likely reason...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×