Jump to content
Abdulla_AlMarzooqi

Game unplayable (I need help)

5 comments in this topic

Recommended Posts

Players
2 posts
475 battles

Greetings,

 

I have been getting so much lag today after I updated WoWs, everything was fine before the update. Today it was impossible to play a single battle, my internet connection is GOOD and I tried playing other games and the connection is fine except for WoWs. Since I do not live in Europe, my average ping to WoWs EU is 50-70 ms. I have been getting lag spikes from 50-1000+ ms today.

I have checked my firewall settings and I tried switching it off and the game is already allowed through firewall but I do not know what's the issue. 

Please help!

 

Regards,

Abdulla

Share this post


Link to post
Share on other sites
Players
25 posts
10,661 battles

Yeah the lag is horrendous after the last patch. Its is noticable just by firing the guns, they seem to lag out and fire out of sync like there is a delay on some guns, and now and again my ship stops dead in the water like i have run aground, then rubberbands forward suddenly. Eaten torps a couple of times because of it and its not enjoyable at all.... in fact it is downright irritating. There was also a monarch in a game earlier complaining that his shells was exploding mid air.

 

Other games are fine, internet connection is stable, only happening since the last patch. Wont be playing until its fixed.

Share this post


Link to post
Share on other sites
Players
10 posts
3,551 battles

lag is the least of your worries when me and several other players are experiencing random freezing mid battle, happens 99% of the time in combat with enemy ships... i'd take your lag spikes over having to relaunch the client only to find my ship obliterated and dead because the game decides im not allowed to win at the weekends.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×