Jump to content
MrConway

Bug Reports

103 comments in this topic

Recommended Posts

[WG-EU]
[WG-EU]
WG Staff, Alpha Tester
2,682 posts
2,606 battles

Dear captains,

 

Please share all bugs encountered version 0.7.1 below, using the following template:

 

1. Description

Clear and substantial description containing all necessary details.
Example: the cruiser Aoba: scout is inoperable.

 
2. Reproduction steps

A sequence of the player's actions which triggered the bug.
Example: 1. Select the cruiser Aoba 2. Enter the battle (Training or Random Battle). 3. Try to launch the scout.

 
3. Result

In-game experience resulting from the bug.
Example: When you press the scout activation button, you can hear the sound, but nothing actually happens. The aircraft stands still on the catapult.

 
4. Expected result

In-game experience which should have occurred if no bug is present.
Example: The scout has to be launched by the catapult.

 
5. Technical details
Example: Bug time: about 19:30 (UTC).Replay (attempt at 01:00), python.log, DxDiag.
 

If you encounter this error, please zip your ~\crashes\ folder, upload it to any online file storage and add the link to your report.

 

565152Sanstitre.png

Share this post


Link to post
Share on other sites
Players
7 posts
13,845 battles

Just played defence of Newport which i have done many times.

 

using New Mexico at start of round proceeded to go backwards as i was in the front near an island.

 

All land masses disappeared and it was like in the open sea.

 

could see all ships and  land artillery.

 

whole round was like this.

 

sorry didnt get a screen shot

Share this post


Link to post
Share on other sites
Players
7 posts
9,720 battles

1. right mouse button not assignable to artillery camera in control settings

2. select artillery camera button in setting ---> push right mouse button

3. nothing happens, sometimes "key reserved" pops up ----> can not use artillery cam ingame with right mouse

4. being able to use artillery cam with right mouse button

  • Cool 2

Share this post


Link to post
Share on other sites
[BUSHI]
Players
3,456 posts
17,894 battles

Ship zoom is not in the same position, as is always be, when switching from torpedos to guns. Every time I must now zoom out what is very inconvinient. Why with every patch some things which was right before are broken ?!!

 

Edit. ok - fixed myself by changing camerasConsumer.xml

  • Cool 1

Share this post


Link to post
Share on other sites
Beta Tester
2,658 posts
10,287 battles

GZ Test I:

 

DW Torpedo setup is supposed to only ignore Destroyers this time. 

 

But instead it is also not possible to hit cruisers.

(These are the old BB+CV Deepwater torpedoes from the 2-3-0 setup.)

 

@MrConway @Tuccy

 

It was not supposed to have these bad DW torps this time, because the only difference in both setups is the flooding chance. 

Share this post


Link to post
Share on other sites
[HABIT]
Beta Tester
1,568 posts

1. Description

I and two division mates joined a match today in the morning where all islands/landmasses were invisible but we could still see the trees and shadows of the islands. Also, the torpedoe lead indicator was not interrupted by the invisible islands (see screenshot 3). It seemed like all the other players in this match didn't experience this bug. Relogging (during the match) or joining the next match made islands visible again.

 

Edit: This bug also seems to appear in the port. See screenshot 5.

 
2. Reproduction steps

Don't know since it was only during one of four or five matches.

 
3. Result

Islands were not visible, the only indication for landmasses were hovering trees (if present). Torpedoes hit invisible islands, enemy movements and cover were harder to assess.

 
4. Expected result

Normal gameplay.

 
5. Technical details
Bug Time: about 10:30 a.m. today.

No mods of any kind installed on any of the three systems where the bug occured.

Map: Estuary (domination mode)

 

 

shot-18.02.08_10.21.27-0956.jpg

shot-18.02.08_10.21.46-0338.jpg

shot-18.02.08_10.23.25-0016.jpg

shot-18.02.08_10.24.13-0732.jpg

5a7d838f10e37_Island_bug1.thumb.jpg.aff57db492e34b490b12271912e930a5.jpg

Edited by Tungstonid
Added more details

Share this post


Link to post
Share on other sites
[NKK]
Beta Tester
702 posts
7,172 battles

1. Description

Unable to update, game is stuck repairing

 

2. Reproduction steps

The Game Center autostarted, downloaded the update, then started repairing, and now it is stuck at downloading repairs at 35% with 182.6 MB remaining.

It happened a couple of patches ago, I had to redownload the whole thing again, which is pretty bad, as it takes a looong time.

 
3. Result

I can't play

 
4. Expected result

I could update and play the game

 
5. Technical details
 

Update: I have fixed it. It was a problem with the SSD. I used the windows utility to scan and fix the drive. It didn't find any errors but a deeper scan after restarting find quite a few (it's odd, first thing it happens in one SSD, and I have like 10). It still didn't work, so I deleted the updates folder under the WOWS folder and it finally continued the repair.

  • Cool 1

Share this post


Link to post
Share on other sites
Players
4 posts
23,109 battles

There seems to be a control bug in the new patch. I cannot use CTRL to lock secondaries on a target whilst in my Bismarck. I run a full secondary setup with manual fire control. Also if I press ESC to access the settings the game drops to desktop

Share this post


Link to post
Share on other sites
Players
10 posts
5 hours ago, FallOutBoi said:

1. right mouse button not assignable to artillery camera in control settings

2. select artillery camera button in setting ---> push right mouse button

3. nothing happens, sometimes "key reserved" pops up ----> can not use artillery cam ingame with right mouse

4. being able to use artillery cam with right mouse button

 

Share this post


Link to post
Share on other sites
Players
10 posts

Hey yes I have this too,, before the patch I could change the preferences file, but now it does not work,, it goes blank after a minute.. I saw a reply above but that's very confusing to read

 

Share this post


Link to post
Share on other sites
Players
66 posts

1. Description

Game crashed my PC twice in the space of about an hour. On both occasions I was exiting the match after being killed in Operation Newport.

 
2. Reproduction steps

Entered battle, played battle, got killed, tried to go back to port, game crashed, black screen, had to force restart because i couldnt do anything else.

 
3. Result

When the game crashes it screws up your computer and you have to restart. No more game. Restart computer, play a match, game freezes up computer again, switch to another game. Playing experience now better me is happy :) But me is not happy, me wants to play big bang bang shooty things :(

 
4. Expected result

Play match, get killed, return to port and play another match in another ship.

 
5. Technical details
Last time it happened was about 21:00hrs.. the first time was about an hour before that. Cant find the crash report, couldnt take any screen shots or the likes because the game crashed my computer.

Share this post


Link to post
Share on other sites
[U-F-O]
[U-F-O]
Players
39 posts
6,379 battles

After playing a battle both my division mate and I returned to the Marseilles port to see a pile of ice erupting from the sea.5a7cc99fba99c_2018-02-0822_03_21-Greenshot.thumb.png.2cab6f971b5e531a8bc3ac9a80ba55f4.png

Maybe it is in fact the accumulated salt of all the cruisers after playing the old Tears of the Desert

 


Following this my division mate changed ship to  be greeted by this:

shot-18_02.08_22_07.08-0806.thumb.jpg.3aa8fbd8d6d62c547aa5feff2f95ba4e.jpg

I think the new port might have a few glitches :D

Share this post


Link to post
Share on other sites
[-DNA-]
Players
92 posts
4 hours ago, Odo_Toothless said:

Problem with right mouse button is very easy to solve yourself. Till last patch all settings could be done in command_mapping_config.xml. Now that file do not exist any more, but there is a new directory "command_mapping".

Here in preset_keyboard_1.xml, or preset_keyboard_2.xml or in both (I do not test this for now) you can change everything you like.

 

1. Unpack directory "wows_unpacker" using wows_unpacker

2. Copy this directory do res_mods

3. change in preset_keyboard_1.xml, or preset_keyboard_2.xml or in both  KEY_RIGHTMOUSE to another value or leave it blank      

 

<CMD_OBSERVE_CAMERA context="ship" type="hold">
<VALUE key="KEY_RIGHTMOUSE"/>
 </CMD_OBSERVE_CAMERA>

 

4.         change to KEY_RIGHTMOUSE

 

<CMD_ART_CAMERA context="battle" type="forceTap">
            <VALUE key="KEY_RIGHTMOUSE"/>
        </CMD_ART_CAMERA>

 

That's it.

 

 

Thanks for that, but is a little confused, and i dont want to mess up with unpacker and such things.... and is not our job to fix the things that usless people broke every update,They dont do their jod right, they are USLESSS.

Share this post


Link to post
Share on other sites
[BUSHI]
Players
3,456 posts
17,894 battles
1 hour ago, HaZarD_X said:

Thanks for that, but is a little confused, and i dont want to mess up with unpacker and such things.... and is not our job to fix the things that usless people broke every update,They dont do their jod right, they are USLESSS.

As You wish, but it's simple procedure - taking a few minutes. For me a few seconds.

anyway changes should be done in preset_keyboard_1.xml

 

Here you are - unpack and copy to res_mods/0.7.1.0 command_mapping.zip (corrected version)

 

The only change is: right mouse assigned to art camera. Free camera assigned to nothing.

 

You change this as you wish in:

 

        <CMD_OBSERVE_CAMERA context="ship" type="hold">
            <VALUE key=""/>
        </CMD_OBSERVE_CAMERA>

Share this post


Link to post
Share on other sites
[DAVY]
Players
12 posts
6,522 battles

1. Description

Myself and a division mate have been playing for a couple of hours. . .about 5 minutes into game on "North" (now called the map of shadowy doom crashes), all scenery decided to slowly vanish. Firstly, only trees were visible, then everything vanished. It was like playing on Ocean, where the islands became shadows of invisible things to beach on (ty WG - I struggle to not crash at the best of times).

 
2. Reproduction steps

Generally being crap awesome.

 
3. Result

Islands slowly vanished, followed by scenery (e.g. trees). Eventually replaced by shadows of doom. 

 
4. Expected result

Shattering disappointment

 
5. Technical details
Bug Time: about 22:00 GMT.

No mods of used.

Map: North

 

 

Edit: I asked in general chat - only myself & my division mate experienced this at the time. . . 

 

 

image.thumb.png.c8ede651a6647cead6c21bdeb456d40a.png

 

 

Share this post


Link to post
Share on other sites
[_IRN_]
Players
98 posts
6,800 battles

 

1. Description

Forward roon turret traversed 360°.

 
2. Reproduction steps

It happened only once, as soon as the turret returned to a normal position it started rotating normally.

 
3. Result

I was able to rotate the turret quicker thanks to the 360°

 
4. Expected result

Roon's forward  turret should not be able to rotate 360°

 
5. Technical details
screenshot attached.
 

shot-18.02.08_23.55.57-0680.jpg

  • Funny 1

Share this post


Link to post
Share on other sites
[_IRN_]
Players
98 posts
6,800 battles

1. Description

Marseille's new port's sea is not deep enough for battleships and high tier cruisers. the Keel in the bow goes below the sea bed.

 
2. Reproduction steps

Load the Marseille port in a big ship like a high tier Battleship or a high tier cruiser

 
3. Result

The submerged part of the bow goes under the sea bed

 
4. Expected result

big ships should drop anchor where the water is deeper.

 
5. Technical details
screenshot attached.

shot-18.02.09_00.11.56-0157.jpg

Share this post


Link to post
Share on other sites
[BUSHI]
Players
3,456 posts
17,894 battles
30 minutes ago, HaZarD_X said:

Thanks, i try it but nop....not working...thanks anyway...im very angry right now, i cant play with no RMB for artillery, they fucked up my misions for tomorrow, i close the ffffffffuing game until that uslees people in WG fix it....every update same shhhhhiiit, they are broke the game the usless  pfffffffffffffffffffffffffffffffffff

Come on. I checked a new code and found where the problem is. A new variable assigned right mouse too:         <CMD_ALIVE_POINTER_ACTION_2 context="alive_mouse" type="hold">. What is it for ? I don't know but seems it could be empty becouse all things are working as before.

 

Uploaded a new version to previous post. Is working 100% now. Simply I have assigned art camera to my middle mouse/wheel click, so didn't know about it. Free camera at right mouse is very needed when you spam shells from DD and want to look around from time to time.

 

Anyway I am not an expert but some things made me trouble and nowadays I can correct most things on the fly. Simply why waiting when you can do it yourself. There will be always some errors.

 

Share this post


Link to post
Share on other sites
[SUNKD]
Players
51 posts
6,903 battles
8 hours ago, Odo_Toothless said:

Ship zoom is not in the same position, as is always be, when switching from torpedos to guns. Every time I must now zoom out what is very inconvinient. Why with every patch some things which was right before are broken ?!!

 

Edit. ok - fixed myself by changing camerasConsumer.xml

I too am having this problem. Select torps (RMB), fire, press 1 for guns, have to then zoom out to see the game.

Also, unusually, I had to reassign buttons, first time in many patches I've had to do this. (Artillery view mapped to thumb mouse button)

Share this post


Link to post
Share on other sites
[-DNA-]
Players
92 posts
26 minutes ago, Odo_Toothless said:

Come on. I checked a new code and found where the problem is. A new variable assigned right mouse too:         <CMD_ALIVE_POINTER_ACTION_2 context="alive_mouse" type="hold">. What is it for ? I don't know but seems it could be empty becouse all things are working as before.

 

Uploaded a new version to previous post. Is working 100% now. Simply I have assigned art camera to my middle mouse/wheel click, so didn't know about it. Free camera at right mouse is very needed when you spam shells from DD and want to look around from time to time.

 

Anyway I am not an expert but some things made me trouble and nowadays I can correct most things on the fly. Simply why waiting when you can do it yourself. There will be always some errors.

 

well, your settings as i read, is different .... i use RMB to zoom and snipe, Free lock i dont use it much and i have it to Lshift...my point is,   left hand move-turn the ship,   right hand RMB to zoom-snipe LMB to shoot...

Share this post


Link to post
Share on other sites
[BUSHI]
Players
3,456 posts
17,894 battles
3 minutes ago, HaZarD_X said:

well, your settings as i read, is different .... i use RMB to zoom and snipe, Free lock i dont use it much and i have it to Lshift...my point is,   left hand move-turn the ship,   right hand RMB to zoom-snipe LMB to shoot...

In that file as I wrote: right mouse button is assigned to art camera. I corrected not working previous download.

 

Free lock you can assign to anything you want, becouse it has no data assigned. Anyway making changes in this file you can assign any button to even restricted buttons. You can make everything you want yourself or wait and write a petition to WG. It's your choice. Good luck.

Share this post


Link to post
Share on other sites
[BUSHI]
Players
3,456 posts
17,894 battles
39 minutes ago, DK63 said:

I too am having this problem. Select torps (RMB), fire, press 1 for guns, have to then zoom out to see the game.

Also, unusually, I had to reassign buttons, first time in many patches I've had to do this. (Artillery view mapped to thumb mouse button)

I downloaded corrected version of original camerasConsumer.xml. camerasConsumer.zip

Copy unpacked file to mod folder.

 

Changes made to:

 

        <snake_tail>

(...)

            <nearModelDistance>180.0</nearModelDistance>            <!-- diapason [120.0 - 180.0]-->
            <farModelDistance>180.0</farModelDistance>            <!-- diapason [120.0 - 180.0]-->

 

was: 130 and 165

 

Now after changing from torps to guns your ship model is returning at once to max zoom out.

If you are using ex. ZEISS mode, then change both in mod file to 180 or 200. It depends from zoom version.

Share this post


Link to post
Share on other sites
[-DNA-]
Players
92 posts
30 minutes ago, Odo_Toothless said:

In that file as I wrote: right mouse button is assigned to art camera. Free lock you can assign to anything you want, becouse it has no data assigned. Anyway making changes in this file you can assign any button to even restricted buttons. Good luck.

ok, i find another way to fix it...i assign the RMB to caps lock(or what else you want), i open the preference file and search for ART_CAMERA, there are 3-4 lines with that, i found the line of ART_CAMERA that have the CapsLock, and change it manual to RMB and works....dont know if tomorrow when i open the game is still working....

This is how looks the line that i change

 

RRMB.thumb.png.3ffebe8fe7cebb07115ae3114cf33890.png

 

 

Thanks for help Odo. :cap_like:  Send an email to WG to hire you, im sure you are better than that people who work there...

  • Cool 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×