Jump to content
Finarphin

Crit Error

9 comments in this topic

Recommended Posts

Beta Tester
95 posts
4,801 battles

Having same issue. As soon as the opening screen comes up with correct version I get the same as above.

After clicking PLAY.jpg

Share this post


Link to post
Share on other sites
Beta Tester
95 posts
4,801 battles

Imagine my delight when there was an update this morning.

However, after it checking that the game client was up to date, which is it, no launch at all. Nothing. :(

Not opening in safe mode either.

Share this post


Link to post
Share on other sites
Beta Tester
95 posts
4,801 battles

Ok, thanks for the email telling me if i logged in I would get extras.

Thought I would try again, reinstalled the whole game again. Now I don't get any errors, but game still doesn't start.

 

I believe my specs are good enough and I am also running DX12, so I don't know what the issue is.

 

Has anyone discoverd a workaround?

 

 

System Specs.jpg

DX Processor.jpg

Share this post


Link to post
Share on other sites
[3OPS]
Players
2 posts
4,844 battles

Getting same errors. 

Seems to be when windows update, for me. Ended up rolloing back windows update to previous version. 

Worked fine until windows updated again today, and again critical error and can't play anymore.

P.S.

This is on my laptop with windows 10, my desktop works fine, but then again its running windows 7 ultimate.

Share this post


Link to post
Share on other sites
[TEC]
Beta Tester
186 posts

Yep, WoWS crashes on the load screen - every time.

 

I just managed to load the game, by running it in Win7 compatibility mode.

Share this post


Link to post
Share on other sites
Beta Tester
95 posts
4,801 battles

Tried Windows Compatibility Mod 7 and 8 no joy.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×