Jump to content
  • 0
You need to play a total of 50 battles to post in this section.
EfekZ1

Game crash issue

3 comments in this topic

Question

[O-P-C]
[O-P-C]
Players
1 post
5,339 battles

My game is crashing without crash report, it crash when i click on connect and going to port. WGCheck report is telling me that i have issue loading port screen because of unknown reason. Please give me some advice, thanks. 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Beta Tester
305 posts
3,644 battles

hello mate you can remove all mods if u have one or try to update them , or add the game to your firewall or antivirus exceptions as secure, in case  if that its not working just try to reinstall the game , most of the time will fix all your problems :) good luck

Share this post


Link to post
Share on other sites
  • 0
[BAD-A]
[BAD-A]
Beta Tester
1,761 posts
16,583 battles
On 29/01/2018 at 5:38 PM, EfekZ1 said:

My game is crashing without crash report, it crash when i click on connect and going to port. WGCheck report is telling me that i have issue loading port screen because of unknown reason. Please give me some advice, thanks. 

 

Just a few observations from my own personal hell that has been WoWs random crashes etc.... 

 

1) Uninstall ALL mods also delete mods folder AFTER uninstall and reboot.... See if this solves the issue. If it does then you will need to add any mods you wish to use one by one until you find the culprit.

2) Check your drivers on Graphics card... most of the crashes I get are alongside a bong noise and a gfx error....

3) And the best one... go to your WoWs launcher...click on  " GAME SETTINGS", click on  "CHECK AND REPAIR" then click "CONTINUE"....and wait for it to do its' thing.... solves maybe 90% of issues (mainly after a large update...

4) Nuclear option and best if you have a fast connection, is to uninstall, delete ALL WoWs folders, reboot and do a clean install...

 

For maintenance purposes here are some suggestions for you...

 

1) IF you have a large mechanical storage drive then once you have a nice fresh install running copy the whole folder over to a second directory and name it backup WoWs.... remember to delete ALL the contents of the update folder before hand as WoWs stores all updates files which are useless once the update is completed so save the massive space here.

2) IF you have a very fast connection then the best advice is to do a full uninstall/reinstall at EVERY MAJOR patch... this gets you away from the issue that the engine seems to have with corruption on older files and locations etc... 

3) Once you have launched into the game go back to windows and close the WG Game Centre... remembering to also close it in your notification panel.... this thing is as buggy as heck and causes all sorts of random stuff to happen to your machine.

 

For Diagnosis ideas keep an eye on memory usage as there is a well known issue with WoWs and memory leak / release of paged memory... if you are running low RAM in your machine then this could be what is happening after an extended playing period.... simple solution is when committed memory is running too high restart the client and/or reboot the machine... to reset the process.

Also check what stuff is running in background as I have found on occasion that having Chrome open on certain scripted pages can cause issues too...

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×