Jump to content
  • 0
You need to play a total of 50 battles to post in this section.
SkullBreaker007

Game lags even at lowest settings

9 comments in this topic

Question

Players
135 posts
1,146 battles

Hey there.

I used to play world of warships almost half a year ago. I left playing it. At that time I was able to run my game smoothly at medium to high settings. Now I downloaded the game again and was amazed to find it was unplayable. I switched to the lowest possible settings and still it was laggy. I usually enter the battle 30 seconds after it starts. I have a really bad pc 

Intel i5 1.60ghz can go upto 2.4ghz

4gb ram(its enough)

Intel hd 4400 (I know its bad but the game used to run fine some time ago)

One last thing I use process hacker and it shows 0% gpu usage. Could anyone help me I really want to play the game. Btw internet is not the problem.

Many thanks.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
Players
63 posts

As painful as it may be to hear, the problem is your PC. The game has come a long way in a year, improvements to graphics, bigger maps... all these improvements are just data. The more data in a game the more computing power you need to play it.

 

I played on my laptop before Christmas, got a new PC for Christmas.. its not a gaming PC by any stretch of the imagination but it is far superior to the laptop. I never realised how bad my computer performance was before.. I mean its not amazing now.. I play at about 11 fps but loading times are quicker and that means that I'm not the last to enter a fight anymore.

 

Have a look online to see how you can free up some RAM speed for gaming. There are a few tutorials on youtube that might just be enough to get you playing again.

Share this post


Link to post
Share on other sites
  • 0
Players
135 posts
1,146 battles

Hey thanks are there any other tweaks I could do to my pc or game. Because now im also forced to play co op mode because random mode is too laggy. I have a real bad laptop. Btw are there any chances WOW might come to ps4. Its the only thing I have capable if running it?

Share this post


Link to post
Share on other sites
  • 0
[HAERT]
[HAERT]
Players
1,160 posts
2,296 battles
On 1/30/2018 at 7:21 AM, SkullBreaker007 said:

Hey thanks are there any other tweaks I could do to my pc or game. Because now im also forced to play co op mode because random mode is too laggy. I have a real bad laptop. Btw are there any chances WOW might come to ps4. Its the only thing I have capable if running it?

Running the game on an SSD helps, as does more RAM, and somewhere Flamu I think posted info about how to modify the games engineconfig xml file to change the ram buffer setting.

Share this post


Link to post
Share on other sites
  • 0
Players
204 posts
321 battles

With SSD that reach extreme read write speeds now RAM wil be owershadowed. IMO the processor will eat up the RAM and integrate it to L1 an L2 memory blocks which already are better bang for buck instead of RAM.

So tl;dr get a better CPU. It's possible to split the load to your GPU, but your better of buying an new PC.

Spoiler

System32.png

 

Share this post


Link to post
Share on other sites
  • 0
[BAD-A]
[BAD-A]
Beta Tester
1,659 posts
14,919 battles
On 23/01/2018 at 1:39 PM, SkullBreaker007 said:

Hey there.

I used to play world of warships almost half a year ago. I left playing it. At that time I was able to run my game smoothly at medium to high settings. Now I downloaded the game again and was amazed to find it was unplayable. I switched to the lowest possible settings and still it was laggy. I usually enter the battle 30 seconds after it starts. I have a really bad pc 

Intel i5 1.60ghz can go upto 2.4ghz

4gb ram(its enough)

Intel hd 4400 (I know its bad but the game used to run fine some time ago)

One last thing I use process hacker and it shows 0% gpu usage. Could anyone help me I really want to play the game. Btw internet is not the problem.

Many thanks.

 

An oldie but goldie for Big World engine is the following....

 

1) Find your Wows executable file, make a shortcut to it (maybe to desktop) 

2) Right click on the shortcut, click properties, then click on "TARGET" right arrow all the way to the end of the string.

3) Hit the space bar (ensuring you have NOT highlighted all the characters) then type in +fullproc

4) Apply and OK.

Share this post


Link to post
Share on other sites
  • 0
[OMNI]
Players
97 posts
11,945 battles

I believe 4Gigs ram might also be low now. Game uses 1.5Gigs alone for me, and windows about 3,5G (but again windows uses anything if it comes free). check the pagefile if its used (if its like 1 - 2% its ok but if it is used, you are using the disk because you are out of ram).

 

If its video ram, try to compress textures (with a mod) and test again

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×