Jump to content
LykkeSabine93

I can't install the game..help me!

11 comments in this topic

Recommended Posts

Players
3 posts
26 battles

Hello i have a problem...i can't install the game and the virus program is not the problem it's AVG Free the PC have and my own PC have the same virus program....it's like the game is being blocked from install the game and the update...yes i have tried to install the game before this time but i uninstalled it again because of the same problem as now...i have tried to restart the PC and that doesn't work either so i don't know what it could be who is blocking it...the internet is fine here and on my own PC i don't have this problem at all...something is blocking it from installing and update the game and i really don't know what it is...so i really hope that you guys could help me with this! i really wanna play the game :O 

eng.jpg

Share this post


Link to post
Share on other sites
Players
204 posts
329 battles

I assume it's not your internet, so it can only be either the pc specks can't run the game or there is no HDD/SSD space left to download/run it.

 

If it's the client itself: https://forum.worldofwarships.com/topic/125811-wg-check-tool/

 

Anything else is is probabbly internet provider -DHCP related if your antivirus and firewall are fine as you say.

 

Share this post


Link to post
Share on other sites
[SM0KE]
Players
2,635 posts
6,496 battles

Are you trying to install from Steam? If not, you could try that approach; that might make a difference.

(that assumes there are no down-sides to using the Steam version - anyone?)

 

Edit: if you *are* trying to install from Steam, try the other version?

Share this post


Link to post
Share on other sites
[SM0KE]
Players
2,635 posts
6,496 battles

Is that screen-grab current (I can't read the clock)? If it is, what's that 'Beta' doing top-left?

 

Are you trying to use an old installation package?

Share this post


Link to post
Share on other sites
[FAD]
Players
86 posts

Hi @LykkeSabine93

try to download an old installer to install the game maybe Game Center has a problem downloading the game otherwise try to redownload the latest Game Center again

Share this post


Link to post
Share on other sites
Weekend Tester
57 posts
4,968 battles

The beta in the screenshot refers to the beta status of the Wargaming Game Centre tool, not the client itself.

 

Under the game centre folder, in the logs sub folders, there'll be logs starting with wgc_date/time which may give more info.

 

Share this post


Link to post
Share on other sites
[SM0KE]
Players
2,635 posts
6,496 battles
15 hours ago, TheSpearman said:

The beta in the screenshot refers to the beta status of the Wargaming Game Centre tool, not the client itself.

 

 

Ah, I see - when I installed, I used the stand-alone thing; I'm avoiding Game Centre until it's out of Beta...

Share this post


Link to post
Share on other sites
Players
12 posts
302 battles

Back when I first tried the game on my old machine, I encountered a somewhat similar

problem. The game actively refused to launch after some time had passed, in the same

way old games refuse to run on new computers unless you run them in compatibility

mode. It just made up its mind that it doesn't want to run, and that's that.

 

Personally I recommend a complete wipe.

1.) Uninstall the game

2.) Delete all remaining files associated to the game (if any are left)

3.) Run a Disc Cleanup or CCleaner to remove all temporary files on your computer

4.) Clear as much space on your drive as you can

5.) Defragment your computer (defragment all drives)

5a.) EDIT: Update your drivers if you haven't done so in a while.

6.) Download the latest game client and hope for the best.

 

If this doesn't fix it, nothing will, yes it's pretty extreme, but that's the most reliable

way to do it.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×