Jump to content
  • 0
You need to play a total of 50 battles to post in this section.
kidd18

WoWs nie uruchamia się

30 comments in this topic

Question

Beta Tester
1,166 posts
7,615 battles

W niedzielę Win 10 zainstalował mi aktualizację. Przed aktualizacjami gra działała (jeszcze tego samego dnia), potem już nie (to raczej nie jest zbieg okoliczności). Przeinstalowałem grę i nadal jest problem. Podobnie z WoT. Nie dotyczy to innych gier (np. ze Steam). Wygląda to tak, że klikam "Uruchom grę", pojawia się informacja (w Game Center), że gra jest uruchomiona, ale nic się nie dzieje. Nie pojawia się żadne okno grą, gry nie ma na pasku. Proces jest pokazywany tylko w menadżerze urządzeń. Nie mogę ponownie kliknąć, bo (a jakże) gra już jest uruchomiona. Nie mam nic na pasku. Jest parę raportów o crash'ach w folderze gry. Kiedy kliknę uruchom słychać dźwięk włąśnie jak przy crash'u aplikacji. Jak to naprawić?

 

Gram na czystym kliencie, bez żadnych modów. Wcześniej nie miałem żadnych tego typu problemów. Reinstalowałem, badałem integralność dodałem wyjątki do zapory sieciowej, nie wiem co dalej.

Mój OS to Windows 10 Home, wersja 1709, kompilacja 16299.98

 

W crash report z folderu gry mam w opisie coś takiego:

 

Quote

Message:
The BigWorld Client has encountered an unhandled exception and must close (EXCEPTION_ACCESS_VIOLATION : 0xC0000005 @ 0x016E8DD1) (Read @ 0x4294967136)

 

Ticket do supporu ofc wysłany, ale milczą jak zaklęci...

Share this post


Link to post
Share on other sites

29 answers to this question

Recommended Posts

  • 0
Players
5,402 posts
24,784 battles

Cofnij system do stanu przed aktualizacji (edit. kolega poniżej napisał, że niby cofnęło go do Win 8.1 ... !?) i zatrzymaj aktualizacje automatyczne, do czasu, aż ktoś coś będzie wiedział na ten temat. Niby Win10 tego nie umożliwia, ale są sposoby na obejście.

 

być może działa ten ?

http://www.instalki.pl/demonstracje/systemowe/19271-windows-10-wylaczanie-aktualizacji.html

 

edit. da się wyłączyć - zmieniamy usługę aktualizacji automatycznych na wyłączone i w zakładce odzyskiwanie ustawiamy w sekcji pierwsza próba (uruchomienia) na: nic nie rób.

Jak chcemy się zaktalizować to czasowo to odznaczamy.

 

Tak czy siak na przyszłość jak będziesz miał jakieś turnieje itd. to lepiej blokuj aktualizacje na ich czas, bo nigdy nie wiadomo jakie kwiatki jeszcze będą.

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

To nie wina WG, tylko syfiastej aktualizacji windowsa 10. Jest tam bug który powoduje, że system automatycznie ustanawia wszystkie foldery i podfoldery jako "tylko do odczytu". Niestety ani przez zakładkę właściwości, ani przez cmd attrib nie można zmienić atrybutów folderów.

Gra nie może zapisywać plików i dlatego jest crash. Co gorsza nie można, przynajmniej w moim przypadku, cofnąć się do windy sprzed aktualizacji. U mnie zakończyło się to powrotem do windowsa 8.1. [edited] ich mać. Na razie nie chce mi się tego za bardzo zgłębiać, 4 dni aktualizacji i odzyskiwania jednego gównianego systemu to trochę za dużo.

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
[MS-B]
Beta Tester
41 posts

mam ten sam system i najnowsza aktualizacje i wszystko smiga - wows i wot

ale niemam  tego gow..   ( Game Center)

mysle ze to powoduje jakis konflikt

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles

Udało mi się cofnąć do poprzedniej kompilacji, ale przy okazji straciłem połowę sterowników i co najmniej parę programów. Reinstaluję grę jeszcze raz i zobaczymy, czy działa.

 

Na 99% to GC i nowa kompilacja Windy nie współpracują. Generalnie to jest prawdopodobnie jakiś bug w GC, bo już z samą instalacją miałem problem (nie doczytywało plików z res packages), ale jak uruchomiłem GC jako administrator i pozmieniałem dostępy to poszło, co prawda problemu nie naprawiło, jednak przynajmniej zainstalowałem (i tu mam podejrzenie, że w czasie instalacji "zgubiło" się parę ważnych plików, dlatego gra od razu crashuje, czyli jednak instalator GC).

 

Generalnie programiści z WG dali dupy ze swoim softem, bo inne programy i gry śmigają bez problemu na nowej kompilacji (z tego co zauważyłem nawet wydajność systemu wzrosła).

 

A support nadal milczy. :cap_old:

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

Tyle tylko, że u mnie po cofnięciu do windows 8.1 gra instaluje się i działa z poziomu GC. Ponownie zainstalowałem czysty windows 10 i dupa blada. Nie mogę w systemie zmienić uprawnień folderów i plików do odczytu. Gc zainstalował się poprawnie, gra też, tyle że nie odpala. Gdzieś tam wyskakuje brak dostępu. Support z wg, wspaniale zalecił mi zmianę atrybutów pliku, tyle że to nic nie daje.

Obstawiam, że nowa aktualizacja gryzie się z GC, ale może to być też zależna od producenta lapka, lub posiadanego procesora. W tym wypadku u mnie jest lenovo, intel i ge force.

Gry na steam po ponownej instalacji też nie działają, fakt, że same starsze tytuły.

Odo cofniecie do win8.1 wynikało z tego, że podczas aktualizacji, system się wysypał i komp zawiesił, pomogło jedynie cofniecie do stanu początkowego.

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles

Zdaje się, że Win 10 ma "dokładniejsze" zabezpieczenia do których instalator nie jest dostosowany.

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles
6 minutes ago, Tumaniszwili said:

A próbowałeś uruchomić gier w trybie zgodności np. z Windows 7?

 

Tak. Nie pomogło. :/

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles
36 minutes ago, Tumaniszwili said:

BTW. Już wiem teraz dlaczego ostatnio nie widziałem Cie w bitwach :)

 

Właśnie dlatego. :(

 

giphy.gif

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles

Uwaga techniczna - po przywróceniu kompilacji systemu sprzed ostatniej aktualizacji okazało się, że nie straciłem sterowników (są nadal zainstalowane w najnowszej wersji), za to system przestał je "czytać" (co powinien robić bez problemu, bo poprzednio działał). Problem oznaczony jest kodem 39 i nic nie jestem w stanie na niego poradzić (Win 10 sam trzyma gdzieś kopie sterów i nie można ich zastąpić "świeżymi" bez grzebania w rejestrze). Także uważajcie przy korzystaniu z tego narzędzia. Zostaje mi czysta instalacja, a jak to nie pomoże, to format. Support nadal milczy. Zaczynam się powoli wkurwiać.

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

Tyle tylko, że do czasu tej ostatniej gównianej aktualizacji, windows 10 sprawował się dużo lepiej od 8.1.

Problem z brakiem możliwości zmiany atrybutów dotyka nie tylko graczy, ale aktualizacja zablokowała także dostępy do plików z innych aplikacji.

Kidd niestety tak jak napisałem wcześniej, czeka cię powrót do stanu zero. Doradzę tylko byś nie instalował czystego windows 10, bo to gówno daje, tylko od razu skorzystał z odzyskiwania pierwotnego systemu, (u mnie 8), i po kolei instalował wszystkie aktualizacje.

A zobacz jeszcze czy odinstalowanie w menadżerze urządzeń sterów i potem ponowne ich wyszukanie w sieci i zainstalowanie da jakiś efekt.

Ja tak miałem właśnie z usb3.0, występował błąd i dupa, urządzenie wyłączone, dopiero odinstalowanie sterowników i ponowna instalacja dała wynik pozytywny.

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles
1 hour ago, KrzysiekEg said:

Doradzę tylko byś nie instalował czystego windows 10, bo to gówno daje.

 

Właśnie to zrobiłem....

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

Daj znać jaki efekt, może u Ciebie zagra, z tego co czytałem na forum Microsoft to problem występuje w różnych wariantach, i uj wie od czego zależny. Ja nawet zrobiłem cały dysk c z dostępem na full, i dupa. Nawet nowo stworzone foldery mimo atrybutów pozwalających na zapis i odczyt, gówno dały. Nie i uj, i co mi pan zrobi.

Odczekam z miesiąc, pewnie Microsoft da kolejna łatkę, na razie 8.1 rządzi.

Share this post


Link to post
Share on other sites
  • 0
WG Staff
2,392 posts
4,502 battles

Nie jestem pewien czy chodzi Ci o nasz support czy o Microsoftu.
Jesli do naszego jeszcze tego nie zgłosiłeś to zrób to czym prędzej.

Ja postaram się opisać Twój przypadek i też podać wyżej.
Niestety czasem jesteśmy zależni od Windowsa i nie zawsze ich aktualizacje współgrają z innymi programistami.

Przykro mi, że tego doświadczasz. 

  • Cool 3

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles

Zgłosiłem do Supportu WG i dostałem już odpowiedź, jestem w trakcie sprawdzania zaproponowanych rozwiązań:

 

 

Quote

 

Aby rozwiązać problem prosimy:

  • dodać grę włącznie z launcherem do list programów zaufanych
  • sprawdzić we właściwościach folderu po kliknięciu prawym klawiszem myszki, czy nie jest ustawiona "read only" i wyłączyć ta opcję
  • uruchomić grę z poziomu konta administratora

 

  •  

Dam znać czy działa.

 

Generalnie to nie jestem zaskoczony, bo Win10 sprawia mi problemy od samego początku. Zabawne, że akurat teraz, kiedy klanówki się kończą, a mi ostało raptem 6 bitew do wygrania. :C Zmarnowanego czasu już nie  liczę. To zupełnie nowa kategoria problemów, nie było tego przy Win2000, XP, Vist'a, czy 8 - jakich używałem. Bardzo irytujące.  Widzę, że sporo ludzi ma ten sam problem co ja, szkoda, że aktualizacja Win10 wyszła po testach, bo może udało by się to wykryć na tym etapie.

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles
3 minutes ago, SirensRevolution said:

Jeżeli nadal będziesz miał problem to czy próbowałeś zmienić atrybuty dostępu do plików w trybie awaryjnym?

 

Sprawdzę, czy to coś da.

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

Nie dawało, przynajmniej do 12 grudnia. Próbowałem zarówno jako administrator jak i właściciel.

Kidd zobacz na forum wot, tam też mają problemy z aktualizacją. Podobno wczoraj była jakaś łatka i zaczęło działać, inni podają by zmienić skalowanie w ustawieniach grafiki. U innych pomaga wyłączenie wszystkich ustawień w xbox.

U mnie też support napisał podobnie, i gówno to dało.

 

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles

Zrobiłem czystą instalację Win 10 (tą głęboką z wywaleniem wszystkiego) + dorzuciłem to co napisał support i działa. :) Dzięki wszystkim za pomoc!

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

No i dupa. Przeszedłem od nowa całą ścieżkę aktualizacji od 8.1 do 10 i ponownie to samo.

wows dodany ponownie do reguł programów zaufanych, konto administratora, i nadal problem z atrybutami.

Nie mam możliwości zmiany atrybutu folderu.

Kończą mi się pomysły.

Znalazłem rozwiązanie na angielskim forum.

https://forum.worldofwarships.com/topic/144629-fix-for-game-crash-at-start-upafter-windows-10-update/

 

Może ktoś bieglejszy przetłumaczy to z angielskiego. Ogólnie trzeba zmienić w ustawieniach gry na dx9. Można to zrobić w pliku preferences.

Słabo wg, bardzo słabo.

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles
23 minutes ago, KrzysiekEg said:

Nie mam możliwości zmiany atrybutu folderu.

 

Ja cały partycję udostępniłem. Dodałem do programów zaufanych też całe foldery: GC i WoWs. Dopuściłem też dostęp do sieci publicznych dla WoWs.

 

Dziwna sprawa, że nie możesz ruszyć atrybutów folderu - to wskazuje, że coś z uprawnieniami konta na którym działasz jest nie tak. Rozszerzyłeś uprawnienia wszystkich kont do "pełna kontrola" nad plikami?

Share this post


Link to post
Share on other sites
  • 0
Players
224 posts
19,561 battles

Tak, zrobiłem tak jak Ty. Cały  c: ustawiłem na full dostęp. I nic to nie dało. Dopiero ten myk, z plikiem preferences i zmiana api da dx 9. I gra odpaliła. U ciebie chodzi z dx11?

Reasumując, problemem nie jest brak dostępu do plików jak sugeruje wg, tylko nowa aktualizacja windowsa gryzie się z ustawieniami gry, i nie chce pracować z dx11.

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
1,166 posts
7,615 battles
56 minutes ago, KrzysiekEg said:

Tak, zrobiłem tak jak Ty. Cały  c: ustawiłem na full dostęp. I nic to nie dało. Dopiero ten myk, z plikiem preferences i zmiana api da dx 9. I gra odpaliła. U ciebie chodzi z dx11?

Reasumując, problemem nie jest brak dostępu do plików jak sugeruje wg, tylko nowa aktualizacja windowsa gryzie się z ustawieniami gry, i nie chce pracować z dx11.

 

No proszę. Nie instalowałem dx11 po przywróceniu systemu do konfiguracji fabrycznej, tylko dx9 (prosto z GC). W ustawieniach gry też mam też mam dx9 (to ustawienie domyślne), a nie dx11.  Wydaje się, że to może być sedno sprawy.

Share this post


Link to post
Share on other sites

×