Jump to content
Crysantos

Bugs

50 comments in this topic

Recommended Posts

WG Staff
3,415 posts
14,994 battles

Dear captains,

 

Please share all bugs encountered in the current update 0.6.14 below, using the following template:

 

1. Description

Clear and substantial description containing all necessary details.
Example: the cruiser Aoba: scout is inoperable.

 
2. Reproduction steps

A sequence of the player's actions which triggered the bug.
Example: 1. Select the cruiser Aoba 2. Enter the battle (Training or Random Battle). 3. Try to launch the scout.

 
3. Result

In-game experience resulting from the bug.
Example: When you press the scout activation button, you can hear the sound, but nothing actually happens. The aircraft stands still on the catapult.

 
4. Expected result

In-game experience which should have occurred if no bug is present.
Example: The scout has to be launched by the catapult.

 
5. Technical details
Example: Bug time: about 19:30 (UTC).Replay (attempt at 01:00), python.log, DxDiag.
 

If you encounter this error, please zip your ~\crashes\ folder, upload it to any online file storage and add the link to your report.

 

565152Sanstitre.png

Share this post


Link to post
Share on other sites
Players
161 posts
9,012 battles

1. Description

The game crashes at the end of every match.

 
2. Reproduction steps

Play the game. wait until it ends. it crashes the moment the game ends, not allowing me to see the results screen.

 
3. Result

Game crash.

 
4. Expected result

Game shouldnt have crashed.

 
5. Technical details

Leaving the crashlog

 

error.thumb.png.146d71d8488d9f44f6fb0ab9bd7ec16c.png

crashes.rar

Share this post


Link to post
Share on other sites
Players
6,058 posts
12,083 battles

1. Description

The game crashes when the game is busy logging in after name and password have been entered. The crash occurs at the login screen. It was fine yesterday, 3 attempts resulted in 3 crashes.

 

2. Reproduction steps

Start World of Warships so that the little blue newswindow containing the "Play" button in the bottom right corner.

Then press the Play button and let the game load until it arrives at the screen that asks for login details.

Fill in the login details then let the game continu to log in.

 

3. Result

After having logged in, this error pops up and the game has to be exited.

 

4. Expected result

I expected to have entered my harbor.

 

5. Technical details

Around 10AM CET (roughly 10 minutes ago). I added the entire content of the crash directory as an attachment and also included the error message that pops up after which the game has to be closed.

crashes.zip

crash6.14.jpg

Share this post


Link to post
Share on other sites
[GUNUP]
Weekend Tester
582 posts
35,316 battles

1. Description

My Game Crashes after the Battle Ends, wasnt able to show the ResultScreen

@Crysantos This buy seems to be the most annoying one at the Patch. It happens for me now the 6. Time in a Row, after leaving a Battle (because I was killed) , if i exit the Battle Regulary (wins or loss doesnt matter) but this Bug seems to be a very .... er ... high Priority one.


2. Reproduction steps

Since i dont know how to reproduce it, i hope you can investigate the WGCheckFile and figure it out (im using no Mods at this Time)

 
3. Result

Game Crashed without a Chance to close the Game via the Menue (terminate the Process via Taskmanager only Helps)

 
4. Expected result

Expected as all Guys wish, should be a stable running Client

 
5. Technical details
Screenshot added from WGCheck Tool + Zip File from WGCheck Tool it self

WoWs Crash.jpg

WoWS_report.zip

Share this post


Link to post
Share on other sites
Players
218 posts
8,367 battles

I had an AMAZING experience today. I finished "the hunt for Bismarck"!!! Weee I'm so happy. Actually this is the third time I finish the hunt for Bismarck. Why is it that every other patch the game reset and recomplete the collections?

Share this post


Link to post
Share on other sites
[ALYEN]
Players
2,070 posts
4,042 battles

1. Description

Ingame news browser does not properly display the pages with interactive tabs

 

2. Reproduction steps

Open the news browser, select the "December mission briefing" item

 
3. Result

The missions for the dates are not displayed, see attached screenshot.

 
4. Expected result

Proper page rendering. As an alternative, can we have an option in the client to DISABLE that useless PoS ??

 

5. Technical details
The page itself states that if the Missions are not displayed, we can try to refresh the page. However there's no reload button in the UI. Hitting F5 DOES refresh the News browser, however it also points it back to the top news item. There's no way to refresh a specific news item. Closing and reopening the News browser does nothing.

shot-17.12.01_13.54.03-0738.jpg

Share this post


Link to post
Share on other sites
Players
490 posts
4 hours ago, Anthoniusii said:

WoWs .exe crashes , more often in DX11 ....it seams the textures and shaders have some bugs that lead to CTDs.

error.png

Sorry for the double post...Critical error with DX 9 now but as the message shows its more complicated..

error.png

Share this post


Link to post
Share on other sites
[GUNUP]
Weekend Tester
582 posts
35,316 battles

@Anthoniusii It seems the Big World Engine isnt in Christmas Mood :Smile_playing: look the same Issue (but less detailed) i posted a few Posts above you. Since we are all using Different Setups (Computers and Parts) it must be something with the Engine itself?! But this Bug, or Crash... now causes me 10 Times crashed in a Row. Which is rather annoying.

Share this post


Link to post
Share on other sites
Beta Tester
452 posts
8,129 battles

1. Description

Ingame crash, every 2nd/3rd battle game crashes in game, about in the middle of the battle

 
2. Reproduction steps

nothing special, always different ships, different tiers.

 
3. Result

Result is, black screen, PC restarts automaticly after some seconds, no error message, just battle stops with a black screen.

 
4. Expected result

No game crash, should be able to play battles without PC and Game Crashes

 
5. Technical details
Log from Crash Folder:

Application C:/Games/World_of_Warships_EU/WorldOfWarships.exe crashed 12.01.2017 at 20:55:37

Message:
The BigWorld Client has encountered an unhandled exception and must close (EXCEPTION_ACCESS_VIOLATION : 0xC0000005 @ 0x01A53C25) (Write @ 0x2916483072)
Current thread #5844 native trace:
(0) : WorldOfWarships.exe!0x01A53C25
(0) : WorldOfWarships.exe!0x01A538B0
(0) : WorldOfWarships.exe!0x01A502B3
(0) : WorldOfWarships.exe!0x01A50524
(0) : WorldOfWarships.exe!0x01A5097D
(0) : WorldOfWarships.exe!0x01A3ACB1
(0) : WorldOfWarships.exe!0x01A3B4E4
(0) : WorldOfWarships.exe!0x01A1E50A
(0) : WorldOfWarships.exe!0x01A20CDF
(0) : WorldOfWarships.exe!0x01394645
(0) : WorldOfWarships.exe!0x01A4010B
(0) : WorldOfWarships.exe!0x01A4066E
(0) : WorldOfWarships.exe!0x01A30EAA
(0) : WorldOfWarships.exe!0x01A322EA
(0) : WorldOfWarships.exe!0x01A358C1
(0) : WorldOfWarships.exe!0x01A0BABF
(0) : WorldOfWarships.exe!0x01A0BC24
(0) : WorldOfWarships.exe!0x01A0CAF6
(0) : WorldOfWarships.exe!0x01A0CB61
(0) : WorldOfWarships.exe!0x01A0C9B4
(0) : WorldOfWarships.exe!0x01B0F298
(0) : WorldOfWarships.exe!0x01B0F4F1
(0) : WorldOfWarships.exe!0x019868F4
(0) : WorldOfWarships.exe!0x013045CB
(0) : WorldOfWarships.exe!0x016B712B
(0) : WorldOfWarships.exe!0x016C14CB
(0) : ucrtbase.dll!0x7706AA5D
(0) : KERNEL32.DLL!0x747F8654

System info:
    OS Name: Windows 8.1 or later
    OS Version: 6.6 
    OS Architecture: x86_64


Memory info:
    Virtual memory: 3018660Kb/4194176Kb (72%)
    Working set (process physical memory): 2453968Kb/4194176Kb (58%)
    Commit charge (working set + process page file usage): 2542316Kb/4194176Kb (60%)
    Global physical memory: 6415504Kb/67035856Kb (9%)
    Global commitable memory (physical + pagefile): 268357268Kb/268362448Kb (100%)


System info:
COMPUTERNAME = ALEXPC
APPLICATION = "C:\\Games\\World_of_Warships_EU\\WorldOfWarships.exe" 
12 PROCESSOR(S) = 0 - 6 9e0a
DISPLAYDEVICE 0 = \\.\DISPLAY1, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1
DISPLAYDEVICE 1 = \\.\DISPLAY2, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1
DISPLAYDEVICE 2 = \\.\DISPLAY3, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1
DISPLAYDEVICE 3 = \\.\DISPLAY4, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1


Extended info:
Current thread #5844 native trace:
(0) : WorldOfWarships.exe!0x016B1A3D
(0) : WorldOfWarships.exe!0x016B0FF6
(0) : WorldOfWarships.exe!0x016B0DAA
(0) : WorldOfWarships.exe!0x016B0E90
(0) : KERNELBASE.dll!0x7574D770


Frozen threads:

 

 

Application C:/Games/World_of_Warships_EU/WorldOfWarships.exe crashed 12.01.2017 at 19:52:23

Message:
The BigWorld Client has encountered an unhandled exception and must close (EXCEPTION_ACCESS_VIOLATION : 0xC0000005 @ 0x0041720E) (Read @ 0x00000000)
Current thread #860 native trace:
(0) : WorldOfWarships.exe!0x0041720E
(0) : WorldOfWarships.exe!0x00AF4139
(0) : WorldOfWarships.exe!0x00A5BE69
(0) : WorldOfWarships.exe!0x00391599
(0) : WorldOfWarships.exe!0x00A943F7
(0) : WorldOfWarships.exe!0x00A89284
(0) : WorldOfWarships.exe!0x009741E9
(0) : WorldOfWarships.exe!0x006C90FE
(0) : WorldOfWarships.exe!0x0095648D
(0) : WorldOfWarships.exe!0x00954B90
(0) : WorldOfWarships.exe!0x00923293
(0) : KERNEL32.DLL!0x77D58654

System info:
    OS Name: Windows 8.1 or later
    OS Version: 6.6 
    OS Architecture: x86_64


Memory info:
    Virtual memory: 3045184Kb/4194176Kb (73%)
    Working set (process physical memory): 2546112Kb/4194176Kb (60%)
    Commit charge (working set + process page file usage): 2633024Kb/4194176Kb (62%)
    Global physical memory: 9164832Kb/67035856Kb (13%)
    Global commitable memory (physical + pagefile): 268357304Kb/268362448Kb (100%)


System info:
COMPUTERNAME = ALEXPC
APPLICATION = "C:\\Games\\World_of_Warships_EU\\WorldOfWarships.exe" 
12 PROCESSOR(S) = 0 - 6 9e0a
DISPLAYDEVICE 0 = \\.\DISPLAY1, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1
DISPLAYDEVICE 1 = \\.\DISPLAY2, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1
DISPLAYDEVICE 2 = \\.\DISPLAY3, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1
DISPLAYDEVICE 3 = \\.\DISPLAY4, NVIDIA GeForce GTX 1080 Ti, PCI\VEN_10DE&DEV_1B06&SUBSYS_1B0610B0&REV_A1


Extended info:
Current thread #860 native trace:
(0) : WorldOfWarships.exe!0x006C1A3D
(0) : WorldOfWarships.exe!0x006C0FF6
(0) : WorldOfWarships.exe!0x006C0DAA
(0) : WorldOfWarships.exe!0x006C0E90
(0) : KERNELBASE.dll!0x77B5D770


Frozen threads:

 

Share this post


Link to post
Share on other sites
Players
490 posts
1 hour ago, Skycat79 said:

@Anthoniusii It seems the Big World Engine isnt in Christmas Mood :Smile_playing: look the same Issue (but less detailed) i posted a few Posts above you. Since we are all using Different Setups (Computers and Parts) it must be something with the Engine itself?! But this Bug, or Crash... now causes me 10 Times crashed in a Row. Which is rather annoying.

True...Everything have been being more and more unstable since the 1st patch that introdused DX11 graphics in the game that seams have been done without the proper preparation and testing from WFstaff,

Being a modder my self, a slight texture, shader , model, script or code mistake causes CTDs to the entire game. I have asked many times WG if the game is no longer suitable for older PCs but now i see that better and stronger PCs than mine have the same problems. If WoWs is a heavy game then whatis Attila TW in extreme graphics in DX11? that plays without any issue in my GeForce GTX 660 2G ? :Smile_sceptic:

Share this post


Link to post
Share on other sites
Beta Tester
452 posts
8,129 battles
3 minutes ago, Anthoniusii said:

True...Everything have been being more and more unstable since the 1st patch that introdused DX11 graphics in the game that seams have been done without the proper preparation and testing from WFstaff,

Being a modder my self, a slight texture, shader , model, script or code mistake causes CTDs to the entire game. I have asked many times WG if the game is no longer suitable for older PCs but now i see that better and stronger PCs than mine have the same problems. If WoWs is a heavy game then whatis Attila TW in extreme graphics in DX11? that plays without any issue in my GeForce GTX 660 2G ? :Smile_sceptic:

In my case the PC is top high end, the reason i wondered even more because with my older PC i had a game crash maybe every 100 or 200 battles. Now with the latest top notch high end PC every 2 games. 

Share this post


Link to post
Share on other sites
Players
234 posts
1,189 battles
On 30/11/2017 at 0:01 PM, Marcedus said:

1. Description

Unique captain voices is still broken/unavailable.

Same issue.

Playing without Kongou-chan just isn't the same. :(

Share this post


Link to post
Share on other sites
[TFZ]
Players
99 posts
4,960 battles

1. Description

The "Number of ships targeting you" indicator for the Priority Target Captain skill is not appearing when your ship is being targeted by an enemy ship; despite having the skill assigned to my Captain.

 

I have only witnessed this in the new Operation: The Ultimate Frontier so far.

 

2. Reproduction Steps

Pick a ship whose Captain has the Priority Target (e.g. my Shchors); enter Operation; get targeted and shop at by one of the enemy (AI) ships. You will see that despite the fact your ship is clearly being targeted by the enemy ships, the Priority Target indicator is not working.

 

3. Result

You will see that despite the fact your ship is clearly being targeted by the enemy ships, the Priority Target indicator is not appearing with a number to indicate how many ships are targeting you.

 

4. Expected result

A number appears to indicate how many ships are targeting you.

 

5. Technical Details

Witnessed on 01/12/2017 at circa 23:30 GMT. Please see attached replay for an example.

20171201_233124_PRSC107-Schors_s06_Atoll.wowsreplay

Share this post


Link to post
Share on other sites
[DECOM]
Beta Tester
346 posts
7,741 battles

my game


the game freezes in connect screen after getting disconnected, everytime i disconnect, i cant reconnect back, and i have to shut down the game via task manager, happens with any ship and everytime 

Share this post


Link to post
Share on other sites
Players
2 posts
3,572 battles

1. Description

Map tearing on "The Atlantic", Ship taken: Tirpitz, Only appears from certain angles.

 
2. Reproduction steps

Spawned around I-5/6, and began sailing towards A. First noticed the bug when zoomed in, both onto the ship, and in the aiming reticle zoom.

 
3. Result

Link to screenshots - https://imgur.com/a/xB2NN

 
 

Share this post


Link to post
Share on other sites
[ITAAT]
Players
703 posts
On 30/11/2017 at 9:20 AM, Fubucky said:

1. Description

The game crashes at the end of every match.

 
2. Reproduction steps

Play the game. wait until it ends. it crashes the moment the game ends, not allowing me to see the results screen.

 
3. Result

Game crash.

 
4. Expected result

Game shouldnt have crashed.

 
5. Technical details

Leaving the crashlog

 

error.thumb.png.146d71d8488d9f44f6fb0ab9bd7ec16c.png

crashes.rar

 

The best is that few updates ago, even crashing, you were able once logged back in, to see the summary of your last battle in the notification window bottom right, but without any explanation or notification has been eliminated... I even asked why in a post.... guess what? no answer. Amazing!

Share this post


Link to post
Share on other sites
[HOG]
Players
20 posts
3,269 battles
22 hours ago, Needy_Game said:

my game


the game freezes in connect screen after getting disconnected, everytime i disconnect, i cant reconnect back, and i have to shut down the game via task manager, happens with any ship and everytime 

Identical issue.

Share this post


Link to post
Share on other sites
Players
43 posts
9,774 battles

 

 1. Description

Z46 spotting / detection range error. same as previous version

in many games in z46 with concealment of 94 (5.9km), i am spotted by dd with less concealment rating before they are spotted by me. Usually Yugumo with 93 (6.3km)  but i have seen it happen with Fletcher 92 (6.4km) also.

I always check opposition concealment ratings and for radar ships at start of game. when i am detected there is no icon for radar or hydro and i am not in the firing timer

 

After investigation i found that with upgraded concealment,  there is no increase the concealment rating after adding the 3% camouflage ( the distance value changes but not the rating)

eg

z46 without cammo = 94 / 6.1km

z46 with cammo = 94 / 5.9km

(I checked other German dds and same for maass and z23.)

 

I raised this as a ticket and was told its due to the small distance being less than 1% so is not added but all other ships do change even kagero changes 1% for 100m (97 to 98 rate) so don't think its that reason.

 

Don't know if this is related to the in game spotting / detection problem but it does not happen with any other dd i play with ( non German)


2. Reproduction steps

happens in every game if nearly same % concealment

 
3. Result

get spotted by dds i should not be spotted by

 
4. Expected result

have correct concealment for cammo and not get spotted by dds with less concealment and spot them 1st

 
5. Technical details

94 and 6.1.jpg

94 and 5.9.jpg

Share this post


Link to post
Share on other sites
[BABBY]
Beta Tester
1,596 posts

1. Description

HSF commanders don't have their unique voiceovers in battle.

 
2. Reproduction steps

Enter battle with HSF Harekaze or HSF Admiral Graf Spee.

 
3. Result

Voiceovers correspond with each ship's base nation rather than the commander (Japan/Germany).

 
4. Expected result

HSF voiceovers to play.

 
5. Technical details
- Voiceover language is set to English (United Kingdom).

- Voiceover modification is set to National.

- I have HSF set to visible in the "things i (dont) want to see" menu.

- I am using camouflage other than the HSF skins.

- I haven't changed these conditions before or since the update.

 

 

Won't be playing anymore until this is fixed, I guess I may because of HMAS Vampire, but eh. And this may be my last bug report. You are just too incompetent to continue supporting in any way.

Share this post


Link to post
Share on other sites
[GUNUP]
Weekend Tester
582 posts
35,316 battles

Guys for Real, fix this Issue with the BigWorld Client. It drives me Bonkers. Every 2 Games the same
The BigWorld Client has encountered an unhandled exception and must close (EXCEPTION_ACCESS_VIOLATION ) - THIS!!!

How many Reports does it need, to be fixed? You cant play the Game if it crashes every 2 Battles :etc_swear:

Share this post


Link to post
Share on other sites
[TORAZ]
Beta Tester
14,585 posts
20,730 battles

1. Description

Unable to start planes on Saipan after they finished servicing.

 
2. Reproduction steps

Unknown how exactly to reproduce. Unknown if it only affects the Saipan either, but I haven't encountered it on any other CV yet.

1. Enter a match with a Saipan.

2. Play the match as normal.

3. Bug may or may not appear.

 
3. Result

Planes are displayed to be in the launch queue even if no other plane is taking off, therefore will not launch.

 
4. Expected result

Planes should be launching.

 
5. Technical details
Screenshots:

Spoiler

World_of_Warships_Screenshot_2017.12.03_

World_of_Warships_Screenshot_2017.12.03_

World_of_Warships_Screenshot_2017.12.03_

World_of_Warships_Screenshot_2017.12.03_

 

As you can clearly see, planes are displayed to be in queue despite no other squad currently launching and won't start taking off.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×