Jump to content
Torped1ne

0.6.9 on linux

7 comments in this topic

Recommended Posts

[IRN]
Players
309 posts
12,029 battles

Here we are this patch is out and as expected the wine setup that we used do not work anymore, im not an expert so i hope on someone else knowledge so i've created this topic to share our attemps 

Right now i have try with the last staging version of wine 2.13 and it run until login screen for crash one second after the log in

Share this post


Link to post
Share on other sites
[F_N_E]
Players
31 posts
18,505 battles

I experienced this issue with the recent public test and now with the regular client as well. I read about a switch to DirectX11 from this patch on, only Intel GFX users are said to have DirectX9 in use. So if there's a way to switch back, this could temporarily repair the issue for Wine/Linux users.

Share this post


Link to post
Share on other sites
Beta Tester
26 posts

No joy unfortunately, crashes with an unhandled exception upon trying to enter port. Tried various wine versions (32 and 64bit) various graphical settings (including dx11/dx9) :(

 

Was eyeing up various premiums last night as well, glad I didn't buy them now. Had it running perfectly yesterday, now they patch and break everything.

Share this post


Link to post
Share on other sites
Players
9 posts
2,554 battles

I have a potential resolution for you guys using Wine, this has been discussed on Wine HQ so I take no credit for this.

 

It looks like the game is looking for a ProgramData folder using the PROGRAMDATA environment variable which does not exist in Wine, really Wargaming should be adding checks for Null pointers.

 

Anyway, how I have done it to resolve on my system.

 

Open the prefix you have created your WOWS install and under what is the C: drive add a ProgramData folder.

 

Open wine regedit and under HKEY_CURRENT_USER/Environment add a veriable called PROGRAMDATA pointing to the C:\ProgramData folder you previously created.

 

Run game, play and enjoy!

  • Cool 3

Share this post


Link to post
Share on other sites
Players
9 posts
4,555 battles
2 hours ago, Rebus01 said:

I have a potential resolution for you guys using Wine, this has been discussed on Wine HQ so I take no credit for this.

 

It looks like the game is looking for a ProgramData folder using the PROGRAMDATA environment variable which does not exist in Wine, really Wargaming should be adding checks for Null pointers.

 

Anyway, how I have done it to resolve on my system.

 

Open the prefix you have created your WOWS install and under what is the C: drive add a ProgramData folder.

 

Open wine regedit and under HKEY_CURRENT_USER/Environment add a veriable called PROGRAMDATA pointing to the C:\ProgramData folder you previously created.

 

Run game, play and enjoy!

Don't take too much credit, but you're my hero today.

 

It works!

Share this post


Link to post
Share on other sites
Players
9 posts
4,555 battles

So, to make an current howto play world of warship on linux, here's the deal :

 

  1. Download the worldofwarship windows installer
  2. Install playonlinux
  3. In playonlinux, get the latest version of wine staging in 32bits & 64bits. Currently, 2.13 is ok with wows 0.6.9
  4. In playonlinux, click install :
    1. then "install an unlisted program"
    2. then "in a virtual disk"
    3. type a dull name
    4. then select "change wine version" & "configure wine"
    5. in the wine version selector popup that appeared :
      1. select the last version you installed
      2. then select it in 64bits
    6. in the wine configuration popup that appeared next :
      1. select a recent windows version like win 8.1
    7. select worldofwarships.exe and install it. Let the downloader download & update the game. If it crashes, let it restart.
      but when finished don't launch the game. Also close the systray update. (ultra is ok)
    8. Create a shortcut to WoWSLauncher
    9. End the install process.
    10. Open playonlinux configuration for your new shortcut
      1. In the display tab, set your video memory ammount to the correct value.
      2. In the "wine" tab, click "registry editor"
        1. Create a new chain value in /HKEY_CURRENT_USER/Environment named "PROGRAMDATA" containing "C:\ProgramData"
      3. In the "wine" tab, click "reboot windows" (you might want to hit that button again when you have ingame crappy distorded sound)
    11. mkdir ~/.PlayOnLinux/wineprefix/YOURDULLNAME/drive_c/ProgramData/
    12. Bonus : open a playonlinux console
      1. type POL_Debug_ErrorSilent YOURSHORTCUTNAMEINPLAYONLINUX
    13. Actually proceed to launch the game. Don't login yet, click on the wheel in corner to open wows configuration.
      1. In "video settings" set the game to directx 9 or it will be glitchy.
      2. Start with the lowest graphic settings, but i had no problem running high settings (except the fps). You'll increase the settings gradually to match your setup. Be gentle too with aa.
    14. Login, enjoy, and don't pull too mutch notsers.
  • Cool 6

Share this post


Link to post
Share on other sites

×