Jump to content
You need to play a total of 50 battles to post in this section.
kodos

World of Warships & Linux (guide)

87 comments in this topic

Recommended Posts

Players
441 posts
16,040 battles

I set post processing to High now. I have always had it off since its caused other problems like Big Race going black.

But two matches and back to port button works so that seems to improve it. I dont know yet if it always works but its better.

 

EDIT:

I just selected a T3 ship and Got Big Race. Its  NOT BLACK! :D

 

Played Big Race, game crashed back to port after that match.

 

So its back to "normal", I can play 2-4 matches then it crashes going back to port.

 

Still wish the dam thin would stop crashing back to port randomly, didn't do that prior to 0.5.5.

Edited by G3Virus

Share this post


Link to post
Share on other sites
Players
441 posts
16,040 battles

What ever they did in 0.5.13 removed the crash when going back to port every 3:e game or so.

Now in 0.5.14 it has  regressed and the bug is back.

 

In earlier version of the game, pre 2016 the bug was not there either so.

Share this post


Link to post
Share on other sites
Players
441 posts
16,040 battles

Yes thats why it not longer crashes every game just every 3:e going back to port.

 

Running wine 1.9.20 before, also upgraded to 1.9.22 yesturday but no difference. I know from reading on the net that the bug seems to be a windows bug acording to some wine devs post I read but its a LOT more common under wine then native windows. And this adds up since I read "windows" reports about the same problem.

 

Basicly the game has bugs, it just a lot more unstable under wine and realy the only people can fix it is WG.

 

Im not gonna install som relic version of wine thats for sure.

Edited by G3Virus

Share this post


Link to post
Share on other sites
[LEOND]
[LEOND]
Alpha Tester
1,193 posts
5,212 battles

it is a windows/directX bug

but my game runs fine at the moment

1.9.20 staging, installed d3dx9 (it needs all of them), d3dcompiler43, vcrun2012, msxml6, dotnet3.5sp1

Edited by kodos

Share this post


Link to post
Share on other sites
Players
441 posts
16,040 battles

d3dcompiler_43 or msxml6 completely broke the game for me, wont even start now so restored my settings from a backup.

Edited by G3Virus

Share this post


Link to post
Share on other sites
Supertester
374 posts
3,435 battles

Is anyone running WoWs on Linux since 0.6.2? I am really interested if this works ok on an AMD system (cpu and gpu).

Share this post


Link to post
Share on other sites
Players
441 posts
16,040 battles

It completely broke for me after 0.6.0, just got a single cryptic line giving no useful debug info.

Everything else works under wine as usual so dont know what broke it and still dont.

 

Nowadays I run it using QEMU so hardware virtualisation, just got my self a new RX 460 card dedicated to the Virtual Windows 10 machine.

 

Wine is just lagging more and more behind, no working DX10,11 and 12 support, Vulkan works but hey only game I ever managed to run was Doom using that.

I have been using Wine and cedega back since 2001 but unless they get at least DX11 support this year I dont see it working for gaming much longer.

having a virtual machine just made things a LOT easier and I can now run games I never could under wine and best of all, my system still runs linux and I can keep running it and windows in parallel.

 

My suggestion, If your motherboard and CPU supports VT-d or VT-x and IOMMU get a second graphics card and set up a Virtual machine.

 

For what ever reason at least I got a free Windows 10 license to under QEMU so no extra cost there either.

 

Virtualisation is the future and what I will keep using, faster, more stable and the extra cost is still less then a console for the same performance considering you already have to buy everything else except another GFX card, more features are optional.

Edited by G3Virus

Share this post


Link to post
Share on other sites
[LEOND]
[LEOND]
Alpha Tester
1,193 posts
5,212 battles

did not play for several months, got back with 6.4, changed nothing but upgraded to wine 2.5

no problems with the game so far

Share this post


Link to post
Share on other sites
[LEOND]
[LEOND]
Alpha Tester
1,193 posts
5,212 battles

fps are stable at 75 (max game fps by default)

played several games now on 6.4, no problems so far

Edited by kodos

Share this post


Link to post
Share on other sites
Supertester
374 posts
3,435 battles

fps are stable at 75 (max game fps by default)

played several games now on 6.4, no problems so far

 

please give me some more details, like GPU, Driver, OS and Wine version and Configs, it can be a message as well. thanks. 

Share this post


Link to post
Share on other sites
[LEOND]
[LEOND]
Alpha Tester
1,193 posts
5,212 battles

mint 17, GTX660, i5 6600k

nvidia 370.28

wine 2.5 staging

winecfg: win7, csmt enabled, virtual desktop full screen

winetricks: d3dx9, d3dcompiler43, vcrun2012, msxml6, dotnet3.5sp1 (need older wine version to install corrctly)

 

Share this post


Link to post
Share on other sites
Players
0 posts
7,256 battles

 

Hi,

 

Current status:

0.6.6.0 isn't working for me on OpenSuse.

 

WoWs Version: 0.6.6.0

WINE version:2.6

Operation System:  OpenSuse Leap 42.2

Compatibility: Red

 

Issues:

Crashes at launch

pVVNLBf.png

 

Previous version worked though:

 

WoWs Version: 0.6.5.0

WINE version:2.6

Operation System:  OpenSuse Leap 42.2

Compatibility: Green

 

How I made it  work

1) Install using the default PlayOnLinux script

2) Change WINE version to 2.6

3) Start launcher, disable "enable update seeding"

 

Issues:

Some mods from Ashlain's mod pack didn't seem to work properly

 

 

Share this post


Link to post
Share on other sites
[RBMF]
Moderator
501 posts
6,713 battles

Hi,

 

Current status:

0.6.6.0 isn't working for me on OpenSuse.

 

WoWs Version: 0.6.6.0

WINE version:2.6

Operation System:  OpenSuse Leap 42.2

Compatibility: Red

 

Issues:

Crashes at launch

pVVNLBf.png

 

Previous version worked though:

 

WoWs Version: 0.6.5.0

WINE version:2.6

Operation System:  OpenSuse Leap 42.2

Compatibility: Green

 

How I made it  work

1) Install using the default PlayOnLinux script

2) Change WINE version to 2.6

3) Start launcher, disable "enable update seeding"

 

Issues:

Some mods from Ashlain's mod pack didn't seem to work properly

 

 

I'm not a linux guy, but I've been getting that error in the past and it generally comes from your anti-virus or firewall. Any chance a program could be blocking it? 

Share this post


Link to post
Share on other sites
Players
0 posts
7,256 battles

 

I'm not a linux guy, but I've been getting that error in the past and it generally comes from your anti-virus or firewall. Any chance a program could be blocking it? 

 

Thanks, I have already tried disabling VPN, and being linux, i run no anti-viruses.

It is currently updating in the background. Will report back when it is done.

 

Grab the latest commit and use it with tools->custom script because the PlayonLinux installer isn't up to date:it still uses an old WINE version and more importantly, the installer exes' url were changed by WG and the updated link hadn't been accepted to the official script.

the WINE version can be edited in either the bash script before execution or after the install via the GUI.

 

the updater also crashes when seeding is enabled.

Edited by LEMMEIN

Share this post


Link to post
Share on other sites
[SPAM-]
Players
128 posts
6,138 battles

Hi, I've got exactly the same crash since 0.6.6 with the following:

 

Wine: 1.7, 2.0

OS: Devuan Jessie (with backports repository)

GPU: Nvidia GTX960, binary drivers 375.66

 

No solution yet :wander_cap:

Share this post


Link to post
Share on other sites
Players
0 posts
7,256 battles

I was told in PM that the game works if installed through WINE only, without the use of Play On Linux. I have failed to complete the installation that way. Yet.

Share this post


Link to post
Share on other sites
Players
4 posts

Game working again after installing dotnet40 via winetricks,  actually don't install (installer say new version already installed) but game after this working, i try in clean(backuped) prefix install all dependencies installed by  donten40  but without help.

 

UPDATE:  set emulated windows version in winecfg to  2008 R2 or windows 10 (probably 8/8.1 works too) and game working again nothing else is needed.  

 

 

Edited by anonym_9dRm3TqLKPmR

Share this post


Link to post
Share on other sites
[LEOND]
[LEOND]
Alpha Tester
1,193 posts
5,212 battles

I confirm that everything works fine with wine set to win8.1

Share this post


Link to post
Share on other sites
[SPAM-]
Players
128 posts
6,138 battles

Indeed! I switched windows 8.1, and it works fine. This is such a simple solution, now that we know about it! Thanks Lathanderjk for the troubleshooting!

Share this post


Link to post
Share on other sites
Supertester
374 posts
3,435 battles

Any one of you guys be nice enough to give me a step-by-step in a PM? I am not familiar with wine-only installations, but i would really like to make it work. Thanks in advance. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×