Jump to content
  • 0
Sign in to follow this  
gf333

Ships lost

7 comments in this topic

Question

Players
3 posts
431 battles

Had problems with my computer. was unable to play for some months. today i downloaded the game again. logged in to my account. and every ships i have was gone. only tier 1 ships. what has happen. is my ships gone forever. sucks to loose tier 6-8 ships and start from the beginning


 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
[NED]
Players
4,179 posts
11,667 battles

You probably have played on another server. On this 1 (EU) it's saying you haven't played 1 at all. (or you're a troll, in that case I fell for it again!)

Share this post


Link to post
Share on other sites
  • 0
Players
3 posts
431 battles

i am not sure wich server i have been playing on. strange if it is not europe. live in Norway. but it is before Christmas since i played last time.

Share this post


Link to post
Share on other sites
  • 0
[BYOB]
Players
3,037 posts
10,972 battles

You previously were playing on the North American server (a quick check on wows-numbers.com shows that).

Share this post


Link to post
Share on other sites
  • 0
Players
3 posts
431 battles

Anyone knows if it is possible to move the ships to the EU server. Guess the ping will be better on EU

Share this post


Link to post
Share on other sites
  • 0
[W-C]
Beta Tester, Players, In AlfaTesters
2,287 posts
6,156 battles

I'm almost certain you can't

Share this post


Link to post
Share on other sites
  • 0
[T-N-T]
[T-N-T]
Weekend Tester, Players, In AlfaTesters
3,797 posts
9,190 battles

Anyone knows if it is possible to move the ships to the EU server. Guess the ping will be better on EU

 

Write ticket to support they may help you to switch server but I will not give it to much hope.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×