Jump to content
Sign in to follow this  
Holyqueef

joined the game through refer a friend but didnt receive half the rewards

9 comments in this topic

Recommended Posts

Players
2 posts
657 battles

hey guys, im new to the game and registered using my friends referral link. i received the diana after my first game and got my 7 days premium so no problems there.

however i just reached my first non-premium tier 6 ship today (HMS Leander) and played some games. i realised that i havent recieved the USS Texas or any of the other rewards for reaching a tier 6 ship i was supposed to receive. is this a bug and does anyone know how i can go about fixing it? any help would be appreciated. thanks!

Share this post


Link to post
Share on other sites
[BYOB]
Players
3,073 posts
11,044 battles

Contact support by opening a ticket, they can clarify what went wrong. The link is at the top of the page.

Share this post


Link to post
Share on other sites
[_GG_]
Weekend Tester
261 posts
2,302 battles

I have one guy who used my link, I'll ask him if he had any problems with his reward. I got my rewards for it no problem, though.

Share this post


Link to post
Share on other sites
[NED]
Players
4,194 posts
11,706 battles

Haven't heard about this problem until now. Maybe it's taking some time before the info gets through (some batches perhaps). It took about 3 or 4 days before the kamikaze-R's were distributed with the Pearl event last year. Or maybe you need to re-enter the code to get Texas?

Share this post


Link to post
Share on other sites
[BYOB]
Players
3,073 posts
11,044 battles

did you also play atleast 1 match with a tier 6 ship as that is required to get the texas added to your account

 

 

He has played several tier VI matches, so that's not it. Probably some derpy issue with the system.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×