Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
kapawuwala

Windows 10 ruins his game

32 comments in this topic

Recommended Posts

[DMSPA]
Players
68 posts
3,778 battles

I have been away almost a year. Now I tried to play again and I am amazed by severe lags when I play under the uber crap  OS Windows 10.

Astoundingly I can play with the exact same settings smoothly this game with Wine under Linux!!  Unfortunately  there is another problem with crashes the game after every 3d-4th game, memory leaks probably.

 

I don't have Windows 7 anymore. Is this game really unplayable with the crap Windows 10 ??

Pity developers only tolerated Windows shits over the years and not developed a native Linux client.

Edited by nooboid

Share this post


Link to post
Share on other sites
[DREAD]
Players
453 posts
7,651 battles

I use Win 10 without any lag issues. But I have an exceedingly good computer and bleedingly fast interwebz, so that might help a bit.

 

(Win 7 was the better OS though) :(

Share this post


Link to post
Share on other sites
[SCRUB]
Beta Tester
773 posts
7,411 battles

No problem at all with win 10 for most people... If you update the video drivers and stuff after upgrading.

 

 

Share this post


Link to post
Share on other sites
[SCRUB]
Beta Tester
2,328 posts
5,717 battles

Works fine on 10 for me and most.  Your in depth diagnostic skills needs some refining...

  • Cool 3

Share this post


Link to post
Share on other sites
[HF_30]
Players
1,309 posts

Dunno....replace POL starter with script to restart the game automatically? Shouldn't be that hard, grep ps output for WOWS or so, check if it's running, if not trigger restart. Sorry, don't really have the time right now to look into it, but something along that lines.

Share this post


Link to post
Share on other sites
Weekend Tester
845 posts
4,533 battles

Works fine on 10 for me and most.  Your in depth diagnostic skills needs some refining...

 

Preaty much...

Share this post


Link to post
Share on other sites
[DMSPA]
Players
68 posts
3,778 battles

No problem at all with win 10 for most people... If you update the video drivers and stuff after upgrading.

 

 

Upgraded to latest, restarted, tested Cooperative - the same lags persist.

I have no desire to fix Windows 10 shits,  I guess will play under Linux ... until i get exasperated by the Wine crashes there. No time to lose ... restarting ...

Share this post


Link to post
Share on other sites
Beta Tester
871 posts
5,588 battles

I had no problems with Widows 7 but Windows 10 has been awful in many areas. WoW and WoT have seen numerous problems under Windows 10 for myself. We have to have few crap operating systems before they finally bring out a good one, that's how Microsoft work.

Share this post


Link to post
Share on other sites
[YARRR]
Beta Tester
7,381 posts
13,776 battles

Tried disabling GameDVR? (Part of the Xbox app, may limit your fps in games to 30 and in general cause ridiculous performance issues)

 

More info here: http://www.tenforums.com/tutorials/8637-game-bar-turn-off-windows-10-a.html

Note that to access the Xbox app you need to have a Microsoft account (a Skype account will also work since that's a MS account nowadays). Also tampering with the registry values never worked for me, it would always revert for some reason.

Share this post


Link to post
Share on other sites
Players
1,071 posts
8,134 battles

I have been away almost a year. Now I tried to play again and I am amazed by severe lags when I play under the uber crap  OS Windows 10.

Astoundingly I can play with the exact same settings smoothly this game with Wine under Linux!!  Unfortunately  there is another problem with crashes the game after every 3d-4th game, memory leaks probably.

 

I don't have Windows 7 anymore. Is this game really unplayable with the crap Windows 10 ??

Pity developers only tolerated Windows shits over the years and not developed a native Linux client.

 

Then play with Wine under Linux.

 

Problem solved, thread can be closed.

Share this post


Link to post
Share on other sites
Players
273 posts
2,278 battles

No problems with any of my comps under windows 10. 3 years old work laptop with intel integrated graphics and mobile internet can run this without lag on minimal settings.

 

Also 5 years old core i7 and slowish adsl internet and no lags normally. Last lag I got was some WG issue discussed widely here.

 

Windows 10 has no problems with this game. It is hw driver issue about 75% certainty. If you do not want to diagnose it then you don't, but no need to blame win 10.

Edited by KPtja

Share this post


Link to post
Share on other sites
[DAVY]
Players
1,534 posts
9,002 battles

no problems with Win10 for nearly a year now, both WoT and WoWs work fine...

Share this post


Link to post
Share on other sites
Alpha Tester
244 posts
10,580 battles

You can turn off many background programs, there are tutorials online, it will take you 10-20 minutes to make your PC work faster.

Share this post


Link to post
Share on other sites
Players
18 posts
3,493 battles

Obviously an inadequate PC, cos Windows 10 works better across each of the five devices in my house, and more smoothly, than any OS before it.

​WoT & WoWS both run without lag.

 

Share this post


Link to post
Share on other sites
Players
124 posts
2,008 battles

I'm using Windows 10, no problems whatsoever with any games (newer or older) or other apps. And imho it's the best Windows so far, a worthy successor of Windows 7 (in the line of "good" M$ OS).

Edited by periscope_up

Share this post


Link to post
Share on other sites
[PRAVD]
Players
1,096 posts
5,597 battles

That's why I only say Pan-paka-pan.

 

I have problems as well. Broadside low health Edinburgh, only a few clicks away, AP loaded and right at that moment the game crashed. Three times already today. To me it seems it's very patch-dependent. In 0.5.12 I had problems, in the few patches before that not. Neither in 0.5.12.1

Share this post


Link to post
Share on other sites
Alpha Tester
244 posts
10,580 battles

Win10 will create problems to people with weaker PC's and especially HDD's (with no SSD). But anyway, there are many backgound programs you don't need.

Edited by Slauter

Share this post


Link to post
Share on other sites
Beta Tester
467 posts
13,407 battles

Had windows 10 updating (downloading patches) creating lag and eventually pop ups telling me its time to restart - twice. Other errors have been than that my 3 months old puppet chewed over ip-cable, and once a fan fell out of the gfx-card, I also had my extra hard disk crash and die (my d: with game on) all made me believe it was windows at first.

Share this post


Link to post
Share on other sites
[_I_]
Beta Tester
14 posts
4,914 battles

When I upgraded to Windows 10 WoWS ran like a bag of crap until I updated my drivers, deleted and reinstalled it, that solved the problem for me.

 

Have you updated all of your drivers, etc for the new OS?

Share this post


Link to post
Share on other sites
[BONI]
Players
1,063 posts
9,298 battles

I'm using Windows 10, no problems whatsoever with any games (newer or older) or other apps. And imho it's the best Windows so far, a worthy successor of Windows 7 (in the line of "good" M$ OS).

 

The update system is extremely overbearing and lacks any kind of user control. I'd say that's a huge flaw.

 

Anyway, I've only ever playedit on W10 and the only issue I can think of is the microstutters when clicking things in port (which could be my connection). But yeah, as above, make sure graphics drivers are up to date, some games will chug if you're using an outdated version.

Edited by MoveZig

Share this post


Link to post
Share on other sites
Sign in to follow this  

×