Jump to content
Sign in to follow this  
greyfryer

chrome ?

7 comments in this topic

Recommended Posts

[-GGS-]
Alpha Tester
76 posts
4,235 battles

Yes, but you only downloading the lancher. after you have that the the lancher do the rest. 

  • Cool 1

Share this post


Link to post
Share on other sites
Players
257 posts
350 battles

Drop in a bit more information for us.

You downloaded the launcher and it's in your downloads folder yes? Did you double click to run it? 

 

You are using an operating system from 2001 when your average gaming pc had 512mb of ram, a Duron 800mhz CPU and a Geforce 2. 

Can you list your full specs here for us (the real ones). 

 

 

  • Cool 1

Share this post


Link to post
Share on other sites
Players
3 posts

Thanks guys I will have a look at the spec (real ones  ) and get back to you .

 

I strongly suspect that my computer needs an upgrade !!

 

Share this post


Link to post
Share on other sites
Players
257 posts
350 battles

Thanks guys I will have a look at the spec (real ones  ) and get back to you .

 

I strongly suspect that my computer needs an upgrade !!

 

 

Will take you 5 seconds.

Click Start - Run - Type dxdiag in the box, press enter and it will give you the spec of the CPU and Ram on the first page, then click Display on the top bar to get the GPU details. 

 

Plenty of people here (including myself) will be able to assist you if you need it. 

Share this post


Link to post
Share on other sites
[TMCB]
Players
51 posts
11,722 battles

Check you correctly downloaded the launcher, WoWS_internet_install_eu.exe should be 7.3mb in size.

 

If not correct, delete and try again.

 

Also, when you double click the file to run it, do you get nothing at all, or an error?

 

You may also want to check your firewall settings, to make sure it is allowed to access the internet.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×