Jump to content
You need to play a total of 50 battles to post in this section.
geohei

d3dx10_43.dll and Windows 7

9 comments in this topic

Recommended Posts

Players
3 posts

Hi.

 

Unbelievable that I didn't find any solution in this forum or using Google.

 

I use standard W7 SP1 x64 with all updates included (DirectX 11)!

Starting latest WoT results in the famous error message that d3dx10_43.dll is missing.

Installing it manually in WoT PROGDIR results in d3dx9_43.dll missing.

Installing that one as well manually in WoT PROGDIR results in 0xc000007b error.

I have a totally normal Windows 7. No patches or strange firework, and still ... WoT doesn't start.

 

Is it possible that WoT requires downgrade of DirectX to version 10 or even 9?

 

HELP!

 

Thanks,

Edited by geohei

Share this post


Link to post
Share on other sites
[W-C]
Beta Tester, Players, In AlfaTesters
2,302 posts
6,185 battles

If nothing else works try copying the d3dx9_43.dll and d3dx10_43.dll files into the installation folder...The game is probably just confused

Share this post


Link to post
Share on other sites
Players
3 posts

If nothing else works try copying the d3dx9_43.dll and d3dx10_43.dll files into the installation folder...The game is probably just confused

 

That's what I did already.

See initial posting (PROGDIR).

 

 

Yes ... that worked!

Do you know details why this wasn't installed already on my clean Windows 7 x64 system?

 

Many thanks!

Edited by geohei

Share this post


Link to post
Share on other sites
[KOKOS]
Beta Tester, Players
3,371 posts
8,811 battles

Hi.

 

Unbelievable that I didn't find any solution in this forum or using Google.

 

I use standard W7 SP1 x64 with all updates included (DirectX 11)!

Starting latest WoT results in the famous error message that d3dx10_43.dll is missing.

Installing it manually in WoT PROGDIR results in d3dx9_43.dll missing.

Installing that one as well manually in WoT PROGDIR results in 0xc000007b error.

I have a totally normal Windows 7. No patches or strange firework, and still ... WoT doesn't start.

 

Is it possible that WoT requires downgrade of DirectX to version 10 or even 9?

 

HELP!

 

Thanks,

 

You know this is the World of Warships forum, because you only mention World of Tanks in your post. :honoring:

  • Cool 1

Share this post


Link to post
Share on other sites
[130]
[130]
Players
10 posts
6,405 battles

 

That's what I did already.

See initial posting (PROGDIR).

 

 

Yes ... that worked!

Do you know details why this wasn't installed already on my clean Windows 7 x64 system?

 

Many thanks!

 

I've got the same problem a week ago...;-) No clue why this dll was missing.

Share this post


Link to post
Share on other sites
[SCRUB]
Quality Poster
2,979 posts
8,597 battles

 

Hi all,

 

We had similar thread before:

 

"d3dx9_43.dll is missint"

 

http://forum.worldofwarships.eu/index.php?/topic/37375-d3dx9-43dll-is-missint

 

 

The problem is that WoWs is DX9 game (i.e. using old old "Direct X" engine) you must manually install it!

 

 

Leo "Apollo11"

 

 

 

Share this post


Link to post
Share on other sites
Players
3 posts

You know this is the World of Warships forum, because you only mention World of Tanks in your post. :honoring:

 

Arghhh ... no, I missed that one! Sorry! Does WoT have a forum?

 

The problem is that WoWs is DX9 game (i.e. using old old "Direct X" engine) you must manually install it!

 

That's exactly what I was expecting.

In other words .. I just downgraded my Windows 7 DirectX system?

Edited by geohei

Share this post


Link to post
Share on other sites
[SCRUB]
Quality Poster
2,979 posts
8,597 battles

Hi all,

 

 

That's exactly what I was expecting.

In other words .. I just downgraded my Windows 7 DirectX system?

 

No - you now have both new and old DirectX - everything is OK!

 

 

Leo "Apollo11"

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×