Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
Cirrus4000

How to play Replays? Opens Game Centre instead of game

13 comments in this topic

Recommended Posts

[-WB-]
Beta Tester
156 posts
18,336 battles

Hi, Used to be able to play replay files but since a re-install, whenever I click on the replay file, or drag it to the worldofwarships.exe file, it just opens the Games Centre instead. I know others had this issue but no idea how it was resolved. There's an update pending to the client, but I want to record a game before I do this otherwise I'll not be able to watch it again. Any help? Thanks

Share this post


Link to post
Share on other sites
[BAD-A]
[BAD-A]
Beta Tester
2,070 posts

You are dropping them on the Launcher, not the executable. Best way is to go to your WoWs folder, find the .exe and shortcut it to desktop then you can drag n drop onto that instead.

 

image.thumb.png.fd53218ae9bbde19b049b7c49a092641.png

Share this post


Link to post
Share on other sites
[-WB-]
Beta Tester
156 posts
18,336 battles

Hi, thanks for the reply. I'm dropping on the WorldofWarships.exe file. This is the client EXE as far as I know. I did a search for others and there was a couple of WorldofWarships32.exe and WorldofWarships64.exe. I don't see anything for WoWs.exe. Which ever I use it just opens the game centre and tries to update the client. Any other ideas? I'd really like to get this working. It was an awesome game :)

Share this post


Link to post
Share on other sites
[THESO]
Beta Tester, Players, In AlfaTesters
4,099 posts
10,311 battles

You need to right click and open with. Don't drag and drop, but manually select the app. It's dumb but it works

Share this post


Link to post
Share on other sites
[-WB-]
Beta Tester
156 posts
18,336 battles

SV, I tried that as well with the same result. Actually this was the first method I tried, along with associating the reply with the exe and just dropping it. Nothing seems to work and it just opens the game centre. It's really frustrating as I had it working some time ago before I reinstalled. Is there anyway to disable the game centre and running the game without it?

Share this post


Link to post
Share on other sites
[-WB-]
Beta Tester
156 posts
18,336 battles

That didn't work unfortunately. I just brought the game centre back up and started to download the update. I don't know why WG don't implement a proper function for recording an playback. It's been like this for years...

Share this post


Link to post
Share on other sites
[BAD-A]
[BAD-A]
Beta Tester
2,070 posts

OK so here goes.....

 

Open game up as normal, go to game centre and run the game. When the game is running tab back to desktop, spot the WoWs icon on the task bar and right click 'pin'.

Shut game down again, now right click on the 'pinned' icon and find target, once there create shortcut to desktop ... et voila should have direct access to the .exe

Then feel free to 'unpin' from taskbar

 

Share this post


Link to post
Share on other sites
[BFS]
Beta Tester
2,170 posts
15,077 battles

This problem was reported a short while ago (a week or two) on the forum.  I was wondering what they were referring to so I tried to 'drag and drop' the replay file onto the game exe (not the center exe).   All that happened was the Game Centre launched!

 

I then did the same but with the Game Centre already started and was able to watch the replay OK.

 

Makes me wonder what they're doing at times!

Share this post


Link to post
Share on other sites
Players
1,328 posts
20,957 battles

As @BrusilovX said, we've had this very same issue talked about in the forum not long ago:

 

And yes, you must have WGC running when you open the replays, be it by drag and drop or by file association. The latter option isn't recommended because...

... i.e., you link the .wowsreplay file extension to the executable of one game version, so you're unable to play them if any ulterior update changes where the current executable is (or if you're trying to play one that belongs to an older patch, since 3 folders with different ones are kept within the \bin directory IIRC).

 

Salute.

  • Cool 1

Share this post


Link to post
Share on other sites
[-WB-]
Beta Tester
156 posts
18,336 battles

Hello All, Thanks for your comments and links to similar issues. I've read through them all but none of the solutions work for me. I don't know if this is because the client needs to be updated (which will mean the replay won't work when it's been updated) or something else. All that happens is the it starts the game centre, and if I try to start the replay again (either with open as or dropping on the WorldofWarships.exe, it just switches back to the game centre again and starts the update. I've taken a copy of the game folder and am now updating the main install. This way I at least have the older version available to experiment on. If anyone has any other suggestions I'll be grateful. Cheers

Share this post


Link to post
Share on other sites
[-WB-]
Beta Tester
156 posts
18,336 battles

Fixed! So I downloaded the update and let it install, than thought I would give the replay a go, so with the Game Centre running I opened the replay file with the clients exe, expecting it to say incorrect version, and it ran fine! Thanks for everyone's comments and help. Now, I just need to video capture it for posterity :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

×