Jump to content
You need to play a total of 50 battles to post in this section.
OldschoolGaming_YouTube

Cant access Premium store or Armoury in port?!

77 comments in this topic

Recommended Posts

Beta Tester
2,402 posts
13,570 battles

When I launch the game I cant access the Premium shop or Armory?! I just get the spinning wheel of WoW icon death and nothing happens. Anyone else have this problem? This has been going on for a couple of patches. I can access all the tabs at tops like tech tree etc and also the missions in the box top left, but the ones with golden signs dont open?

 

Kind of sucks now when there is free stuf in the Armory.......

  • Cool 2

Share this post


Link to post
Share on other sites
[CROHR]
Players
4 posts
7,563 battles

Looks like Igor is still sleepimg I cant access Armory, Premium shop nor News portal.

 

Some sort of compensation would be appreciated

  • Cool 3

Share this post


Link to post
Share on other sites
[PUPSI]
Freibeuter
13,008 posts
5 minutes ago, Winged_Cat_Dormant said:

Yes, same for everybody I would say.

no, many players don't have any problems. My main account can access everything while my second account has the same issues with armory etc. And it is not a client issue, I use the same client for both accounts. It seems the server crash yesterday had a bad influence on certain accounts...

 

but at least the access with normal web browser should work for everyone

  • Cool 2

Share this post


Link to post
Share on other sites
[NECRO]
Players
687 posts
5 minutes ago, Klopirat said:

My main account can access everything while my second account has the same issues with armory etc.

Lucky you. I am still looking for an account that hasn't those issues. :Smile_teethhappy:

Share this post


Link to post
Share on other sites
Players
229 posts
12,994 battles

At my place game itself works all other things does not Shop, Armory, Chat. If I log from web browser Shop and Armory works but not all the times...so something is def broken.

Share this post


Link to post
Share on other sites
Players
73 posts
3,072 battles

Clan tab, naval battle, armory, prem shop and clan chat are down for me. I had the naval battle enabled before the server crash and it is still counting my attempts, but i can't see how high the next exp objective for the ship i'm playing is and i can't disable it.

  • Cool 1

Share this post


Link to post
Share on other sites
[-MM]
Weekend Tester
345 posts
9,802 battles

Nothing available for me either - has been down since yesterday lunchtime when I popped for a game or two. Continued being down yesterday evening for most of my clan mates, although two were able to find people on chat, but had no clan chat. We managed to make a division using the guys who still have a chat server, but only they got a div chat window. 

 

So...

 

Armoury and store unavailable

Naval battles won't load

Clan section won't load

Can't create Clan Brawl teams, so we've missed an evening of that

 

It was being discussed on a CC Stream last night, and the streamer had told WG about it on the CC Discord server yesterday morning... 

Share this post


Link to post
Share on other sites
[NECRO]
Players
687 posts
13 minutes ago, _Dunc_ said:

It was being discussed on a CC Stream last night, and the streamer had told WG about it on the CC Discord server yesterday morning... 

Probable reaction: Let's just wait until the update adds further bugs on Tuesday before we waste our precious time with any efforts.

  • Cool 2

Share this post


Link to post
Share on other sites
Players
2,147 posts
16,474 battles
1 hour ago, Klopirat said:

no, many players don't have any problems. My main account can access everything while my second account has the same issues with armory etc. And it is not a client issue, I use the same client for both accounts. It seems the server crash yesterday had a bad influence on certain accounts...

 

but at least the access with normal web browser should work for everyone

 

 

Is one of those accounts in another region? (NA, CIS, SEA, etc)

Share this post


Link to post
Share on other sites
[CATCH]
Players
255 posts
13,157 battles
27 minutes ago, Cheeky_chappie said:

I had the naval battle enabled before the server crash and it is still counting my attempts, but i can't see how high the next exp objective for the ship i'm playing is and i can't disable it.

Same. Which is absolutely infuriating. As is the total lack of communication from WG.

Share this post


Link to post
Share on other sites
Players
2,147 posts
16,474 battles
4 minutes ago, CallmeMessi said:

People, people. If you don't have a Makarov in port you're not getting in. :cap_happy:

 

It should work for everyone, then.

 

Share this post


Link to post
Share on other sites
[LX]
Players
25 posts
12,884 battles
10 minutes ago, HARBINGER_OF_SKULLS said:

Probable reaction: Let's just wait until the update adds further bugs on Tuesday before we waste our precious time with any efforts.

 

Doubt very much that they are not desperately trying to fix this........no access to the Armory or Premium shop means nobody can spend any money.......good for us,but not a situation that WG will tolerate for long.

Share this post


Link to post
Share on other sites
Players
3,184 posts
15,676 battles
5 minutes ago, triumphgt6 said:

Trying uninstall and then re-install - will let you know if it works!

don't waste your time, it's WG's fault not yours, it's this new update all servers before the proper the proper date, so we can have a unified launcher, it's had problems the last two updates.

  • Cool 1

Share this post


Link to post
Share on other sites

×