Jump to content
  • 0
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
bluepanther99

Why GPU usage is very high on the main menu?

7 comments in this topic

Question

Players
2 posts
1,027 battles

Hi guys,

 

I have been playing WOW for the last 6 months or so and it annoys me that the GPU usage is always very high during menu or ship selection. However, during the actual gameplay, the GPU is not high at all. Bizarre right?

 

Has any of you guys encounter this issue? Any solution?

 

I'm using AMD Vega 56 and i7 6700k.

 

Thanks

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Players
2,746 posts
15,291 battles

Stronk coding skillz mate.:cap_haloween:

Ports are very demanding, designers desk is probably the least resource hungry.

With a mods you can make port just a pure black background.

Loading of different things still can be too long.

Share this post


Link to post
Share on other sites
  • 0
Players
2,154 posts
13,064 battles

There are 2 possible reasons that makes sense, everything else is hogwash.

  1. incompetence
  2. malicious intent

There can be NO other reason why this problem already exist for years and wasn't fixed yet. There is also no other logical reason why the game consumes more power in idle state (in port) than when you actually play the game.

 

'Solution': If you are in port and open the Armory the GPU load goes down to like 3%.

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
Players
2 posts
1,027 battles

Do you think they might be running a crypto mining? lol

 

but if it's been running for years and they don't even bothered to fix it.. that's like a serious design flaw

 

but I will change the background to designer desk instead. Thanks for the workaround

Share this post


Link to post
Share on other sites
  • 0
[THESO]
Beta Tester, Players, In AlfaTesters
4,104 posts
10,311 battles

It's just that the game is about as optimized as kansas is optimized for battle. WG is either incompetent or lazy, or just incapable of optimizing the game because they picked the wrong engine to make the game in.

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
Players
9 posts
4,967 battles
On 10/22/2020 at 12:55 PM, domen3 said:

It's just that the game is about as optimized as kansas is optimized for battle. WG is either incompetent or lazy, or just incapable of optimizing the game because they picked the wrong engine to make the game in.

That is so true - just loading into the armoury takes an age, even with an Evo 970 M.2. 

Share this post


Link to post
Share on other sites
  • 0
Quality Poster, In AlfaTesters
1,873 posts
14,712 battles
13 hours ago, _WarLord_7 said:

That is so true - just loading into the armoury takes an age, even with an Evo 970 M.2. 

This is because the armory is a webpage and the port UI features a slow, flash based integrated browser.

https://armory.worldofwarships.eu/en/

Share this post


Link to post
Share on other sites
Sign in to follow this  

×