Jump to content
Armory Maintenance - 30.11.2021 04:00 UTC Read more... ×
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
jim_99

Losing FXP from seemingly bugged upgrade prices

22 comments in this topic

Recommended Posts

[TUESN]
Players
17 posts
3,225 battles

I feel like I must be missing something here, but I've lost thousands of FXP now through misleadingly labelled upgrade prices.

 

For instance, today, Nassau shows 650 XP to upgrade the range.  But when I click on it, the price becomes 800 XP.  

 

Problem is, I have a reflex to click "yes" because I'm already comfortable with the price - and so in some cases the 5,000 XP upgrade I was happy to buy becomes 5,000 XP plus several thousand FXP I never expected to spend.  Am I missing something obvious or is this just a bug?

 

 

nassau_upgrade.jpg

  • Cool 3

Share this post


Link to post
Share on other sites
Players
12,666 posts
9,841 battles

Must be a "display" bug.

 

I went to check, and for every ship, the gunfire control system supposedly costs 6200XP - even for my FDG. In reality, its 25k tho, which is correct.

Or here for Vauquelin: Ofc the upgrade is not 6200 XP, but 17k which would be correct.

image.png.8706670a814a725feb48e3d70d2f970e.png

image.png.8c5e9cb23aaa393f0eb2fbb9136a96c6.png

 

And its ONLY the gun fire control system which is bugged

 

@MrConway @Crysantos

could you pass this along?

  • Cool 2

Share this post


Link to post
Share on other sites
[TUESN]
Players
17 posts
3,225 battles
12 minutes ago, DFens_666 said:

Must be a "display" bug.

 

I went to check, and for every ship, the gunfire control system supposedly costs 6200XP - even for my FDG. In reality, its 25k tho, which is correct.

Or here for Vauquelin: Ofc the upgrade is not 6200 XP, but 17k which would be correct.

 

 

And its ONLY the gun fire control system which is bugged

 

@MrConway @Crysantos

could you pass this along?

Thank you, glad I'm not going crazy.  I thought at first I must have just been tired and clicking without reading properly but finally caught it today and knew I wasn't imagining it. 

 

Frustrating how many FXP I wasted without realising what was going on but I guess at least it's sussed now.

Share this post


Link to post
Share on other sites
Players
222 posts
12,144 battles

Yep, I got caught out by this with the Jutland hull upgrade just recently. I figured they had changed the XP costs for some of the upgrades and just happily clicked the second research notice without actually reading it was taking about 15-20k of FXP.

 

I will be more cautious next time.

 

New UI already makes it harder to see if you've accumulated enough XP for the next upgrade/ship. Not a fan of it. Feels half baked, when you consider it has nothing in common with anything else, like Captain skills or flags & camo. Just means there's another separate menu to go through for information that was available from port previously.

  • Cool 2

Share this post


Link to post
Share on other sites
Players
8,523 posts
2 minutes ago, Commander_Ericson said:

Yep, I got caught out by this with the Jutland hull upgrade just recently. I figured they had changed the XP costs for some of the upgrades and just happily clicked the second research notice without actually reading it was taking about 15-20k of FXP.

 

I will be more cautious next time.

 

New UI already makes it harder to see if you've accumulated enough XP for the next upgrade/ship. Not a fan of it. Feels half baked, when you consider it has nothing in common with anything else, like Captain skills or flags & camo. Just means there's another separate menu to go through for information that was available from port previously.

 

It's a hassle. Another needless hassle is when you pick a ship from the tech tree it takes you to that equipment screen instead of port as was the case before.

  • Cool 4

Share this post


Link to post
Share on other sites
[POP]
Players
54 posts

I've noticed that some time ago. It is clearly some kind of display bug. I can replicate this bug quite easily. Just take two tech tree ships which have same module (say Gun Fire Control System, GFCS) not researched yet. Open Equipment-tab for ship 1. You can see the research price for GFCS. Now choose ship 2 and open Equipment-tab. It has got the same research price for GFCS, even if ship 1 is tier V and ship 2 is tier IX. Same goes to ships 3, 4 and 5 and so on, until you open the tab for ship which doesnt have upgrade for GFCS or you already have researched it. Then the research price is "reset" and now if you open Equipment-tab for ship 2, it shows its correct research price. 

 

  • Cool 1

Share this post


Link to post
Share on other sites
[WG]
WG Staff, Alpha Tester
3,393 posts
4,310 battles
11 hours ago, DFens_666 said:

Must be a "display" bug.

 

I went to check, and for every ship, the gunfire control system supposedly costs 6200XP - even for my FDG. In reality, its 25k tho, which is correct.

Or here for Vauquelin: Ofc the upgrade is not 6200 XP, but 17k which would be correct.

image.png.8706670a814a725feb48e3d70d2f970e.png

image.png.8c5e9cb23aaa393f0eb2fbb9136a96c6.png

 

And its ONLY the gun fire control system which is bugged

 

@MrConway @Crysantos

could you pass this along?

 

This sounds and looks like a mod issue to me, please try cleaning your client using the game center.

 

Mine:

image.png

Share this post


Link to post
Share on other sites
[POP]
Players
54 posts

MrConway:

 

I haven't used any mods ever in World of Warships and I still can replicate that bug.

Share this post


Link to post
Share on other sites
[TUESN]
Players
17 posts
3,225 battles
35 minutes ago, MrConway said:

 

This sounds and looks like a mod issue to me, please try cleaning your client using the game center.

 

I have never used any mods.  It isn't a consistent issue, it just happens sometimes, and then it will disappear again.

Share this post


Link to post
Share on other sites
[WG]
WG Staff, Alpha Tester
3,393 posts
4,310 battles
11 minutes ago, Notmi said:

MrConway:

 

I haven't used any mods ever in World of Warships and I still can replicate that bug.

 

8 minutes ago, jim_99 said:

I have never used any mods.  It isn't a consistent issue, it just happens sometimes, and then it will disappear again.

 

Then both of you please do me a favour and check if it is displaying incorrectly. If it is, take a screenshot and send a ticket including  a WGCheck report and we can investigate. Please feel free to send me the ticket ID as well.

Share this post


Link to post
Share on other sites
[POP]
Players
54 posts

Will do that after I got home. But have you tried to replicate it the way I described it in my first post in this thread (post #9)?

Share this post


Link to post
Share on other sites
[TUESN]
Players
17 posts
3,225 battles
22 minutes ago, Notmi said:

Will do that after I got home. But have you tried to replicate it the way I described it in my first post in this thread (post #9)?

You are spot on.  I just confirmed that my Shiratsuyu and Trento will "swap" prices.

Share this post


Link to post
Share on other sites
Players
1,254 posts
14,291 battles
1 hour ago, MrConway said:

 

This sounds and looks like a mod issue to me, please try cleaning your client using the game center.

 

Mine:

image.png

I'm running clean vanilla WoWS, and i have experienced this issue on my St Louis (T9 FR) on researching the hull yesterday. 
I will check if i can confirm the problem on some other module
 

Share this post


Link to post
Share on other sites
[TUESN]
Players
17 posts
3,225 battles
41 minutes ago, MrConway said:

 

 

Then both of you please do me a favour and check if it is displaying incorrectly. If it is, take a screenshot and send a ticket including  a WGCheck report and we can investigate. Please feel free to send me the ticket ID as well.

I've reported and sent.  

  • Cool 1

Share this post


Link to post
Share on other sites
Players
1,254 posts
14,291 battles
5 hours ago, MrConway said:

 

This sounds and looks like a mod issue to me, please try cleaning your client using the game center.

 

Mine:

image.png

Tiny bit of browsing on my tier 8s, and i've already found the first error. Clearly a big difference and quite wasteful if you're using free XP. 
I will report to support, i'm running completely clean vanilla WoWS

Grtz I_Y

image.thumb.png.14cdfaa968939ae3af47ecf89372038b.png

Share this post


Link to post
Share on other sites
[WG]
WG Staff, Alpha Tester
3,393 posts
4,310 battles
5 minutes ago, Isoruku_Yamamoto said:

Tiny bit of browsing on my tier 8s, and i've already found the first error. Clearly a big difference and quite wasteful if you're using free XP. 
I will report to support, i'm running completely clean vanilla WoWS

Grtz I_Y

image.thumb.png.14cdfaa968939ae3af47ecf89372038b.png

 

There is no need to report it anymore. It is indeed a bug and will be fixed with the next update. It is however only a display issue, the amount of XP needed is correct.

  • Cool 1

Share this post


Link to post
Share on other sites
Players
1,254 posts
14,291 battles
2 minutes ago, MrConway said:

 

There is no need to report it anymore. It is indeed a bug and will be fixed with the next update. It is however only a display issue, the amount of XP needed is correct.

Yeah i figure that the amount of XP needed is correct, and if i had used regular XP it wouldnt be so much of an issue to me

However, i normally only spend tiny amounts of free XP on upgrades, saving all my free XP for ships (i have the missouri, kronstadt, Musashi, Friesland and Hayate because of this policy), so if it had displayed correctly i wouldnt have researched the hull upgrade. 
I know i get a "confirm" pop-up, but normally that just says stuff i already know so it won't change what i was doing. 
In this case though i lost 20k FXP more than i meant to spend (23k instead of 4k), and thats a bit annoying. 
Not a very big deal, but still

Share this post


Link to post
Share on other sites
[BONUS]
Beta Tester
1,788 posts
On 8/17/2020 at 4:35 PM, MrConway said:

 

There is no need to report it anymore. It is indeed a bug and will be fixed with the next update. It is however only a display issue, the amount of XP needed is correct.

And what will happen to the spent Free XP of the volunteers that helped you research and identify this bug? :cap_money:

  • Funny 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

×