Jump to content
Server Maintenance - January 18, 6:00 CET (5:00 UTC) Read more... ×
Server Maintenance - January 18, 6:00 CET (5:00 UTC) Read more... ×
Sign in to follow this  
PleaseNottheFace

Weapons locked

19 comments in this topic

Recommended Posts

Weekend Tester
1 post
546 battles

Anyone had this little beauty yet? All the ships weapons lock in very random directions and you can't get them to aim or fire. As an added fun bonus, none of the damage control options work either!

shot-15.05.16_23.05.42-0141.jpg

Share this post


Link to post
Share on other sites
Players
2,279 posts
6,007 battles

It has happened to me too, all my guns in the Colorado locked. Dont know if my damage control options worked or not as I was not under enemy fire. 

 

Share this post


Link to post
Share on other sites
Beta Tester
131 posts
1,999 battles

Happened to me too. One of my guns just stopped traversing, and I could do nothing to help it. It would reload a different ammo type if I asked it too, but the repair button did nothing at all to fix it.

Share this post


Link to post
Share on other sites
[ST-EU]
Supertester
1,545 posts
469 battles

This is a known issue, if it happens again, please upload a copy of your python log, with the time of your battle. To fix the issue you will need to restart the game. Be aware that this may lock you out of the game until your battle has finished however as that's another issue which has been encountered >.<

Share this post


Link to post
Share on other sites
Beta Tester
57 posts
1,029 battles

Date/Time: 11:26 UK local time 17-5-2015

 

IV Phoenix - Guns not working, Gus not moving to 1 spot, Guns not moving on ship.(can still sail ship around) Torps not working either (cant fire).

 

Python log attached and some screenshots. 

 

 

python.zip

shot-15.05.17_11.21.34-0509.jpg

shot-15.05.17_11.23.21-0739.jpg

shot-15.05.17_11.22.30-0316.jpg

Share this post


Link to post
Share on other sites
[KOKOS]
Beta Tester
184 posts

Happened to me for the first time ever yesterday with a DD (Mahan, fully upgraded) after I installed Aslain's ModPack 0.2.4 activating various mods from it. Map: North. Problems as described by others: couldn't fire (LMB), couldn't target with my torpedo launchers or turrets (and neither zoom into any certain direction), couldn't lay smoke although the voice told me I just dd. I also wasn't able to change control settings. Steering and speed controls worked fine.

 

Strangely enough I didn't have any problems while playing a BB (New Mexico, fully upgraded) the match before. Couldn't be bothered to find out which of the mods caused it (since that was what I assumed), deinstalled the entire ModPack and was able to flawlessly play ever since.

 

Edit: Happened once again with a DD. Fully upgraded Fubuki. Map: North. Clean client. Funny enough in addition to not being able to trigger guns, torpedos and special skills I also couldn't steer right, just left.

Share this post


Link to post
Share on other sites
[GN0ME]
Beta Tester
5,339 posts
1,891 battles

happend to me aswell but i was able to command them to aim at a direction using cntrl+x but i couldnt fire use smoke or anything happend only once though dont have picture sorry will take one if it happens again

Share this post


Link to post
Share on other sites
Alpha Tester
34 posts
3,185 battles

Had the same, guns locked straight forward and aft. 

Ctrl-x gave me the option to turn guns, but never fire.

Share this post


Link to post
Share on other sites
[ST-EU]
Supertester
1,545 posts
469 battles

happend to me aswell but i was able to command them to aim at a direction using cntrl+x but i couldnt fire use smoke or anything happend only once though dont have picture sorry will take one if it happens again

 

The python log and replay would be more helpful than a picture :)

 

Edit: for those wondering, here's the main report of the issue so far:

 Description:

All inputs aside from basic camera/ movement controls are ignored by the client.

 

In-depth Description:

Loading a Co-op battle in the New Mexico on the north map. Once in the battle, you are able to move your ship forward, however the turrets do not turn or respond to mouse movements. By using "Ctrl+X" and "Shift+X" you are able to turn and lock the turrets into different directions and positions, however no controls respond to fire the guns (LMB & MMB). You are able to move the ship around (QWEASD), however all other controls do not respond. (tested: P, R, T). The ship will automatically fire it's secondary and AA guns and all shells fired work correctly. The ship is able to be set on-fire, and have flooding caused to it. The ship is able to take damage. You are able to set an auto-pilot course, as well as change into all camera types and modes (Free, "sniper", turret, and 3rd person). You are unable to repair or regenerate the ships health, despite the noise and icon activation appears as pressed (activation noise is heard, however there is no effect and the skill is not activated).

 

We know what happens, and what ships can do when they're experiencing the bug, what we don't know is what causes it to happen in the first place, hence the python log requests as they will likely contain the answer for the developers :)

Edited by Shepbur

Share this post


Link to post
Share on other sites
Beta Tester
1,716 posts

I've just had this happen to me in my New Mexico and I have no idea what a python log is.

 

I started the game and from the very start had no control of any turret or damage control, my secondary's fired but that was it. Wasted 3 pennants.

Edited by Aldramelech

Share this post


Link to post
Share on other sites
[ST-EU]
Supertester
1,545 posts
469 battles

I have no idea what a python log is.

Here's how to find the python log:

c:/games/World_of_Warships

 grnFNko.png

Then find the python log next to your preferences.xml file:

 A3jhKLb.png

 

Remove the log from the folder (don't worry, a new one is made each time you start the game), and place it into a zip file (right click-> send to -> compressed file), then upload it to the forums giving the time and date of the battle in which the issue occurred. The file can sometimes get quite large if you haven't deleted it recently, so you might need to upload it to an external site, else if you can understand the code you should be able to cut out past days which were still in the log record without any problem.

Share this post


Link to post
Share on other sites
Beta Tester
1,716 posts

View PostShepbur, on 19 May 2015 - 06:36 PM, said:

Here's how to find the python log:

c:/games/World_of_Warships

Spoiler

Then find the python log next to your preferences.xml file:

Spoiler

 

Remove the log from the folder (don't worry, a new one is made each time you start the game), and place it into a zip file (right click-> send to -> compressed file), then upload it to the forums giving the time and date of the battle in which the issue occurred. The file can sometimes get quite large if you haven't deleted it recently, so you might need to upload it to an external site, else if you can understand the code you should be able to cut out past days which were still in the log record without any problem.

 

OK, thanks.
 

19.05.15 New Mexico game 15.35 local UK time

 

Turrets and guns not responding at all, damage control not working at all.


 

python.zip

Edited by BigBadVuk

Share this post


Link to post
Share on other sites
Beta Tester
1 post
451 battles

Map: Ocean, Standard battle

Ship: New Mexico

around time 26.5.15 22:54

can't turn guns, shoot or reload, skills were also locked, but they do their sound when key was pressed. secondary weapons and ship control working properly

 

shot-15.05.26_22.54.27-0111.jpg

shot-15.05.26_22.54.12-0273.jpg

shot-15.05.26_22.55.45-0634.jpg

shot-15.05.26_22.55.53-0751.jpg

python.zip

Share this post


Link to post
Share on other sites
Beta Tester
1,989 posts
4,351 battles

Just happened to me in the Sims, both front guns not loading and stuck in about 90 degrees to starbord. Last battle from python file (starting 11:09 AM)

 

shot-15.05.28_11.15.09-0349.jpg

python.zip

Share this post


Link to post
Share on other sites
[PNAVY]
Beta Tester
146 posts
10,192 battles

i had the same in a destroyer, with 2 guns locked others working, and the reloading indicators showed not loaded, like in crooq_Lionfangs last pic

Share this post


Link to post
Share on other sites
Beta Tester
265 posts
17,486 battles

That turrets gettting locked happened to me a couple times as well... in every situation it was right after I targeted a plane for secondary guns (so right after clicking control+click on a squad I couldnt control my guns anymore)...

 

Also normaly when the squad I targeted moves out of range or disapears I regain control of the turrets again

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×