Jump to content
Server Maintenance - January 18, 6:00 CET (5:00 UTC) Read more... ×
Server Maintenance - January 18, 6:00 CET (5:00 UTC) Read more... ×
You need to play a total of 50 battles to post in this section.
pixelwarrior_1

Ships turns on its own

17 comments in this topic

Recommended Posts

Beta Tester
62 posts

Forgive if i posted this in wrong section wasn't sure where to post it. Does anyone else notice that your ship tends to turn on its own? Not sure if its a bug or not or a key binding problem but i can happily sailing along in a straight line when all of a sudden my ship starts turning. 

Share this post


Link to post
Share on other sites
[KOOKS]
Modder, Beta Tester
1,340 posts
3,342 battles

It tries to steer away from islands and such, and it is annoying because it goes the wrong way at times and you hit the bloody island if you do not pay attention.

Share this post


Link to post
Share on other sites
[SARMA]
Beta Tester
486 posts
2,428 battles

you can turn off the "auto avoid" (i forgot how its called) in the game settings menu.

Share this post


Link to post
Share on other sites
[CMP]
Weekend Tester
441 posts
3,818 battles

You can turn it off in the setting under controls :

LRotUTq.jpg

  • Cool 3

Share this post


Link to post
Share on other sites
[KOOKS]
Modder, Beta Tester
1,340 posts
3,342 battles

I looked for that last night, guess I was too tired to noticed. Nice one, thanks!

Share this post


Link to post
Share on other sites
Beta Tester
990 posts
3,372 battles

It would be nice to include an option to turn this off (in-match). 

 

The game's autopilot tries to help you by automatically steering away from island, but with multiple islands in front it usually calculates its evasive route based on the wrong island and makes you crash into another island. It's very annoying, especially when you've already manually steered your ship to pass through some gaps and then the autopilot takes over and still steers your ship right into one of the sides if you're not paying attention.

 

Just like AA there should be an option to situationally turn it off/on. 

Share this post


Link to post
Share on other sites
Weekend Tester
216 posts
1,856 battles

It would be nice to include an option to turn this off (in-match). 

 

The game's autopilot tries to help you by automatically steering away from island, but with multiple islands in front it usually calculates its evasive route based on the wrong island and makes you crash into another island. It's very annoying, especially when you've already manually steered your ship to pass through some gaps and then the autopilot takes over and still steers your ship right into one of the sides if you're not paying attention.

 

Just like AA there should be an option to situationally turn it off/on. 

 

In fact there are such options. Deactivate the "Collision Avoidance System" in the Controls menu. For the AA, press P on your keyboard and they will not shoot until you press P again. :coin:

Share this post


Link to post
Share on other sites
Beta Tester
42 posts
187 battles

Huh, I always thought it just made the siren sound, never noticed it trying to steer the ship.

Share this post


Link to post
Share on other sites
Beta Tester
990 posts
3,372 battles

 

In fact there are such options. Deactivate the "Collision Avoidance System" in the Controls menu. For the AA, press P on your keyboard and they will not shoot until you press P again. :coin:

 

Yes I know about the AA option, that's why I was referring to it. I was trying to say they should implement a similar in-match option to disable or enable autopilot steering depending on the situation you're in. 
  • Cool 1

Share this post


Link to post
Share on other sites
Beta Tester
2,286 posts
9,870 battles

am having trouble with the control I can not do ctrl and LMB to target the ships like dd end airplans h du you change this.

 

Theoldman.

 

EDIT: totally misunderstood you...

Edited by Troublemaker_CRO

Share this post


Link to post
Share on other sites
Beta Tester
172 posts
5,702 battles

I have suffered from this bug since I started playing, I turned collision avoidance off immediately but I find my ship turning itself all the time, usually at the most inappropriate moment.

 

Share this post


Link to post
Share on other sites
[SCRUB]
Alpha Tester
17,384 posts
5,400 battles

I have suffered from this bug since I started playing, I turned collision avoidance off immediately but I find my ship turning itself all the time, usually at the most inappropriate moment.

 

 

Move to a house which isn't haunted ;)

Share this post


Link to post
Share on other sites
[TTT]
Players
1,168 posts
9,822 battles

am having trouble with the control I can not do ctrl and LMB to target the ships like dd end airplans h du you change this..

 

go options->collision avoidance system->off

I don't think you answered his question :P

 

@Theoldman: It could be because you play in a ship that doesn't have AA or secondaries (by design, or because of damage). And you can't ctrl-click a target for which you have no offensive weapons. 

Share this post


Link to post
Share on other sites
Beta Tester
2,286 posts
9,870 battles

 

I don't think you answered his question :P

 

 

 

I just realized it. I don't know what was I thinking... It was a bit late I guess :P

Share this post


Link to post
Share on other sites
[AXIS]
Beta Tester
4,060 posts
17,291 battles

am having trouble with the control I can not do ctrl and LMB to target the ships like dd end airplans h du you change this.

 

Theoldman.

 

You probably changed the in-game control keys. Delete the preferences.xml file and keep the default control keys and it should work.
Edited by 22cm

Share this post


Link to post
Share on other sites
[BONUS]
[BONUS]
Beta Tester
2,681 posts
7,226 battles

am having trouble with the control I can not do ctrl and LMB to target the ships like dd end airplans h du you change this.

 

Theoldman.

 

You need to do a search.  I had the same issue and got it sorted.  I have a side mouse button that does that for me, once I assigned it.

 

 

Try this  http://forum.worldofwarships.eu/index.php?/topic/33014-help-ctrl-button-not-working/page__hl__%2Bfree+%2Bcursor__fromsearch__1

 

Edited by Erinaceus_europaeus

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×