Jump to content
  • 0
You need to play a total of 50 battles to post in this section.
SRSpoony

Steam Login problem

5 comments in this topic

Question

[SORE]
Alpha Tester
4 posts
2,969 battles

so normally i would have the game installed via the standalone Client but i decided to install it on steam but i cant login

 

just asks me to pick a username thats already taken by me,

 

any idea on a solution ?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1
[SORE]
Alpha Tester
4 posts
2,969 battles
1 hour ago, Astolfo_Is_My_Waifu said:

The steam client is, by default, designed to use your steam credentials to login.

 

In order to log in with a wargaming account you must do the following;

  1. Make sure the game is closed before changing client files.
  2. Go to the WoWS install directory, by default a Steam WoWS install would be found here;
    
    C:\Program Files (x86)\Steam\steamapps\common\World of Warships\

     

  3. From there, go to the bin folder, then the folder with the highest number (which is the folder for the latest update) and inside that go to the bin64 folder
  4. Here you should find a file called steam_api64.dll, you should rename this file (rename instead of deleting so that it still doesn't work but if you have any problems you can simply change its name back).
  5. Now you can launch WoWS and log in with your Wargaming credentials.
    • Important: You wont be able to use any Steam DLC you buy for WoWS or earn Steam achievements unless you are using your Steam credentials when you play, even if you are using the Steam client.
  6. You will need to repeat this every time WoWS has an update.

If you have an existing WG account with >2500 battles you might prefer to reinstall the normal WGC version of the game and simply add it to Steam via the "Add a non-Steam game to my library" button which would effectively be exactly the same result as above but without having to modify the files every update.

thanks for the info, the DLL isnt in my folder this is my issue for some reason i do not have this at all.

 

i think i shall go back to the client install as it seems much easier to get on with.

Share this post


Link to post
Share on other sites
  • 0
[KOKOS]
Weekend Tester, Players, In AlfaTesters
105 posts
2,142 battles

I think accounts are separated..

Share this post


Link to post
Share on other sites
  • 0
Quality Poster, In AlfaTesters
1,521 posts
13,775 battles

The steam client is, by default, designed to use your steam credentials to login.

 

In order to log in with a wargaming account you must do the following;

  1. Make sure the game is closed before changing client files.
  2. Go to the WoWS install directory, by default a Steam WoWS install would be found here;
    C:\Program Files (x86)\Steam\steamapps\common\World of Warships\

     

  3. From there, go to the bin folder, then the folder with the highest number (which is the folder for the latest update) and inside that go to the bin64 folder
  4. Here you should find a file called steam_api64.dll, you should rename this file (rename instead of deleting so that it still doesn't work but if you have any problems you can simply change its name back).
  5. Now you can launch WoWS and log in with your Wargaming credentials.
    • Important: You wont be able to use any Steam DLC you buy for WoWS or earn Steam achievements unless you are using your Steam credentials when you play, even if you are using the Steam client.
  6. You will need to repeat this every time WoWS has an update.

If you have an existing WG account with >2500 battles you might prefer to reinstall the normal WGC version of the game and simply add it to Steam via the "Add a non-Steam game to my library" button which would effectively be exactly the same result as above but without having to modify the files every update.

Share this post


Link to post
Share on other sites
  • 0
Quality Poster, In AlfaTesters
1,521 posts
13,775 battles
4 minutes ago, SRSpoony said:

thanks for the info, the DLL isnt in my folder this is my issue for some reason i do not have this at all.

 

i think i shall go back to the client install as it seems much easier to get on with.

Strange, I'm not a Steam user so perhaps this process has changed yet again.

Sorry about that.

Share this post


Link to post
Share on other sites

×