Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
cracktrackflak

Some Tier 10 snowflakes/crates not dropping?

4 comments in this topic

Recommended Posts

Weekend Tester
922 posts

I'm just working through my tier 10 snowflakes, and on three ships (so far) the snowflake has vanished without dropping a loot box. This happened with Yamato, Kremlin and GK.

 

Is this happening with anyone else, or is WG just targeting me because I've written too many cynical forum posts?

Share this post


Link to post
Share on other sites
Players
1,152 posts
13,213 battles
5 hours ago, cracktrackflak said:

I'm just working through my tier 10 snowflakes, and on three ships (so far) the snowflake has vanished without dropping a loot box. This happened with Yamato, Kremlin and GK.

 

Is this happening with anyone else, or is WG just targeting me because I've written too many cynical forum posts?

Are you sure you have not allready collected them on first day the current update went live.

 

I had one ship, that still showed a snowflake, but due the fact I allready collected it - I did not get anything. It was allready collected.

Share this post


Link to post
Share on other sites
[BOBS3]
Beta Tester
519 posts
21,733 battles

also ships played during daily reset are showing a flake in port after match despite a win and collecting the reward, it disapears next game win or lose without reward

Share this post


Link to post
Share on other sites
Sign in to follow this  

×