Jump to content
You need to play a total of 50 battles to post in this section.
UnholyRevenant

Emblem Bug, or am i missing something here

9 comments in this topic

Recommended Posts

Players
6,612 posts
10,814 battles

Huh why is that number so weird? Ive never had any decimals showing up. Did that change at some point? (been a while since I checked)

Share this post


Link to post
Share on other sites
[0INK]
Players
23 posts
3,651 battles

I have the same bug with the 64k dmg elite emblem on DD!

 

It says like 64934,39489384 and it isn't unlocked! That's pretty bad :Smile_izmena:

Share this post


Link to post
Share on other sites
[JRM]
Players
6,746 posts

Yea I noticed same weird numbers yesterday, must be a bug of some kind...

Share this post


Link to post
Share on other sites
Players
65 posts
4,779 battles

Most likely someone at WG has screwed with the calculation script.

 

It looks like the averages calculation script is done using a real numbers where as the compare script (checking you are meet the criteria to get the award) uses integers. 

 

It doesn’t make a difference to you or I when looking at the numbers but a computer needs to know the type of numbers system. No doubt it’ll get fixed and your awards will all popup at the same time

 

here ends my post of pointlessness 😜

  • Cool 1

Share this post


Link to post
Share on other sites
[0INK]
Players
23 posts
3,651 battles

UPDATE. With the last patch it's still bugged.

 

Why they aren't fixing it?

 

Alle 27/11/2019 alle 00:44, Duecut ha scritto:

It doesn’t make a difference to you ...

 

Well actually it does! Because it shows the number of average damage that is over the value needed to unlock the emblem... but it doesn't unlock! So no emblem.

Maybe some "collector" players puts some effort to reach some achievements. It's pretty bad if you reach them and doesn't work as intended :(

 

I mean, to me it doesn't seem a so big bug to fix.

  • Cool 1

Share this post


Link to post
Share on other sites
Players
6,612 posts
10,814 battles
25 minutes ago, _warlove_ said:

Why they aren't fixing it?

 

Does WG create money from the emblems? So there you have the answer.

Share this post


Link to post
Share on other sites
Players
65 posts
4,779 battles
19 minutes ago, _warlove_ said:

UPDATE. With the last patch it's still bugged.

 

Why they aren't fixing it?

 

 

Well actually it does! Because it shows the number of average damage that is over the value needed to unlock the emblem... but it doesn't unlock! So no emblem.

Maybe some "collector" players puts some effort to reach some achievements. It's pretty bad if you reach them and doesn't work as intended :(

 

I mean, to me it doesn't seem a so big bug to fix.

Please don’t quote me out of context.

 

The fact that this is a broken function makes a difference to the awards, BUT my point was that when you read a real number or an integer you automatically see the number system being used a computer can’t.

 

How difficult a fix this is depends on if the script used to get the average figure is used for doing something else.

Share this post


Link to post
Share on other sites

×