Jump to content
Sign in to follow this  
You need to play a total of 1 battles to post in this section.
Filipin00

What am I doing wrong?

9 comments in this topic

Recommended Posts

[UAC]
Players
659 posts
2,260 battles

For some reason when I try to use ModsSDK the way it's explained in the tutorials (https://forum.worldofwarships.eu/topic/108438-modapi-contentsdk/)

The ships I extract (for modding) that way are broken in game. They have no textures and instead show that broken black and red stock texture or whatchamacallit....

Am I doing something wrong? Because there are several other tutorials I've found that use that tutorial as a preparation (in my case, plane model swap) to actual tutorial and it's all just broken. And I don't want to mod entire ship, just planes, does it mean I can't? Do I have to instead extract original ship files from the game and manually put them in the mod before I can actually start modding what I originally wanted? Am I using the contentSDK wrong completely? Like...what the hell? :Smile_child:

 

Share this post


Link to post
Share on other sites
[ALONE]
Modder
2,375 posts
14,345 battles
Am 10.11.2019 um 21:00, Filipin00 sagte:

For some reason when I try to use ModsSDK the way it's explained in the tutorials (https://forum.worldofwarships.eu/topic/108438-modapi-contentsdk/)

The ships I extract (for modding) that way are broken in game. They have no textures and instead show that broken black and red stock texture or whatchamacallit....

Am I doing something wrong? Because there are several other tutorials I've found that use that tutorial as a preparation (in my case, plane model swap) to actual tutorial and it's all just broken. And I don't want to mod entire ship, just planes, does it mean I can't? Do I have to instead extract original ship files from the game and manually put them in the mod before I can actually start modding what I originally wanted? Am I using the contentSDK wrong completely? Like...what the hell? :Smile_child:

 

I know your pain, just had the same issues.

It's in the ModsSDK - the paths of some textures (glasses) are wrong and haven't been updated (probably for a while), so they do not work anymore.

After loading the ship in client, you can check the profile/python.log, there all texture that could not be loaded are listed.

Then have to check and alter all paths of these in all xml-files-  similar to how the propeller-paths are changed in the plane-swap-tutorial.

  • Cool 1

Share this post


Link to post
Share on other sites
[UAC]
Players
659 posts
2,260 battles

Nah, I give up. This is too complicated for the end result I'm trying to achieve.

 

11 hours ago, Smeggo said:

I know your pain, just had the same issues.

It's in the ModsSDK - the paths of some textures (glasses) are wrong and haven't been updated (probably for a while), so they do not work anymore.

Like, literally, the whole ship is missing textures, not just glasses. Literal whole ship. And that's without modding, just loading it up without touching it after the ModsSDK has made the folder with all the files inside for modding. I see textures are correct, so are the paths in .model and .mfm files but the ship is still broken in game. I don't even think I'm doing anything wrong I think the whole system is broken.

Share this post


Link to post
Share on other sites
[ALONE]
Modder
2,375 posts
14,345 battles
Vor 14 Minuten, Filipin00 sagte:

Nah, I give up. This is too complicated for the end result I'm trying to achieve.

 

Like, literally, the whole ship is missing textures, not just glasses. Literal whole ship. And that's without modding, just loading it up without touching it after the ModsSDK has made the folder with all the files inside for modding. I see textures are correct, so are the paths in .model and .mfm files but the ship is still broken in game. I don't even think I'm doing anything wrong I think the whole system is broken.

 

Yes, unfortunately it requires a lot of manual fixing :fish_nerv:

If the paths refer to a texture that is stored elsewhere in the client, it sometimes cannot access these.

Then unpacking the required textures (using the wowsunpacker-tool), storing it into the mod-folder using a software like paint.net (as simply copying doesn't work also) and changing all paths to the new textures can work.

Share this post


Link to post
Share on other sites
[UAC]
Players
659 posts
2,260 battles
4 minutes ago, Smeggo said:

 

Yes, unfortunately it requires a lot of manual fixing :fish_nerv:

If the paths refer to a texture that is stored elsewhere in the client, it sometimes cannot access these.

Then unpacking the required textures (using the wowsunpacker-tool), storing it into the mod-folder using a software like paint.net (as simply copying doesn't work also) and changing all paths to the new textures can work.

Yeah, I wish it were more easy than that, as it doesn't seem hard to do, it's just a lots of stuff to fix on your own that should already work in the first place.

Oh well...thanks for the help, right now I don't feel like doing all that with my time. Ju-87s on GZ can wait lol

Share this post


Link to post
Share on other sites
[ALONE]
Modder
2,375 posts
14,345 battles
Vor 5 Minuten, Filipin00 sagte:

Yeah, I wish it were more easy than that, as it doesn't seem hard to do, it's just a lots of stuff to fix on your own that should already work in the first place.

Oh well...thanks for the help, right now I don't feel like doing all that with my time. Ju-87s on GZ can wait lol

Ju-87 on GZ sound great - where can the Ju-87 models be found, are they still in the client?

Share this post


Link to post
Share on other sites
[UAC]
Players
659 posts
2,260 battles
5 minutes ago, Smeggo said:

Ju-87 on GZ sound great - where can the Ju-87 models be found, are they still in the client?

Indeed they still are in game, they are old plane models (I think from the RTS days but ju-87 nonetheless). I've seen them in germany's aircraft section using wowsunpack tool. There are textures and everything. Now I don't know if it's possible to swap existing planes with them because previous plane model swaps were mostly done with planes that are actually used now in game (tenrais/BTD destroyers on hosho, your mod....) and ju-87's are not used in the game on any carrier so....

I don't know if it's realistically possible to swap them. There's like JU-87B and JU-87C I've seen.

Share this post


Link to post
Share on other sites
[ALONE]
Modder
2,375 posts
14,345 battles

Ok, I tried it. Ignored the texture-errors on the ship, just tried to swap the planes with the ones from the old models.

Unfortunately the plane-models don't load, as the old model-files are differently made and probably lack all kind of required parts (like moving flaps and wires)

 

Zitat

2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitiveschassis_off_BlendBoneShape.vertices
2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitiveschassis_on_BlendBoneShape.indices
2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitiveschassis_on_BlendBoneShape.vertices
2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitiveshull_wire_lod1Shape.indices
2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitiveshull_wire_lod1Shape.vertices
2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitivesmodShape.indices
2019-11-12 12:36:45.119: ASSET: [Other] Failed to read binary resource: PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.primitivesmodShape.vertices
2019-11-12 12:36:45.120: ASSET: [Other] Could not load model: 'PnFMods/GZ/GSA518_Graf_Zeppelin/aircraft/GAB703_Ta_152_C1_R14_proto.model'

 

  • Cool 1

Share this post


Link to post
Share on other sites
[UAC]
Players
659 posts
2,260 battles
3 hours ago, Smeggo said:

Ok, I tried it. Ignored the texture-errors on the ship, just tried to swap the planes with the ones from the old models.

Unfortunately the plane-models don't load, as the old model-files are differently made and probably lack all kind of required parts (like moving flaps and wires)

 

 

Just what I thought. Like I said, realistically impossible to swap them. Thanks for trying, you got that fast, I would've spent days trying.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×