Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
Verblonde

Is WOWS less stable and/or slower when running WG Game Centre?

23 comments in this topic

Recommended Posts

[SM0KE]
Players
4,919 posts
12,035 battles

As a matter of interest, how have people found WOWS run through the standalone launcher versus when it's run through the Game Centre?

 

I probably got unlucky, and WOWS has been flaky anyway since the last patch, but I've found that since I installed Game Centre, WOWS seems marginally more prone to falling over, and seems slower to change between screens etc. Has anyone else seen something like this, or am I going mad?

 

BTW I only installed Game Centre in the first place because you are now *required* to if you want to play WOT, which is a whole different topic and grounds for some fairly harsh language (IMO anyway).

Share this post


Link to post
Share on other sites
[ROT8]
[ROT8]
Beta Tester
1,506 posts
9,703 battles

I installed the game centre not long after it came out and it was a nightmare for when I updated the game as it would freeze a lot and crash

nowadays though its been very smooth and I would say I don't have problems

  • Cool 1

Share this post


Link to post
Share on other sites
Players
1,924 posts
6,510 battles

Got a Win7 PC running the standalone and a Win10 Laptop running Game Centre - Both are stable but the Port UI seems faster on the Win7 PC.

Share this post


Link to post
Share on other sites
[HOO]
Beta Tester, Players, In AlfaTesters
3,242 posts
37 minutes ago, Verblonde said:

WOWS has been flaky anyway since the last patch

Run the "check and repair". I had the same issues, and it was because some files were missing. Running the C&R fixed it to pre-patch performance for me. 

 

Oh, and Windows7 FTW!

  • Cool 1

Share this post


Link to post
Share on other sites
[SM0KE]
Players
4,919 posts
12,035 battles
1 minute ago, MrFingers said:

Run the "check and repair".

I'll give it a try - many thanks!

I did that a couple of days ago with the regular launcher version, after getting several crashes with the current patch (the game had generally been pretty stable prior to that)...

Share this post


Link to post
Share on other sites
[CN_]
Moderator, WoWs Wiki Team
1,836 posts
6,164 battles

I have no problem with the Gamecenter + WoWs. Updates are even faster than before, at least that's how it feels.

My game is also stable, I had only one crash during the last weeks and that was probably caused by my gpu driver and not by WoWs.

 

On a really weak computer the game might be a bit slower with the Gamecenter running because by default the Gamecenter is running in background after starting the game. But if something like that is too much for your computer, you should consider replacing it anyway (I also don't think that this is the issue you have here).

  • Cool 2

Share this post


Link to post
Share on other sites
Players
628 posts
2,129 battles

Game Centre is very stable with both WoWs and WoT, I held off for a long time but now I'm happy I swapped over. Running Win 10. One additional bonus generally for encouraging players to use Game Centre is that it at least gives a snapshot of the game news and keeps them partially up to date.

  • Cool 1

Share this post


Link to post
Share on other sites
Beta Tester
2,104 posts
11,183 battles
8 hours ago, Verblonde said:

As a matter of interest, how have people found WOWS run through the standalone launcher versus when it's run through the Game Centre?

 

I probably got unlucky, and WOWS has been flaky anyway since the last patch, but I've found that since I installed Game Centre, WOWS seems marginally more prone to falling over, and seems slower to change between screens etc. Has anyone else seen something like this, or am I going mad?

 

BTW I only installed Game Centre in the first place because you are now *required* to if you want to play WOT, which is a whole different topic and grounds for some fairly harsh language (IMO anyway).

After the 0.8.8.1 pacth my game has been running slowly when leaving the battle(either post game end result or post sinking), the menues are slow to respond and when exiting the game it takes longer than before.

  • Cool 1

Share this post


Link to post
Share on other sites
[TTT]
Players
2,042 posts
19,953 battles

I only start the GC for game updates and close it immediately when it's done, I start the game by clicking a link to the WoWS.exe. You could try this to check if GC is causing the problems. Check if the game picks the right version or link to the 32-bit or 64-bit version yourself.

  • Cool 1

Share this post


Link to post
Share on other sites
[COR3]
Players
1,321 posts
12,751 battles

i usually only use the WGC for the Updates and then start the 64 Bit Version of the game that runs rocksolid.

Share this post


Link to post
Share on other sites
Beta Tester
710 posts
11,585 battles

Just from curiosity how you people measure the changes?

As maybe there is something with your method of measuring not with game.

 

I run WGC from begining and latest patches resulted in a crash. Previous crash was months ago, now it is a monthly event. So you would say it sounds plausible. But I changed the way I use my computer (more background programs) so that makes it impossible to guess what happened.

Share this post


Link to post
Share on other sites
Players
176 posts
10,509 battles

I stopped using it as it can't update itself and then i couldn't play WoWS so i am back to the standalone client which always work. (i was keeping deinstalling the game centre en reinstalling it to get it working again. Also updating WoWS is very slow and need a lot of manual pushes to continue). rubbish product (when it works it is fine and was a reason to use it but when it was updating time ....)

Share this post


Link to post
Share on other sites
[PONY]
Beta Tester
5,814 posts
10,005 battles

I use the center from when it was fist launched. Never had problem with it. Nothing got slower or faster.

Share this post


Link to post
Share on other sites
[CN_]
Moderator, WoWs Wiki Team
1,836 posts
6,164 battles
Vor 1 Stunde, Onsterfelijke sagte:

I stopped using it as it can't update itself and then i couldn't play WoWS so i am back to the standalone client which always work. (i was keeping deinstalling the game centre en reinstalling it to get it working again. Also updating WoWS is very slow and need a lot of manual pushes to continue). rubbish product (when it works it is fine and was a reason to use it but when it was updating time ....)

That's an unusual behaviour, my Gamecenter is able to update itself without any problems. Did you send a ticket to customer support to report this issue? If noone reports issues like that, they can't be fixed.

 

Vor 3 Stunden, Sir_Grzegorz sagte:

Just from curiosity how you people measure the changes?

As maybe there is something with your method of measuring not with game.

 

I run WGC from begining and latest patches resulted in a crash. Previous crash was months ago, now it is a monthly event. So you would say it sounds plausible. But I changed the way I use my computer (more background programs) so that makes it impossible to guess what happened.

Crashes are not always connected to the game center itself. You could try using the old launcher (I think someone might still have the installer file somewhere) and test if you encounter the same problems. If you do still have these problems, it's probably caused by the game itself, if you don't have these problems after changing the launcher, you should report the issue to customer support.

 

 

That also applies to any kind of issue, crashes, freezes, whatever: If there is no forum thread that tells you that WG is aware of the issue, report bugs and issues to customer support as described in this thread:

 

  • Cool 1

Share this post


Link to post
Share on other sites
[HOO]
Players
1,865 posts
3,594 battles
21 hours ago, Verblonde said:

As a matter of interest, how have people found WOWS run through the standalone launcher versus when it's run through the Game Centre?

 

I probably got unlucky, and WOWS has been flaky anyway since the last patch, but I've found that since I installed Game Centre, WOWS seems marginally more prone to falling over, and seems slower to change between screens etc. Has anyone else seen something like this, or am I going mad?

 

BTW I only installed Game Centre in the first place because you are now *required* to if you want to play WOT, which is a whole different topic and grounds for some fairly harsh language (IMO anyway).

I don't have problems with the Game Centre and WoWS, but lots of people have had issues with this last patch being a bit flaky.

 

I had the issue when you log out of the client and the screen is locked with the game GUI, even though all processes are ended. I just dragged another open window from my second monitor into the game display and it would go back to my desktop view as expected. The hotfix issued resolved that for me

 

A couple of clan mates had stutters and freezes in battle. For one of them it turns out it was his VPN.

 

And there seems to be the odd GUI glitch every now and then in games etc

 

 

  • Cool 1

Share this post


Link to post
Share on other sites
WoWs Wiki Team, Supertester, Privateer
1,869 posts
11,627 battles
21 hours ago, Verblonde said:

I probably got unlucky, and WOWS has been flaky anyway since the last patch, but I've found that since I installed Game Centre, WOWS seems marginally more prone to falling over, and seems slower to change between screens etc. Has anyone else seen something like this, or am I going mad?

I do test WGC since Beta-Version and I did not have any problems yet and most of the times am not affected by other reported issues (recent: black harbor, game not terminating on end properly, stutters, hardware-acceleration of ingame-browser  etc) - and thus running on a Gaming-Notebook and since half a year on a desktop, too. From my personal experience and some clan-mates those "slow" port sometimes is a matter of hardware, too. In addition: slow loading of matches/game is mostly related to  HDD - when I migrated to SSD (and I am using SSD now for everything) it's quite fast and as stable as ever. 

  • Cool 1

Share this post


Link to post
Share on other sites
[PARAZ]
Beta Tester
13,227 posts
18,952 battles

Tbh I've never had an issue with the game center amd I installed it fairly early on.

I suspect the game itself just gets slower over time. On EU it takes me 40-50 seconds to load into a match, on CN which is still on 0.7.3 meanwhile it takes me 15 seconds at most. Both are on the same drive and I like to think I have a fairly powerful rig, any difference must therefore be due to the version of the game.

  • Cool 1

Share this post


Link to post
Share on other sites
Beta Tester
1,049 posts
2,954 battles

I've never had a problem with either stand alone or WGC.  I installed WGC very late. I load in about 20 sec before timer.  I do have quite a powerful rig (i7 6700/GTX 980TI/16gbDDR4,SSD), so I suppose that isn't surprising.  

 

I've had the usual connection issues, but everyone else has had those. 

Share this post


Link to post
Share on other sites
Players
176 posts
10,509 battles
On 11/8/2019 at 10:52 AM, floribe2000 said:

That's an unusual behaviour, my Gamecenter is able to update itself without any problems. Did you send a ticket to customer support to report this issue? If noone reports issues like that, they can't be fixed.

 

Crashes are not always connected to the game center itself. You could try using the old launcher (I think someone might still have the installer file somewhere) and test if you encounter the same problems. If you do still have these problems, it's probably caused by the game itself, if you don't have these problems after changing the launcher, you should report the issue to customer support.

 

 

That also applies to any kind of issue, crashes, freezes, whatever: If there is no forum thread that tells you that WG is aware of the issue, report bugs and issues to customer support as described in this thread:

 

The problem started 2 months ago when the gamecentre was updating after that i had these problems. Sorry i didn't report it as it's still a beta version and i will wait for the final release. (before that WoWs updated perfectly just when the Gamecentre was updated problems started. 

Share this post


Link to post
Share on other sites
Players
5,976 posts
10,961 battles
On 11/7/2019 at 1:51 PM, Verblonde said:

As a matter of interest, how have people found WOWS run through the standalone launcher versus when it's run through the Game Centre?

 

I probably got unlucky, and WOWS has been flaky anyway since the last patch, but I've found that since I installed Game Centre, WOWS seems marginally more prone to falling over, and seems slower to change between screens etc. Has anyone else seen something like this, or am I going mad?

I only use the game center to update the game. For me it's more convenient to use the standard executables as I have a set of custom batchfiles I use to backup my replays before wargaming gets a chance to swoop in and delete everything again.

Quote

BTW I only installed Game Centre in the first place because you are now *required* to if you want to play WOT, which is a whole different topic and grounds for some fairly harsh language (IMO anyway).

Wut? :Smile_hiding:

  • Cool 1

Share this post


Link to post
Share on other sites
[SM0KE]
Players
4,919 posts
12,035 battles
2 hours ago, NothingButTheRain said:

Wut? 

It's a terrible affliction - I'm hoping it can be remedied with ointment...

  • Funny 2

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×