Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
A_useless_noob

Whats wrong with this picture

10 comments in this topic

Recommended Posts

[BFS]
Beta Tester
1,518 posts
9,670 battles

It looks like you have a Russian Flag on the USA ship Dallas.

 

I presume you may have a mod installed that changes the flags.  I use Alsain's Mod Pack and part of that with historical flags messed up flags big time - I think the Italian Fag was replaced by the Japanese one.

 

There was an update to that modpack yesterday that fixed that problem.

 

Edited:

See this thread:  

 

Share this post


Link to post
Share on other sites
Players
612 posts
2,089 battles
12 hours ago, A_useless_noob said:

Spot the fault

 

You aren't using camo on a cruiser?

Share this post


Link to post
Share on other sites
[I-J-N]
Players
2,284 posts

The flag issue is down to obsolete mods. Download a new version and it will get fixed.

 

Why WG keeps shifting flag positions on the chart is beyond me.... :Smile_facepalm:

Share this post


Link to post
Share on other sites
[OSWEG]
[OSWEG]
Players
874 posts
5,447 battles

Lets see, potato computer with insanly low resolution. No camo, Co-Op battle selected. Stock consumables and an 8 point captain on a ship that pretty much requires IFHE.

  • Cool 4
  • Funny 2

Share this post


Link to post
Share on other sites
Players
1,029 posts
15,834 battles
6 hours ago, Karasu_Hidesuke said:

Why WG keeps shifting flag positions on the chart is beyond me.... :Smile_facepalm:

Not only the flag positions but also the camouflages in port. When I saw they moved all the permacamos to another category I thought that was ok, but then I've been having some headaches with where the one-use ones are. Type 1 and 2 in particular are sometimes placed at the beginning, sometimes at the end, sometimes even in switched order: I had a battle yesterday where I mounted Type 1 (extra dispersion instead of extra concealment) by mistake and kept wondering all the time how could the red Gearing outspot my Shimakaze until I noticed the stripped pattern instead of the patched one. Since I started playing and up until this patch they were always at the top and Type 2 before Type 1.

 

Back on topic, the matter about flags when mounted on ships is simple: all the flags and signals (I know this because I unpacked the .dds file a while ago) are in a DirectDraw image and almost for sure referenced by the game in order to display them by their coordinates within the aforementioned image. This works in the exact same way as sprites for many 2D RPG games, hence it should make sense keeping them at the very same positions and expand the file when new flags are added to the game, which also saves time because you only need to include the coorditates' references to render them as new code instead of revamping the whole location system (which is what caused OP's glitch).

 

Salute.

  • Cool 1

Share this post


Link to post
Share on other sites
[SWTP]
Players
1,457 posts
10,674 battles
6 hours ago, Floofz said:

Lets see, potato computer with insanly low resolution. No camo, Co-Op battle selected. Stock consumables and an 8 point captain on a ship that pretty much requires IFHE.

At least name fits well:Smile_trollface:

Sorry OP couldn't stop myself:Smile_hiding:

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×