Jump to content
Sign in to follow this  
slabby_1

unable to log in

2 comments in this topic

Recommended Posts

[A-TF]
Players
1 post
13,668 battles

when ive tried to get on game get message the current installed game is older than server please update client. It has just updated but showing 0.8.5.1 not 8.6 no more updates showing

Share this post


Link to post
Share on other sites
Sign in to follow this  

×