Jump to content
  • 0
Sign in to follow this  
DeletedUser

Mit AMD Ryzen 7 startet der Launcher die 32bit Anwendung?

11 comments in this topic

Question

10 answers to this question

Recommended Posts

  • 0
[VEBA]
[VEBA]
Weekend Tester
491 posts
5,711 battles

Neben dem "Spielen"- Button ist ein Pfeil, da kannst du manuell den Client auswählen

wows1.jpg

Share this post


Link to post
Share on other sites
  • 0
Modder
5,638 posts
10,217 battles

Welchen Launcher verwendest du?

Mit dem GC sollte nur die Ram Größe ausschlaggebend sein ob 32 oder 64 bit Client verwendet wird.

bis 6Gb --->32bit über 6GB --->64bit

 

In der clientrunner.txt im ordner :\Games\World_of_Warships\profile sollte eine log enthalten sein was erkannt und welcher Client zugewiesen wurde.

Share this post


Link to post
Share on other sites
  • 0
Players
0 posts

Ich verwende wieder den alten Launcher, da ich eh nur WoWs spiele.

 

Den richtigen Client selbst starten kann ich auch so -  es war halt die Frage ob das bekannt ist.

 

Das sagt das clientrunner.log:

[2019-07-18 09:04:20] ================ Log started at 2019-07-18 09:04:20 ================
[2019-07-18 09:04:20] using preferred architecture: x32
[2019-07-18 09:04:20] Selected realm: eu
[2019-07-18 09:04:20] Single version client detected
[2019-07-18 09:04:20] Running D:\World of Warships\bin32\WorldOfWarships32.exe.
[2019-07-18 09:04:20] Started through wgc, entering sleep to continue holding the mutex
[2019-07-18 09:04:20] ================ Log closed at 2019-07-18 09:04:20 ================

 

Witzige Architektur dieses "x32" - das soll wohl 32bit bedeuten... :cap_yes:

 

Wenn mir jemand den Link zum WGC inkl. Pfadwahl posten könnte, könnte ich testen, ob der WGC das auch falsch erkennt.

Share this post


Link to post
Share on other sites
  • 0
Modder
5,638 posts
10,217 battles
Vor 2 Stunden, McMurmel sagte:

Ich verwende wieder den alten Launcher, da ich eh nur WoWs spiele.

 

Den richtigen Client selbst starten kann ich auch so -  es war halt die Frage ob das bekannt ist.

 

Das sagt das clientrunner.log:

[2019-07-18 09:04:20] ================ Log started at 2019-07-18 09:04:20 ================
[2019-07-18 09:04:20] using preferred architecture: x32
[2019-07-18 09:04:20] Selected realm: eu
[2019-07-18 09:04:20] Single version client detected
[2019-07-18 09:04:20] Running D:\World of Warships\bin32\WorldOfWarships32.exe.
[2019-07-18 09:04:20] Started through wgc, entering sleep to continue holding the mutex
[2019-07-18 09:04:20] ================ Log closed at 2019-07-18 09:04:20 ================

 

Witzige Architektur dieses "x32" - das soll wohl 32bit bedeuten... :cap_yes:

 

Wenn mir jemand den Link zum WGC inkl. Pfadwahl posten könnte, könnte ich testen, ob der WGC das auch falsch erkennt.

http://redirect.wargaming.net/WGC/Wargaming_Game_Center_Install_EU.exe

 

Wenn du es getestet hast bitte um Rückmeldung! :cap_like:

 

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
WoWs Wiki Team, Supertester, Privateer
2,027 posts
12,293 battles
2 hours ago, McMurmel said:

es war halt die Frage ob das bekannt ist.

Zumindest startet mein PC mit Ryzen 7 und die bei uns im Clan korrekterweise den 64bit-Client - aber halt alle mit WGC.

  • Cool 1

Share this post


Link to post
Share on other sites
  • 0
Players
0 posts

Nein - auch der WGC startet bei mir die 32bit Anwendung - einfach goil.

 

Mein Windows 10 war doch bloß ein paar Stunden nicht aktiviert - bis ich meinen alten Windows 8.1 Key wiedergefunden habe. :fish_panic:

Share this post


Link to post
Share on other sites
  • 0
Modder
5,638 posts
10,217 battles
Vor 3 Minuten, McMurmel sagte:

Nein - auch der WGC startet bei mir die 32bit Anwendung - einfach goil.

 

Mein Windows 10 war doch bloß ein paar Stunden nicht aktiviert - bis ich meinen alten Windows 8.1 Key wiedergefunden habe. :fish_panic:

Das hat mit dem key doch nichts zu tun!

Da muß irgend etwas anderes nicht passen, weil eigentlich nur die RAM Größe abgefragt wird.

Alles andere ist eigentlich egal.

DirektX mal geprüft?

Share this post


Link to post
Share on other sites
  • 0
Players
0 posts

Witzige Erkennungsroutine - ansonsten funktioniert ja alles - inkl. manuell gestartetem 64bit Client.

Wahrscheinlich ist mein Windows nach all den Jahren der Core I5-Prozessoren einfach kein AMD gewöhnt - das wird sicher wieder. :dance_turtle:

Ansonsten muss ich mal mit Process-Monitor beigehen...

Share this post


Link to post
Share on other sites
  • 0
Modder
5,638 posts
10,217 battles
Vor 2 Minuten, McMurmel sagte:

Witzige Erkennungsroutine - ansonsten funktioniert ja alles - inkl. manuell gestartetem 64bit Client.

Wahrscheinlich ist mein Windows nach all den Jahren der Core I5-Prozessoren einfach kein AMD gewöhnt - das wird sicher wieder. :dance_turtle:

Ist natürlich auch eine Möglichkeit die exe direkt zu starten?

 

Ja WG ist da sehr einfallsreich, statt eine richtige Leistungsbewertung wird nur die RAM Größe abgefragt.

Share this post


Link to post
Share on other sites
  • 0
[ASOP]
Beta Tester
1,951 posts
11,811 battles

Ich kann bestätigen, dass WoWS auf Ryzen Systemen standardmäßig den 32 Bit Client startet.

Betroffen sind bei mir Ryzen 2700X und 3700X mit B450 und X570 Boards.

Zumindest vor AGESA 1003 war ein System mit Ryzen 2600 (6 Kerne) nicht davon betroffen und hat brav den 64 Bit Client gestartet. Leider habe ich im Moment nicht die Möglichkeit, dieses System nach dem Update auf ein AGESA 1003 BIOS zu testen.

 

@Sehales Kannst Du bitte an die Entwickler weiterleiten, dass die entweder eine vernünftige Erkennung für das System ins Gamecenter einbauen oder zumindest eine Einstellung, dauerhaft den 64 Bit Client zu starten?

Mit dem 32 Bit Client habe ich seit dem letzten Patch nämlich dauernd Abstürze, der 64 Bit Client scheint zumindest besser wenn nicht gar absturzfrei zu laufen. Nur klicke ich leider oft aus Gewohnheit direkt auf den Starten Button...

Share this post


Link to post
Share on other sites
Sign in to follow this  

×