Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
Beltalowda

Need help

6 comments in this topic

Recommended Posts

[DCBC]
Beta Tester
32 posts
4,310 battles

Hello everyone,

 

Since the last update every time I press fire, my guns get locked onto the target and it says Armament Locked on Bearing. When this happens I have to manually press ctrl+x to get them unlocked, point at the target, fire and it gets locked again. This is quite annoying especially when I play my cruisers with high RoF and the game is literally unplayable this way.

 

I checked my settings and there is nothing that would indicate that my Left mouse button is set to lock my guns on target. X button is set to lock the target not LMB. 

 

Is there something I have missed or is this a know bug ?

 

 

shot-19.03.21_20.52.34-0586.jpg

Share this post


Link to post
Share on other sites
[TOXIC]
Players
4,657 posts
11,768 battles
45 minutes ago, Beltalowda said:

Hello everyone,

 

Since the last update every time I press fire, my guns get locked onto the target and it says Armament Locked on Bearing. When this happens I have to manually press ctrl+x to get them unlocked, point at the target, fire and it gets locked again. This is quite annoying especially when I play my cruisers with high RoF and the game is literally unplayable this way.

 

I checked my settings and there is nothing that would indicate that my Left mouse button is set to lock my guns on target. X button is set to lock the target not LMB. 

 

Is there something I have missed or is this a know bug ?

 

 

shot-19.03.21_20.52.34-0586.jpg

First of all, you're mistaken about what "lock target" means. "Lock target" is for picking the ship you're targeting for purposes of aiming assistance and torping indicator.

The gun-locking is invoked by Ctrl+X instead... but for some reason this seems to be absent from controls tab. Perhaps it's something that can be changed manually in key controls and somehow it got bound to your LMB?...

The first thing I would try would be to

1. Bind your "fire" to something else, click Apply

2. Bind it back to LMB

Test if this cleared any unwanted strange bindings.

If that doesn't work, I would try with "fire" bound to something else to make sure if the binding is really on the LMB or perhaps got bound to the action of firing instead... in the latter case there's something VERY wrong. In the former it still sounds like merely a very strange problem with settings - that being the case, your best bet might be rummaging through the preferences.xml file. There are things that can be changed in preferences manually but not through preferences tab.

Share this post


Link to post
Share on other sites
[TTT]
Players
2,092 posts
21,114 battles

If nothing helps you can delete the preferences.xml file in your WoWS folder, this will delete all settings. Before you do that make screenshots of your settings in the game for easier setup. Also all minimap settings will be reset and all ships will have HE loaded.

  • Cool 1

Share this post


Link to post
Share on other sites
Players
9,842 posts
11,553 battles
54 minutes ago, Yedwy said:

Sounds like a mod problem

Might be.

 

@Beltalowda run game in safe mode, if that doesn't help, remove/rename preferences.xml to recreate config file. All keys and settings will reset obviously.

Share this post


Link to post
Share on other sites
[DCBC]
Beta Tester
32 posts
4,310 battles
23 hours ago, Yedwy said:

Sounds like a mod problem

I don't use any mods, playing the game in vanilla version is challenging enough for me :).

 

I will delete the preferences file since nothing else seems to work.

 

Thread can be closed now, thanks to everyone who tried to help.

 

EDIT: I deleted the preferences.xml file and the problem still persist. When I double click to fire my guns or even when I single fire them I get the Armament Locked on Bearing and have to press ctrl+x to unlock them again.

 

The only thing I changed in settings before making a test run was to set my Crosshair to be dynamic. 

 

EDIT 2: Problem solved, it was on my end, my mouse settings were the real issue here. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×