Jump to content
You need to play a total of 50 battles to post in this section.
iEarlGrey

Potential FPS Fix

58 comments in this topic

Recommended Posts

[BEWBS]
Players
116 posts
9,757 battles

Hello Captains,

We have a potential fix for those of you that have been having FPS issues. 

To apply the fix, users should:

  1. Download the archive relevant to your region, (so for EU players, download fps_fix_eu.zip attached below).
  2. Unpack the archive
  3. Copy the "fps_fix" folder to the game directory, next to worldofwarships.exe
  4. Go to the directory fps_fix
  5. Launch apply-patch_<Realm>.bat
  6. Select the "1. Apply Changes" option.
  7. Press any button

To undo changes:

  1. Run the apply-patch_<Realm>.bat
  2. Select the "2. Cancel changes"
  3. Press any button

 

Important! In order for the fix to work correctly, the game must be without installed modifications or running in safe mode.

Please let us know if this improves things for you, and let us know your PC config details.

fps_fix_asia.zip

fps_fix_eu.zip

fps_fix_na.zip

fps_fix_ru.zip

  • Cool 9

Share this post


Link to post
Share on other sites
[PMI]
Players
2,564 posts
7,312 battles

Thanks for posting using a format hard to read for people using the dark forum theme.

 

You guys really seem to like doing that and obviating the fact you have a dark forum setting, interesting, and par for the course being WG...

  • Funny 1

Share this post


Link to post
Share on other sites
[SCRUB]
Players
8,460 posts
13,036 battles

Seriously, what's with all those people writing in non-standard formatting that's hard (or in other cases, impossible to read) with the dark forum theme.

What's so bloody hard to just use the default forum formatting or if using copy/paste checking the post as plain text box to default copied content to the forum's default formatting?

 

 

Well, two can play that game ...

  • Cool 1
  • Funny 3

Share this post


Link to post
Share on other sites
[ADRIA]
[ADRIA]
Players
4,979 posts
8,466 battles

@iEarlGrey @MrConway It is so lovely that it’s not just random posts from random people who don’t normally visit forums that can’t be read. Who wants to see what WG staff are posting anyway?

 

I swear, if this continues I’ll start posting everything in moderator red soon.

  • Funny 1

Share this post


Link to post
Share on other sites
[XTREM]
Players
1,090 posts
12,663 battles

Thanks for this, it's appreciated.

 

I'll try it out and will let you guys know if it works

Share this post


Link to post
Share on other sites
[BEWBS]
Players
116 posts
9,757 battles

Have amended heinous formatting crimes. Please accept sincerest apologies 

Sorry I Apologize GIF

  • Cool 3
  • Funny 16

Share this post


Link to post
Share on other sites
[TTTX]
[TTTX]
Players
4,608 posts
8,081 battles
12 minutes ago, iEarlGrey said:

Have amended heinous formatting crimes. Please accept sincerest apologies 

 

and commited a few new ones with @Aotearas's and @wilkatis_LV's posts, eh? :Smile_teethhappy: I like it!

 

On a somewhat more serious note, any chance you could push this rather annoying issue with the forums up the food chain?

 

Aaaand on topic - can't try the fix right now, but will see if I have the time later today. Thanks at any rate!

Share this post


Link to post
Share on other sites
[SCRUB]
Players
8,460 posts
13,036 battles
1 hour ago, iEarlGrey said:

Have amended heinous formatting crimes. Please accept sincerest apologies 

Sorry I Apologize GIF

I'm a magnanimous forum despot, the colosseum shall wait until next time.

  • Cool 1
  • Funny 1

Share this post


Link to post
Share on other sites
[ADRIA]
[ADRIA]
Players
4,979 posts
8,466 battles
4 hours ago, iEarlGrey said:

Have amended heinous formatting crimes. Please accept sincerest apologies 

Sorry I Apologize GIF

With that colour choice?

 

tenor.gif

  • Cool 1

Share this post


Link to post
Share on other sites
Players
3,313 posts
15,811 battles
25 minutes ago, Miragetank90 said:

Good to see you all getting along, like good boys

 

104500257_Isaidstophurtingoneanotherlovemanlove.gif.495c87f6d94a3d25eb3bc411a1781d3d.gif

 

 

 

 

 

Brilliant post! This is why the forum is much better than the game these days.

  • Cool 3
  • Funny 1

Share this post


Link to post
Share on other sites
[BLITZ]
Players
2,779 posts
10,353 battles

Let's see if enabling disabling texture streaming does the trick.

Share this post


Link to post
Share on other sites
[XTREM]
Players
1,090 posts
12,663 battles

This seems to be working for me, played several games now without frame rate drops where It normally would have occurred.

 

Thanks again! @iEarlGrey

 

I can provide my PC config details. Just to confirm, are you referring to ''System Information'' accessed via dxdiag?  

Share this post


Link to post
Share on other sites
[BEWBS]
Players
116 posts
9,757 battles
5 minutes ago, Miragetank90 said:

This seems to be working for me, played several games now without frame rate drops where It normally would have occurred.

 

Thanks again! @iEarlGrey

 

I can provide my PC config details. Just to confirm, are you referring to ''System Information'' accessed via dxdiag?  

That would be great! Feel free to DM it over to me. Thanks alot.

 

Will add that even those who experience no benefit, please send over either you DXdiag or simply a description of your system specs for forwarding to Devs.

Share this post


Link to post
Share on other sites
[BEWBS]
Players
116 posts
9,757 battles
1 hour ago, B0Tato said:

Let's see if enabling texture streaming does the trick.

Was it disabled?

 

In \res\engineconfig.xml editing <enableTextureStreaming>true</enableTextureStreaming> to <enableTextureStreaming>false</enableTextureStreaming> can improve things for some people. I'd be surprised if doing the reverse helped. Please let me know.

Share this post


Link to post
Share on other sites
[BLITZ]
Players
2,779 posts
10,353 battles
33 minutes ago, iEarlGrey said:

Was it disabled?

 

In \res\engineconfig.xml editing <enableTextureStreaming>true</enableTextureStreaming> to <enableTextureStreaming>false</enableTextureStreaming> can improve things for some people.

Whoops, you're right, mixed it up.

Share this post


Link to post
Share on other sites
[KITEN]
Players
239 posts
13,156 battles
15 hours ago, Juanx said:

Thanks for posting using a format hard to read for people using the dark forum theme.

 

You guys really seem to like doing that and obviating the fact you have a dark forum setting, interesting, and par for the course being WG...

I have not been visiting these forums for very long, but what i have noticed is par for the course, is you complaining.

 

You dont even appear to play the game...  not in the last 3 months anyway... :Smile_sceptic:

  • Cool 3

Share this post


Link to post
Share on other sites
Players
2,480 posts
12,045 battles
8 hours ago, JohnMac79 said:

I have not been visiting these forums for very long, but what i have noticed is par for the course, is you complaining.

You catch on very fast, sir :Smile_teethhappy:

  • Cool 2
  • Funny 2

Share this post


Link to post
Share on other sites
Players
69 posts
4,051 battles

Hmm seems to make things a bit better but I am not sure yet... One of my clan mate used to crash almost every battle when he was caught in a torpedo soup, the patch seems to have fixed his crash.

I'll report more when I do some more game later today.

Share this post


Link to post
Share on other sites
Players
124 posts
1,046 battles

Patch worked om My EU client.

Got approx. 10 FPS better.

I had FPS drop especially later in game session.

Thanx!

Share this post


Link to post
Share on other sites
[BEWBS]
Players
116 posts
9,757 battles
16 minutes ago, Mr_Snoww said:

@iEarlGrey will this be patched into the update next week? Or do we have to do it manually 

Unfortunately, you'll need to do this manually.

Sadly, we've found this doesn't fix things for everyone, it's deeper rooted than just texture streaming, so there's more investigation and testing to do in order to deploy a complete solution to this issue.

Share this post


Link to post
Share on other sites
[BS4]
Players
1,165 posts
6,591 battles
24 minutes ago, iEarlGrey said:

Unfortunately, you'll need to do this manually.

Sadly, we've found this doesn't fix things for everyone, it's deeper rooted than just texture streaming, so there's more investigation and testing to do in order to deploy a complete solution to this issue.

Aplied this fix last week when @MrConway kindly delivered it to us in the previous fps thread. Happily this seems have solved the fps issue for me....however the SOUND still suffers from distortion and slows down when under heavy graphical load as it did before the fix....wich is weird? 

Is anyone else still suffering from sound issues after this fix has been Aplied?

 

Share this post


Link to post
Share on other sites
Players
69 posts
4,051 battles

So it didn't solved it for me, I still have a lot of issues when a lot of torpedoes are spotted, I even had some lags when I was dropping torps from Enterprise... It doesn't happen every game, but the more I play without restarting the game, the worst it gets. It seems to come when a lot of informations are displayed at the same time in game, also i had some sound issues with Atlanta when firing all main guns.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×