Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
Ronin_Cahill

Huge Issues with ships / graphics rendering

2 comments in this topic

Recommended Posts

[_CHN_]
Players
27 posts

So a friend got me into this game. its quite fun. I live in Canada and play in eurpoe as he is in that area. I get 500 ping so it may be the issue but when I zoom in nearly all the time the ships don't render as well as islands etc. so I need to zoom out see the target and quickly zoom and fire to have a chance OR just fire without zooming in..wow that's hard. None of the targets are in smoke etc. eg. a battleship at 5km disappears. I have a top end system and a 1080gtx ti 11gig card that likes dx 12, and a tech friend said the dx 11 may be the issue but hes not sure. He also suggested I get WOWS to migrate my account to the north American version as  I should have been on there first place. I thought this game was like any other and there was only 1 version so I could just click and go to that area and the occasional bad ping to Europe would not kill me. unless of course my issue isn't ping related. a confusing mess indeed but I do need help this is starting to kill me.

thanks

Ronin

Share this post


Link to post
Share on other sites
[ADRIA]
[ADRIA]
Players
4,945 posts
7,206 battles
18 minutes ago, Ronin_Cahill said:

So a friend got me into this game. its quite fun. I live in Canada and play in eurpoe as he is in that area. I get 500 ping so it may be the issue but when I zoom in nearly all the time the ships don't render as well as islands etc. so I need to zoom out see the target and quickly zoom and fire to have a chance OR just fire without zooming in..wow that's hard. None of the targets are in smoke etc. eg. a battleship at 5km disappears. I have a top end system and a 1080gtx ti 11gig card that likes dx 12, and a tech friend said the dx 11 may be the issue but hes not sure. He also suggested I get WOWS to migrate my account to the north American version as  I should have been on there first place. I thought this game was like any other and there was only 1 version so I could just click and go to that area and the occasional bad ping to Europe would not kill me. unless of course my issue isn't ping related. a confusing mess indeed but I do need help this is starting to kill me.

thanks

Ronin

Hmm, weird

I know a few Canadians who play on EU but their ping is quite reasonable, not 500 like yours...

 

Can you maybe share a replay of a game where this happens? You can find replays of your last games (30 by default) in your WoWS folder -> Replays folder

Typically it would be something like C:\Games\World_of_Warships\replays

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×