Jump to content
Sign in to follow this  
Sehales

World of Warships Premium Account

8 comments in this topic

Recommended Posts

[WG]
WG Staff, Alpha Tester
6,280 posts
2,062 battles

Captains,

 

please share your feedback about the WoWs Premium Account in this thread.

 

Detailed information about this feature can be found on the portal.

Share this post


Link to post
Share on other sites
[B0TS]
[B0TS]
Players
22 posts
18,321 battles

Does anyone know how the additional prem account works now?

Will my 56 days be extended by the warships prem after the wargaming prem expires?

Share this post


Link to post
Share on other sites
Players
5,061 posts
8,562 battles
8 hours ago, kingbright said:

Does anyone know how the additional prem account works now?

Will my 56 days be extended by the warships prem after the wargaming prem expires?

No, your 56 days of PA are now 56 days of WoWS PA

 

Your PA actually didn't disappear as both can and do run at the same time, but only the highest bonus is taken into account, not both of them

  • Cool 1

Share this post


Link to post
Share on other sites
[TIB]
Beta Tester
29 posts
9,541 battles

Seems to be a Problem with the Warships Premium account, at the time of the update I had 19 days premium, and won one extra day on the directive.

However when Looking at the ships in port this morning, they all still Show 50% xp Bonus for first win of the day, surely this should be 65% if it was upgraded to warships premium.

If this is a bug, would we be able to get the missing 15% xp and credits for all battles played since the update credited to the account.

Have just checked the battle results and the bonuses added  for daily win Bonus are showing as 50%.

Share this post


Link to post
Share on other sites
[WG]
WG Staff, Alpha Tester
3,347 posts
3,869 battles
1 hour ago, glorgir said:

Seems to be a Problem with the Warships Premium account, at the time of the update I had 19 days premium, and won one extra day on the directive.

However when Looking at the ships in port this morning, they all still Show 50% xp Bonus for first win of the day, surely this should be 65% if it was upgraded to warships premium.

If this is a bug, would we be able to get the missing 15% xp and credits for all battles played since the update credited to the account.

Have just checked the battle results and the bonuses added  for daily win Bonus are showing as 50%.

 

The daily win bonus is always 50% and not connected to the premium account. You will get the 65% bonus even after the first win.

  • Bad 1
  • Angry 1

Share this post


Link to post
Share on other sites
[TC_DK]
Players
1 post
10,494 battles
36 dakika önce, MrConway dedi:

 

Günlük kazanma bonusu her zaman% 50'dir ve premium hesaba bağlı değildir. İlk kazanmanın ardından% 65 bonus kazanacaksınız.

MrConway 'm writing because I'm writing to you because I'm writing badly I need your help I can talk to you about this issue

  • Boring 1
  • Bad 1

Share this post


Link to post
Share on other sites
[HOB]
Moderator
1,838 posts
7,825 battles

It is simply 10% more XP compared to Wargaming Premium.

There are 3 possiblities:

-No premium - 100%
-WG Premium - 150%

-WOWS Premium -165%

  • Funny 1

Share this post


Link to post
Share on other sites
Players
1 post
9,396 battles

Issue has now been successfully resolved by support  :cap_cool:

 

I'm somewhat confused..

 

As I understood it, any generic premium account time held as of 19th December would be converted into an equivalent amount of WOWs premium account on the release of the patch on 20th December?

 

The reason I ask;

 

I purchased an additional 360 days of premium account on the 19th December, unfortunately this wasn't included in the WOWs premium time when the patch went live the following day.

 

I raised a support ticket to adjust this & they added 360 days to my WOWs premium account (fantastic!) HOWEVER they then deducted 360 days from the generic premium account (not fantastic as I also regularly play WOT) - I'm now stuck in a frustrating loop of messaging support to explain the error to be told the issue has been resolved correctly :Smile_facepalm:

 

Have I misunderstood something here?

 

KT

Edited by Kaarlo_Tyr

Share this post


Link to post
Share on other sites
Sign in to follow this  

×