Jump to content
You need to play a total of 50 battles to post in this section.
albinbino

Low FPS and almost unplayable after last update. Anyone else?

28 comments in this topic

Recommended Posts

Players
662 posts
11,080 battles

Am I the only one who has problems after yesterday's update to play this game? Everything was fine before update, but since then it is almost unplayable with so low FPS, simply game does not run smoothly anymore for me, always delaying every action i make in the battle and breaking it.

Dont know what to do, played thousands and thousands of battles, but now i simply cannot play it anymore. And all just for that little update. I admit i dont have strong machine, that is why i always play on lowest settings possible, that is not problem for me, i got used it, but now i cannot go any lower.

2 years ago i made post here how i always fear when WG announces update, and so many times unfortunately my fear was justified. :Smile_sad:

Looks like will have to make long pause and wait for some future update that maybe will improve this situation for me.

Share this post


Link to post
Share on other sites
[H_FAN]
Players
2,728 posts
45,912 battles

Hve you cleaned your computer and reinstalled windows etc again? If you just update all the time the PC will become unplayable after some years.

But you do fulfil the requierements?

Share this post


Link to post
Share on other sites
Weekend Tester
1,128 posts
8,805 battles

Speaking of it, i noticed it as well. Although not as dramatic as yours going from avg 55 to an avg of 45 is something.

Share this post


Link to post
Share on other sites
Players
662 posts
11,080 battles
1 hour ago, Srle_Vigilante said:

Speaking of it, i noticed it as well. Although not as dramatic as yours going from avg 55 to an avg of 45 is something.

Well, mine FPS drop to 15 when shooting and torping start, and stays like that till end of battle, maybe even goes lower for some seconds. Prior to update i have been playign about 30 battles per day due to legendary upgrade grind and had no problems. But yesterday after i did the update, i wanted to contiue i realized i cant. Somehow played 3 battles, but horrible expiriance, tried this morning, the same. Everyting seems interrupted during the battle, shooting, torps travelling, ship traveling, even sound of events lags.

Cant play good, cant hit anything as i want, so i must stop playing in order my teams not to suffer because of me. 

I guess they did something to the game in last patch, something that players with strong machines cannot notice so easy, but for me with weaker machine it has drastic impact. 

 

Share this post


Link to post
Share on other sites
[-AP-]
Players
2,852 posts
6,905 battles
30 minutes ago, albinbino said:

Well, mine FPS drop to 15 when shooting and torping start, and stays like that till end of battle, maybe even goes lower for some seconds. Prior to update i have been playign about 30 battles per day due to legendary upgrade grind and had no problems. But yesterday after i did the update, i wanted to contiue i realized i cant. Somehow played 3 battles, but horrible expiriance, tried this morning, the same. Everyting seems interrupted during the battle, shooting, torps travelling, ship traveling, even sound of events lags.

Cant play good, cant hit anything as i want, so i must stop playing in order my teams not to suffer because of me. 

I guess they did something to the game in last patch, something that players with strong machines cannot notice so easy, but for me with weaker machine it has drastic impact. 

 

Can you list your pc specs please? Always helpful in these matters 

  • Cool 1

Share this post


Link to post
Share on other sites
[SERBS]
Alpha Tester, Players, In AlfaTesters
2,623 posts
9,595 battles

Nope

Share this post


Link to post
Share on other sites
Players
662 posts
11,080 battles
19 minutes ago, thiextar said:

Can you list your pc specs please? Always helpful in these matters 

Intel Core2 Quad 2.33GHz

4 G RAM, DDR 2

ATI RADEON 512 MB DD2 , 128bit 

And some simple hard disc of 400 G. 

 My net: ADLS 5 MBps/512 kbp

I am not now home to doublecheck, but this is it i am pretty much sure. 

Share this post


Link to post
Share on other sites
Players
295 posts
1,794 battles
4 minutes ago, albinbino said:

Intel Core2 Quad 2.33GHz

4 G RAM, DDR 2

ATI RADEON 512 MB DD2 , 128bit 

And some simple hard disc of 400 G. 

 My net: ADLS 5 MBps/512 kbp

I am not now home to doublecheck, but this is it i am pretty much sure. 

Seems that you are between the minimum and recommended system requirements. And possibly nearer to minimum than recommended (specually RAM, as it's stated as Active and not as total amount).

 

https://worldofwarships.eu/en/content/game/system-requirements/

 

Try to check the game video config as something could be changed on the last update and is messing with the game performance.

Share this post


Link to post
Share on other sites
Players
182 posts
3,092 battles

I have always had fps staying stable at the cap (was it 78 fps?) but last few patches I have seen fps drop to 50-60 and even though it is playable its still noticeable and feels weird :D

 

I don't think I have that overwolf thingy on my PC but their logo looks familiar, so I need to check that when I get home.

  • Cool 1

Share this post


Link to post
Share on other sites
[HALON]
Players
656 posts
10,981 battles
54 minutes ago, Vlad_Vado said:

Check if this can be your issue:

 

If not, try to do a fresh WoWs installation,

 

@MrConway

 

Reading this one thing came to mind.

 

Did you guys remember the ban wave that occurred in WOWS, two years ago i guess ?

 

In the end it came out that the vast mayority of them was caused by overlays and injectors ( reshade for examples ). 

 

I remember that some community manager said that it was wise to refrain from using them.

 

Did something changed in that regard ?

Share this post


Link to post
Share on other sites
Players
662 posts
11,080 battles
13 minutes ago, Vlad_Vado said:

Seems that you are between the minimum and recommended system requirements. And possibly nearer to minimum than recommended (specually RAM, as it's stated as Active and not as total amount).

 

12 minutes ago, Naesil said:

I have always had fps staying stable at the cap (was it 78 fps?) but last few patches I have seen fps drop to 50-60 and even though it is playable its still noticeable and feels weird :D

 

Well i think they did something in last patch that only people with weak machines (borderline sufficiant to play) such is mine can really notice that well.

I think WG must change thier game requirments description on home page, becouse what is mentioned there right now it does not fit reality, game in practice is more demanding than that.  :Smile-angry:

Share this post


Link to post
Share on other sites
[-AP-]
Players
2,852 posts
6,905 battles
1 hour ago, albinbino said:

Intel Core2 Quad 2.33GHz

4 G RAM, DDR 2

ATI RADEON 512 MB DD2 , 128bit 

And some simple hard disc of 400 G. 

 My net: ADLS 5 MBps/512 kbp

I am not now home to doublecheck, but this is it i am pretty much sure. 

Hmmm, one possible scenario:

 

You have only 4gb of ram, and 0,5 gb of gram. It is very possible that you were right on the limit of your ram usage back when the game was running smoothly, but now, with all the new stuff that has been added, your computer is running out of ram, and is therefore trying to use the hard drive as ram.

 

A possible solution to this scenario, and a general reducement in required performance to run this game, would be to try out a texture compression mod. This will reduce the load on the ram amongst other things

 

 

I would also recommend using black friday to rectify the core issue ;) You can see all the discounts on different computer parts using something like pricerunner :D

Share this post


Link to post
Share on other sites
[HALON]
Players
656 posts
10,981 battles
12 minutes ago, thiextar said:

 

A possible solution to this scenario, and a general reducement in required performance to run this game, would be to try out a texture compression mod. This will reduce the load on the ram amongst other things

 

 

Aslain mod collection has low quality texture mods for that.

Share this post


Link to post
Share on other sites
[WGB]
Community Contributor
2,150 posts
29,644 battles
6 hours ago, albinbino said:

Am I the only one who has problems after yesterday's update

I played for a couple of hours prime-time last night with lil Bro and had no problems with FPS, only probs I did have, was trying to explain why its best not to sit in my smoke beside my Kamikaze with his BB. :cap_fainting:

Share this post


Link to post
Share on other sites
[WG]
WG Staff, Alpha Tester
3,376 posts
4,011 battles
23 hours ago, Amon_ITA said:

 

@MrConway

 

Reading this one thing came to mind.

 

Did you guys remember the ban wave that occurred in WOWS, two years ago i guess ?

 

In the end it came out that the vast mayority of them was caused by overlays and injectors ( reshade for examples ). 

 

I remember that some community manager said that it was wise to refrain from using them.

 

Did something changed in that regard ?

 

Unfortunately not, we still cannot allow usage of those kind of modifications as their base functions could also be used to inject unwanted things into the game.

 

So please do keep on refraining :)

Share this post


Link to post
Share on other sites
[LUXX]
[LUXX]
Players
79 posts
13,095 battles

i can confirm this FPS drops. Allways "had" 95-160FPS, now with  my system down to FU 40fps.... wtf is wargaming doing. the only change on my system is wows update and fu Windows 10 update.....

Share this post


Link to post
Share on other sites
[-AP-]
Players
2,852 posts
6,905 battles
1 hour ago, THEBUFUMAN said:

i can confirm this FPS drops. Allways "had" 95-160FPS, now with  my system down to FU 40fps.... wtf is wargaming doing. the only change on my system is wows update and fu Windows 10 update.....

what are your pc specs?

Share this post


Link to post
Share on other sites
[UNICS]
Players
1,452 posts
22,675 battles

I have i-3 + 2gb graphics card + 4gb ram, Quad CPU 3.2ghz , im noticing some fps drops, and sometimes struggle to load in game , but i think its ram issue.. 

 

And why does 3 processes  (cef_browser_process.exe) open up if you go to arsenal (something not right with your arsenal browser)

Share this post


Link to post
Share on other sites
[-AP-]
Players
2,852 posts
6,905 battles
6 minutes ago, Ysterpyp said:

I have i-3 + 2gb graphics card + 4gb ram, Quad CPU 3.2ghz , im noticing some fps drops, and somethimes struggle to load in game , but i think its ram issue.. 

 

And why does 3 processes  (cef_browser_process.exe) open up if you go to arsenal (something not right with your arsenal browser)

Yeah, the recurring theme for people who has experienced fps drops lately seems to be a lack of ram. Not much wargaming can do about this except for stop adding ships, but then again, you cant halt the entire development process of the game just to support the bottom range of computers.

 

Anyhow, anyone who has experienced fps issues should try the texture compression mod that is included in aslains modpack, it should lower the amount of ram needed by reducing the quality of the loaded textures.

 

Also it is quite common for programs and games to open more than one process, see it as a distribution of labour / a way to keep the code cleaner and more tangible by splitting it up.

Share this post


Link to post
Share on other sites
[UNICS]
Players
1,452 posts
22,675 battles
44 minutes ago, thiextar said:

Yeah, the recurring theme for people who has experienced fps drops lately seems to be a lack of ram. Not much wargaming can do about this except for stop adding ships

Well there are 24 ships in a match, that doesn't change, so they can add ships as they please it would not affect ram 

 

The textures affects rams.. and added feature in-match, not ships it stays the same unless they add fancy pants cammos like the mogami octopus( This can be disabled, the octopus is one extra mesh in the game with added animation)
 

But i would upgrade my gpu on this pc , it would be all i need 

 

 

 

Share this post


Link to post
Share on other sites
[-AP-]
Players
2,852 posts
6,905 battles
28 minutes ago, Ysterpyp said:

Well there are 24 ships in a match, that doesn't change, so they can add ships as they please it would not affect ram 

 

The textures affects rams.. and added feature in-match, not ships it stays the same unless they add fancy pants cammos like the mogami octopus( This can be disabled, the octopus is one extra mesh in the game with added animation)
 

But i would upgrade my gpu on this pc , it would be all i need 

 

 

 

The amount of ships in a match doesnt necessarily increase ram usage, as any two ships of the same type, can share the same 3d model/texture loaded on the ram, but the amount of unique ships will increase ram usage. And the more unique ships there are in the game, the more unique ships there will be in a battle, these 3d models takes up a lot of memory.

 

Also, when it comes to upgrading your pc, i really dont think just upgrading the gpu will do you any good. 4gb of ram is absolutely tiny, and that cpu of yours is also very very weak.

It wouldnt make sense to upgrade the gpu to anything less than a 1070 at this point, as cheaping out now only means that you will have to upgrade it again much sooner, and quite frankly, your pc will only be able to utilize a tiny amount of a new gpu:s capabilities, as both your cpu and ram would cause a bottleneck.

 

I would recommend going for a full upgrade:

 

upgrading the motherboard(since your current one will have an old socket, and wont support any decent cpus, and also to be able to use ddr4 ram)

upgrading the cpu to something close to the performance of an i5 9600k

upgrading the gpu to something close to the performance of a 1070

upgrading your ram to 16gb of ddr4, make sure to use both channels on the motherboard

buying a cheap third party cpu cooler, because stock coolers are garbage.

buying an ssd for windows if you dont already have that, makes a world of difference speedwise

 

There isnt really a single part in your current setup that you can keep when upgrading your computer, because anything you keep, will just cause a massive bottleneck, i guess you can keep the chassis :)

 

Share this post


Link to post
Share on other sites
Players
204 posts

I would urge anyone struggling with FPS issues to check their power settings and make sure they are set to 'high performance' or similar.  I had dismissed this as a possibility with my PC because I assumed Windows would never use crippling settings for a desktop system to save power - but I was wrong. Maybe a Windows update has changed your power settings?

Share this post


Link to post
Share on other sites
Players
632 posts
4,964 battles
On 11/13/2018 at 10:09 AM, albinbino said:

Intel Core2 Quad 2.33GHz

4 G RAM, DDR 2

ATI RADEON 512 MB DD2 , 128bit 

And some simple hard disc of 400 G. 

 My net: ADLS 5 MBps/512 kbp

I am not now home to doublecheck, but this is it i am pretty much sure. 

there's your problem. upgrade your potato.

Share this post


Link to post
Share on other sites

×