Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
MrFingers

Random day of Premium credited?

12 comments in this topic

Recommended Posts

[HOO]
Beta Tester, Players, In AlfaTesters
2,392 posts

It turns out I have 18 hrs of Premium account running, so it started with the server reset. I didn't buy a day of premium, nor did I achieve 5 stars in an operation, and my reward for reaching Rank16 also has been credited a while ago, so... what gives? 

 

 

Share this post


Link to post
Share on other sites
[SCRUB]
Players
8,460 posts
11,264 battles

Could be the compensation for that one server hick-up we had two weeks ago (only thing that comes to mind). But if that were the case, I'd be asking myself why it took them this long ...

Share this post


Link to post
Share on other sites
[HOO]
Beta Tester, Players, In AlfaTesters
2,392 posts

@Benjyboy12, did you participate in the video contest of August and didn't get your crates? The one with the #my_WoWS_story.

Share this post


Link to post
Share on other sites
[NWP]
Beta Tester, Players
1,771 posts
5,007 battles

Exlusive peek through the glass door to WG transparency department:
image.png.f036412e9dbf62c90911381ad27198ea.png

  • Cool 2
  • Funny 4

Share this post


Link to post
Share on other sites
[BONUS]
Beta Tester
30 posts
19,421 battles
18 minutes ago, MrFingers said:

@Benjyboy12, did you participate in the video contest of August and didn't get your crates? The one with the #my_WoWS_story.

No, have had all my public test rewards and entered no contest's

Share this post


Link to post
Share on other sites
[HOO]
Beta Tester, Players, In AlfaTesters
2,392 posts
2 hours ago, Aotearas said:

Could be the compensation for that one server hick-up we had two weeks ago (only thing that comes to mind). But if that were the case, I'd be asking myself why it took them this long ...

I was thinking the same, but no. That’s another day of premium one has to manually redeem on the user-bonuses website. I still have that day there.

Share this post


Link to post
Share on other sites
[WG-EU]
[WG-EU]
WG Staff, Alpha Tester
2,701 posts
2,666 battles
6 hours ago, MrFingers said:

It turns out I have 18 hrs of Premium account running, so it started with the server reset. I didn't buy a day of premium, nor did I achieve 5 stars in an operation, and my reward for reaching Rank16 also has been credited a while ago, so... what gives? 

 

 

 

I was intrigued and checked :)

 

It appears that you had an outstanding day of premium time for some server compensation in World of Tanks ages ago. Due to the addition of the new Polish tier 1 tank your account was synchronized and the outstanding day added.

 

In conclusion:

Image result for bank error in your favor

 

:cap_like:

  • Cool 2
  • Funny 3

Share this post


Link to post
Share on other sites
[HOO]
Beta Tester, Players, In AlfaTesters
2,392 posts

Thanks for the insight Conway! Hurray for our tanker brothers (even with their premium ammo)!

Share this post


Link to post
Share on other sites
[BONUS]
Beta Tester
30 posts
19,421 battles
1 hour ago, MrConway said:

 

I was intrigued and checked :)

 

It appears that you had an outstanding day of premium time for some server compensation in World of Tanks ages ago. Due to the addition of the new Polish tier 1 tank your account was synchronized and the outstanding day added.

 

In conclusion:

Image result for bank error in your favor

 

:cap_like:

Thanks for giving us the reason why some received  a days premium today, not played WOT for a while now but never going to say no to a freebie.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×