Jump to content
You need to play a total of 50 battles to post in this section.
Reaper_JackGBR

Fix the game breaking bugs already

10 comments in this topic

Recommended Posts

[SCRUB]
Players
817 posts
7,098 battles

Now first off, I'm not making a bug report, because obviously those are either ignored or the bugs we report are not given a high priority, as the bugs I'm about to talk about have been present for months or maybe even years. 

 

So what happened? I was merrily driving along in my DD, about to grab a cap, and suddenly a DD pops up for me to shoot, no biggy, he smokes, I drop torps and turn away. Normal right? DD pops up again as my torp hits him, weird I thought, his healthbar, name tag and ship icon don't appear, he's just a blank ship. Then about five seconds later my entire UI goes AWOL, everything freezes apart from ribbons, I panic press smoke and slow down, I see my ship smoking, but no smoke rings or smoke appearing on top of me, then my ship begins to drift away from my screen, as my camera has decided it doesn't want to follow anymore, all other ships on my screen are normal. Unable to get out of this bug, I try and restart my client quickly, my division mates informing me my panic smoke had been torped and I was dead. 

 

But was that the end of it? No. After dying as first blood because of a freaking bug, my load screen upon client restart gets stuck and I can't even get back into the game. I sit there for five minutes before finally rebooting my entire PC and finally getting back in game ten minutes later. 

 

Now this wouldn't be an issue, but a, we lost this game because I died so early from full health. And b, this happens in Clan battles and Ranked battles too, and in those modes, it decides games. Wargaming, if you want to ever be taken seriously as a competitive platform, you need to get rid of this crap. Already even in this season I can report at least ten games (about 8%) of our games where at least one of our players has suffered a bug forcing a client restart. It literally makes the difference between winning and losing. Fix it. 

  • Cool 3
  • Funny 1
  • Boring 2

Share this post


Link to post
Share on other sites
[SCRUB]
Players
2,590 posts
7,066 battles

Ive had certain disconnect the other week.

 

I got disconnected, check google ... worked .... I was what the hell WG. This happened several times per game session.

I reconnected and it worked again for 10 minutes then bam again.

 

Then I went to investigate.

While I did ping check to www.google.com i noticed certain packet losses.

Did the standard reboot, ipconfig /renew /flushdns, killed processes, etc etc ... but nothing helped. I could surf the net normally but still received packet loss while pinging google.

 

Finally I checked my router... all fine. Went on WIFI and ... wow no more packet loss.

 

Yes ... it was a faulty UTP cable. Replaced it and no more packet losses and WoWS disconnects :)

 

Why did I write this?

Because its not always servers fault.

many times its client fault ... the problem is just that you have to take time to investigate.

Im not saying its the same in your case, but in many cases it is.

 

Good luck.

Share this post


Link to post
Share on other sites
[TRAV]
[TRAV]
Players
2,398 posts
2 hours ago, Reaper_JackGBR said:

Now first off, I'm not making a bug report, because obviously those are either ignored or the bugs we report are not given a high priority, as the bugs I'm about to talk about have been present for months or maybe even years. 

 

So what happened? I was merrily driving along in my DD, about to grab a cap, and suddenly a DD pops up for me to shoot, no biggy, he smokes, I drop torps and turn away. Normal right? DD pops up again as my torp hits him, weird I thought, his healthbar, name tag and ship icon don't appear, he's just a blank ship. Then about five seconds later my entire UI goes AWOL, everything freezes apart from ribbons, I panic press smoke and slow down, I see my ship smoking, but no smoke rings or smoke appearing on top of me, then my ship begins to drift away from my screen, as my camera has decided it doesn't want to follow anymore, all other ships on my screen are normal. Unable to get out of this bug, I try and restart my client quickly, my division mates informing me my panic smoke had been torped and I was dead. 

 

But was that the end of it? No. After dying as first blood because of a freaking bug, my load screen upon client restart gets stuck and I can't even get back into the game. I sit there for five minutes before finally rebooting my entire PC and finally getting back in game ten minutes later. 

 

Now this wouldn't be an issue, but a, we lost this game because I died so early from full health. And b, this happens in Clan battles and Ranked battles too, and in those modes, it decides games. Wargaming, if you want to ever be taken seriously as a competitive platform, you need to get rid of this crap. Already even in this season I can report at least ten games (about 8%) of our games where at least one of our players has suffered a bug forcing a client restart. It literally makes the difference between winning and losing. Fix it. 

 

So did I get this right:

You believe that Wargaming is leaving gamebreaking bugs in the code deliberatly?

Why would they do that? What could motivate them to sabotage their own project, their own source of income?

 

The accusation makes no sense.

 

I have a few suggestions for you:

  1. Never believe that it can't be a problem on your end, or at one of the many providers along the way.
  2. Make sure to run a proper diagnosis on your own system before you submit a bug report
  3. Provide proper bug reports (see here for a "how to")
  4. Be patient. Bugfixing isn't done by waving a magic wand. It needs time to isolate the issue. Proper bug reports help a lot
  5. Rants like the quoted one above are not proper bug reports. Rants like this do not help to fix things

Share this post


Link to post
Share on other sites
[SCRUB]
Players
6,915 posts
9,129 battles

Yep, that's a nasty bug, had had it happen to me quite a while ago (a year or so) ... was fun watching my ship sailing away from my camera without me being able to do anything except waving it goodbye.

 

Share this post


Link to post
Share on other sites
[FDUSH]
Players
1,044 posts
6,183 battles

I keep reporting the silent plane bugs and the automatic waitpoints which happens since 7 or 8 versions ago and nobody does a EDIT about it.

Edited by Kampa1987
Vulgarism

Share this post


Link to post
Share on other sites
[SCRUB]
[SCRUB]
Players
1,335 posts
12,570 battles

Left CTRL+Left SHIFT+ Backspace. And watch your ship sail away from you. Feature not a bug. 

:Smile_teethhappy:

Spoiler

Kek

 

Share this post


Link to post
Share on other sites
[SCRUB]
Players
2,590 posts
7,066 battles

Tbh i never seen this one before. Gonna try out this new feature. ;)

Share this post


Link to post
Share on other sites
[B0TS]
Beta Tester
1,556 posts
4,803 battles

I know I am an 'old git' when it comes to some modern (aka youngster) communications, but what is with the use of 'already' in instances like this?

(Not trying to be  grammar nazi etc, just curious, is it language or is it actual 'usage')

Share this post


Link to post
Share on other sites
[SCRUB]
Players
817 posts
7,098 battles
9 hours ago, Egoleter said:

 

So did I get this right:

You believe that Wargaming is leaving gamebreaking bugs in the code deliberatly?

Why would they do that? What could motivate them to sabotage their own project, their own source of income?

 

The accusation makes no sense.

 

I have a few suggestions for you:

  1. Never believe that it can't be a problem on your end, or at one of the many providers along the way.
  2. Make sure to run a proper diagnosis on your own system before you submit a bug report
  3. Provide proper bug reports (see here for a "how to")
  4. Be patient. Bugfixing isn't done by waving a magic wand. It needs time to isolate the issue. Proper bug reports help a lot
  5. Rants like the quoted one above are not proper bug reports. Rants like this do not help to fix things

 

7 hours ago, Sargento_YO said:

I keep reporting the silent plane bugs and the automatic waitpoints which happens since 7 or 8 versions ago and nobody does a $hit about it.

 

Also, Wargaming has proven repeatedly that they love sabotaging their own source of income through repeated mistakes leading to a horrible player retention rate. Granted I wrote my rant while very ticked off, but that much is true, especially where there customer service department is concerned. 

 

5 hours ago, philjd said:

I know I am an 'old git' when it comes to some modern (aka youngster) communications, but what is with the use of 'already' in instances like this?

(Not trying to be  grammar nazi etc, just curious, is it language or is it actual 'usage')

 

I honestly am not too sure. I've always spoken this way since the 90's. Don't know what to tell you there bud. 

  • Cool 1

Share this post


Link to post
Share on other sites
[FDUSH]
Players
1,044 posts
6,183 battles

*edit

Edited by Mlddim
This post has been edited by the moderation team due to not being constructive.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×