Jump to content
  • 0
You need to play a total of 50 battles to post in this section.
nikogaming

How to login with wargaming account via steam?

3 comments in this topic

Question

[DKWS]
Players
1 post
2,108 battles

How do i login with my wargaming account via steam. After the update 0.7.6, i cant seem to login via my wargaming account on steam.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Beta Tester, In AlfaTesters
550 posts
8,474 battles

Q Can I use my Wargaming.net account?
A: Unfortunately, not. World of Warships wasn’t initially designed as a cross-platform project. That means that if you've played the game already you would want to keep using the original client. If you log in using Steam, you automatically create a new game account, which binds to your Steam account. Important note: all updates to the game installed using Steam client will also be downloaded and installed through Steam. Same is true for the original client: you can not update a Game Center or launcher installation through Steam and vice versa.
 

Taken from the WoWS Steam Edition discussion sections FAQ post.

https://steamcommunity.com/app/552990/discussions/0/1480982338949306284/

 

But this implies you never could log in with your WG.net account on Steam, so either this is incorrect or you weren't using your WG.net account in the first place (which might explain why you can't log in with it).

Share this post


Link to post
Share on other sites
  • 0
[PUPSI]
Players
6,983 posts
Vor 9 Stunden, Benser sagte:

But this implies you never could log in with your WG.net account on Steam, so either this is incorrect or you weren't using your WG.net account in the first place (which might explain why you can't log in with it).

there is a workaround to use the "steam version" of wows with your normal account (but of course without using any of the steam features like the steam wallet or steam achievements) by replacing a file. Of course you have to repeat this replacing after every update, perhaps the TO has forgot to do it after the update on 0.7.6.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×