Jump to content
  • 0
Sign in to follow this  
Axia

Black screen problem

6 comments in this topic

Question

[WFYG]
Beta Tester
265 posts
396 battles

Hello!

I have this problem when my screen goes black in the middle of battle and the computer gets into rest mode. I did the "check and repair" in Wargaming Game Center but it didnt work. 

 

My computer specs:

Processor

AMD Phenom(tm) II X6 1035T Processor

 

Video Card

AMD Radeon HD 5700 Series

 

RAM

6.0 GB

 

Operating System

Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
[AEP]
Alpha Tester
12 posts
2,558 battles

Somewhat similar problem. Also screen goes black in the middle of the battle, but the game not freezes. The Battle goes on (all sound still played properly), even cursor is active and visible (sometimes), but the whole screen is black. Cannot say if escape menu is active. Tried to click it blindly - without success. This also happened in port. In all cases, I had to restart the game - ctrl+alt+del and kill the process - other options don't work.

Share this post


Link to post
Share on other sites
  • 0
[SVX]
Beta Tester
432 posts
15,812 battles

Ive had the same problems for months now. Sometimes it happens every once in a couple of hours and some days many times a day.

 

The screen goes black (and a bit white in the middle). The game keeps running and I hear sound. I guess its a graphics problem? I need to restart the computer to do something.

 

I have the latest graphics drivers and tried different graphics settings.

 

 

Any hints on what can be done?

Share this post


Link to post
Share on other sites
  • 0
[DONAU]
Players
208 posts
1,927 battles
On 10/23/2018 at 9:13 AM, gbgroger said:

The screen goes black (and a bit white in the middle). The game keeps running and I hear sound

 I have the same problem since a week or so. Every other game runs smooths. All temps are good. Just the crashes and black screens in wows.

Share this post


Link to post
Share on other sites
  • 0
Beta Tester
403 posts
1,209 battles

Classical questions:

 

Did you try the "repair files" function in the launcher? Did you try to re-install the game? Do you use the most recent GPU drivers? If you do, have you tried reverting to an earlier version?

 

@Axia: by "goes into rest mode" you mean the computer shuts down?

Share this post


Link to post
Share on other sites
  • 0
[DONAU]
Players
208 posts
1,927 battles

The game worked fine for some weeks now, since I used the windowed mode as some WoT players suggested. This "fixed" the problem. So but now, since today my PC crashes every minute. Blackscreen, and goodbye.

 

Only in WoWs. Maybe the update that the client downloaded?!?!

 

Drivers are updated, and my other games work like a charm. WoT players also state similar problems, so I guess it is the game client itself.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×