Jump to content
Sign in to follow this  
You need to play a total of 50 battles to post in this section.
_DiscoDave_

Reinstalled game after months away and cannot remap keys.

7 comments in this topic

Recommended Posts

Players
8 posts

I am left-handed so remap my keyboard controls to the right hand of the keyboard. After remapping them, I click apply, go to game, and the keys are still at default! Tried it many times, and the same result. This does work fine in WoT, but WoWS is a no-go.

It use to work before, really struggling to understand why it is not working now?

Any help would be greatly appreciated.

 

P.S. I cannot use the WSAD keys, have tried many times. [Yes, us lefties are akward gits ;)]

Share this post


Link to post
Share on other sites
[THESO]
[THESO]
Moderator
3,720 posts
10,106 battles

wellcome to the update 7.xx xxx

They made it impossible to remap SOME of the keys.. not all..

It was a torture to adapt zooming something other than my right click..

It still is.. I want my rightclick.. back... I have no idea why I cant!

Share this post


Link to post
Share on other sites
[ROT8]
Players
2,730 posts

Also a lefty and have no problems remapping a fair few, arrows instead of WASD, consumables and HE AP to mouse keys (razer), torp spread to middle mouse button and 1 or 2 others. I can't really work out why you have a problem OP.

Share this post


Link to post
Share on other sites
[SCRUB]
Quality Poster
4,389 posts
15,273 battles

Hi all,

 

19 hours ago, _DiscoDave_ said:

I am left-handed so remap my keyboard controls to the right hand of the keyboard. After remapping them, I click apply, go to game, and the keys are still at default! Tried it many times, and the same result. This does work fine in WoT, but WoWS is a no-go.

It use to work before, really struggling to understand why it is not working now?

Any help would be greatly appreciated.

 

P.S. I cannot use the WSAD keys, have tried many times. [Yes, us lefties are akward gits ;)]

 

Have you reinstalled from the scratch or you used your old installation (together with already existing "preferences.xml" file)?

 

I suggest you try to BackUp and then delete the "preferences.xml" and start WoWs again (it would create brand new "preferences.xml") and then start editing the options...

 

 

Leo "Apollo11"

  • Cool 2

Share this post


Link to post
Share on other sites
Players
8 posts
1 hour ago, Leo_Apollo11 said:

Hi all,

 

 

Have you reinstalled from the scratch or you used your old installation (together with already existing "preferences.xml" file)?

 

I suggest you try to BackUp and then delete the "preferences.xml" and start WoWs again (it would create brand new "preferences.xml") and then start editing the options...

 

 

Leo "Apollo11"

Thats exactly what I done! Re-installed as new, but copied over an old pref.xml file! I had a feeling it was something simple i overlooked, but it never dawned on me it would be the pref. file.

 

Thank you very much!

  • Cool 1

Share this post


Link to post
Share on other sites
[KAKE]
Players
2,519 posts
5,938 battles
22 hours ago, _DiscoDave_ said:

[Yes, us lefties are akward gits ;)]

Pfft. Speak for yourself.

Share this post


Link to post
Share on other sites
Modder
4,866 posts
22,096 battles

Ramapping to any key could be done in command_mapping/preset_keyboard_1.xml extracted from /res_packages directory and then copied to mods. Some of in game keys are restricted but correcting that file works.

 

Other possibility is making game profile and remapping keys in keyboard utility, when it's avaible option. That way having no mouse with wheel i made PageUP/PageDown working again as zoom.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×